Hub update problem

I have no idea where or to whom to post this, so this looked like a good place to start. I told my Hub that was running VER: to update to Ver: and then I went to take a shower. Came back after about 15mins and it still said it was updating. Is there something I should check to see if the Hub is having an issue?

go to: http://[Your Hub IP]:8081/ and click Restore Previous Version. See if you have 125 there, if so click on it and then click Yes

1 Like

Thank you Chuck......

I don know what I was thinking.....I guess just used to 30yrs of IT support.
I wasn't really expecting a response this late. I tried to do the update again, when it appeared to fail again, I rebooted the Hub from the settings menu. This time when I did the updat, it appears to have worked.

Thanks for your response

FWIW, I too upgraded from .120 to .125, it went through the process, then when done told me I was still on .120 and an update was available. I ran the update again and it took on the 2nd try.

On my 3 hubs, 2 updated as expected first try... One required a reboot before it would update. Don't know why, never had to reboot it before updating before.

But, whatever, it worked in the end.

My C4 hub updated no problem. My C5 hub hung also on the updating so I had to go back to the settings page and reboot. After that, the update completed with no issue.

Is it just the C5 hub having this problem or is it the C4 hub also?

On mine, my two C4 updated correctly and my C5 required the reboot.

My hub is a C5

From this small sample, this problem appears to be with updates to a C5 hub. The C4 hubs appear to be updating without issue. @chuck.schwer

You tagged me, is there a question you have? We are aware of issues with cloud connectivity, that is why there was a hotfix, there are a number of threads ongoing about connection issues and it appears they have been solved by Cloud endpoints not working

I tagged you because I saw your reply (post #2) above. I also noted that this appears to affect C5 hubs so I was wanting to know if this was also your observation. Edit: My C4 and JasonJoel's C4 hubs did not have this issue.

Mine is a C5 and had the update issue also.

Mine was an original hub showing no updates available but after reboot was updateable.

I think this is now fixed ?

On the last 2 updates, my main C5 hub has updated fine. My remote (shed) C5 Hub indicated that it needed to be updated but when I started the update process it said that there was no update available. On both updates, I had to reboot the second hub before it would recognize that there was an update. After it went through the motions it appears that it is fine.

Tonight's update from to had the same issue. My C4 hub updated just fine. I started my C5 hub just before starting the C4 hub. The C4 hub updated and rebooted. The C5 hub is just sitting there stuck at "Applying update." I don't think this has anything to do with the cloud issue. Both downloaded the update and unpacked it just fine. The problem is that the C5 hub is stuck. In a moment, I will reboot it and try again.

Edit: After a reboot, the update for the C5 hub completed.

I had the same issue. My 2 C4 hubs updated with no problems but my C5 hub got stuck and I had to do it several times before it applied. This was with Tagging @bobbyD for his awareness.

Are you saying that when you updated from 120 to 125 you had this issue? If yes, then that is a known issue and fixed in 125. If no, then I'm confused because it appears that your hub is running 125 so it does not appear that you have upgraded to 127 yet.

It happened to me going TO 125.

If it has already been fixed, that's great (although it should show up in the release notes I think, too... If it was, and I missed it, I apologize in advance.).

It wasn't that big of a deal either way for me. Reboot, retry, done.

Ok, I have my wires crossed. If you have the issue of clicking update and the download finishes but the update never completes try switching to port 8081 and see if the update is available there to switch to. I believe I know what the issue is (the shutdown process hangs so the reboot doesn't complete) but it will require more testing on our end and will hopefully be fixed in 2.1.4.


That is exactly what happened to me on my C5 hub (all my C4s updated as expected). I did not try connecting to 8081, thanks for the tip on that. If it does it again, I'll try it.