Hub Drops Offline

Hopefully this is the correct location for this post. About every 7-10 days, my HE drops offline from my LAN. It still has the green light, but it is not showing up in my router and won't load on my web browser. I'm connected to a dd-wrt router with an ethernet cable and with address reservation. Cycling the power restarts the HE without any issue. I have 26 devices connected (10 WEMO and 16 z-wave). I also have Rebooter restarting the HE every 24 hours.

Reviewing the logs, I did see "No route to host (Host unreachable)" periodically, but not when the HE dropped offline. I'm assuming that it was still communicating with the z-wave devices while offline. If I were patient enough, hopefully it would recover the connection when it runs the Rebooter app at 3 AM.

When it restarts does it come back online OK? When it is offline can you still get to the diagnostics page on port 8081 or ping the router? I'm thinking if the answer to the first is yes and the 2nd two is no, it would point to a loss of connectivity rather than some UI/firmware thing. Have you tried turning on auto-reconnect under network settings? Might also be worth turning off auto-negotiate and fixing the port at 100mb.

What made you start rebooting every 24 hours? Just being proactive or were you addressing a specific issue?

2 Likes

Thanks for the helpful reply...

  • When I cycle the power, it comes back ok.
  • I did not try port 8081 when it was offline, but it didn't respond to pings.
  • I have NOT used auto reconnect. Thanks for this suggestion! :slightly_smiling_face: I should spend a little more time in the network settings! I just enabled auto reconnect with the default 30 second attempt. The next two weeks should let me know if this solved it or not!
  • Ethernet speed (and most other network settings) are still on default. I'll look at these settings if I still have problems.
  • The reason I installed the Rebooter app was because of the dropping offline.

If you have the Hub Information Driver loaded you might consider creating a rule to alert you if the IP address changes.

1 Like

Thanks! I'll load it and see what I can do with it!

Whats the upstream look like? is it a direct cable from HE to a switch or router or are there other devices involved? Is the ethernet running over/under anything?
I love to share a story about me troubleshooting a network years ago - and no one could solve it. I was standing on an upstairs area looking down over the clients office space - with a diag running in front of me... totally intermittent failure once or twice a day. Out of the corner of my eye I see a woman sit in her chair and the same instant - the network dropped.
Come to find out her ethernet (it was vampiric connectors on a coax back then) cable ran under her chair mat and one of the teeth of the mat was punching through the cable shorting it out! Anyways. Maybe you've got a pinched cable or something - I also once saw a cable that was damaged but the damage was inside the 4" of the wall it was penetrating... really tough to find that one too!

2 Likes

If you have jumbo frames turned on on your network switches, try turning it off. The hub is very sensitive to abnormal packet sizes, and that can cause the network interface to stop responding sometimes.

4 Likes

Also if it goes offline again you light look at the router's clients table and see if for some reason it shows up with a new IP. Was working with a guy a few days ago who had more than one DHCP server on his network (unbeknownst to him). That caused the hub's IP address to change depending on which server responded first.

3 Likes

After 6 days my Hubitat dropped offline again today. I just realized it, but it's been offline for 5 hours so far. I monitor my network with a Fing device, which tracks the MAC address and would give the IP address it was connected to. Fing also records the date/time it dropped offline, and the HE hasn't dropped offline for 6 days. This time I decided to leave the HE offline while I troubleshoot.

  • The HE still has a green light.
  • It doesn't respond to pings.
  • Z-wave devices don't seem to be communicating with the HE...I say this because a z-wave motion sensor is not turning on z-wave controlled lights. This was unexpected since I thought the z-wave network would still continue to function without an internet connection.
  • It's not connected under a different IP address.
  • I can't connect using port 8081 either.
  • I have enabled the auto reconnect with the default 30 second attempt.

My main router is a Linksys router (WRT3200ACM) running dd-wrt. The HE is connected to a wired/wireless access point, which is another Linksys router running dd-wrt and is not configured as a DHCP server. The AP is communicating with the LAN without any issues (via ethernet), and I rebooted the AP but still no connection with the HE. I think my next option at this point is to try connecting directly to the main router and not use the access point.

Try two things before that:

  1. Swap out the ethernet cable for one that is known to function.
  2. Try a different port on the access point (BTW, are the TX/RX lights lit up for the port the Hubitat is currently using on the AP? What about on the Hubitat?)

If the access point is also running dd-wrt lookup the ARP table for the Hubitat's MAC.

3 Likes

They will work without internet. So either the hub locked up, or the Zwave radio is offline for some reason.

2 Likes

This isn't a case of double-NATting, is it? I know you said the 2nd router had DHCP disabled but is it providing NATting?

1 Like
  • The Hubitat MAC address does not show up as an active client in the ARP table.
  • The cable tests good.
  • The router shows an ethernet connection with the HE (white T on the front panel), but the light isn't flickering to show any activity. I tried a different ethernet port, no changes.
  • I don't think I have any NAT conflicts, that's all handled by the main router.

It might be inconvenient, but maybe wait until @gopher.ny or @bobbyD another of the staff can look at your hub from the diagnostic tool before doing anything else. Along with that, I would send a PM to @support

If you do reboot or pull the plug or whatever, the evidence might be gone as to what caused this. Or maybe just seeing that support cannot contact the hub might be a clue as to what is going on.

2 Likes

Good suggestions, I hadn't thought about that. Now I'll need to remember to turn the lights off. :slightly_smiling_face:

Can you PM me your hub's id? I'll take a look at the engineering logs on the hub, they may have some clues.

1 Like

Thanks for looking into this. I also have a request open with Hubitat Support. They said to temporarily disable all WEMO devices, apps, and drivers to see if the problem is related to these devices. I have some disabled and am replacing others with z-wave devices and hope to have this done in a week or so.

Update: I removed the last of my WEMO devices 4 weeks ago and disabled the WEMO devices, apps, and drivers as per Hubitat Support. This worked, I haven't had any problems since.

4 Likes

I have come to hate IP based devices, at least in the space of HE. They always caused me problems in 1 form or another.

I dunno. I used to feel that way, but over the last few months, I've added ~10 LIFX bulbs and 8 TP-Link Kasa outlets. Everything seems to be ok. Of course, all of these are directly accessed within the LAN - no cloud involved.

Download the Hubitat app