Hub Drops Offline

Interesting. Thanks for the feedback. What's your zigbee/z-wave devices counts look like? I wonder if it could be that only certain combinations of devices have issues..

My WiFi devices are all on my zigbee hub. I’ve got about 45 zigbee devices, 70 virtual devices, and 18 WiFi devices on it.

Personally, I think that the rate limiting step with WiFi devices is having a solid WiFi mesh network.

Was a cause or solution found? Reading all these posts it sounds as if i could have written them. Hubitat light is on. Port is showing blinking lights. The router software shows HE offline. This is an escalation of rules that were working, not triggering as seen in the logs. Power cycling HE makes it accessible even if it chooses on its own which rules it wants to activate. As in one room the lights get triggered but the room right next to it will have motion trigger but lights stay off as the rule doesn't activate in the log. I’ve pkayed around with cloning a working rule, change the sensor and light, and it doesn’t work. Driving me bonkers. Sadly i might need to go back to smartthings as i believe I’ve reported this before and don’t recall a response.

Not sure I recall your previous posts but happy to help try to figure it out. Sounds like you have a couple issues - the first is it drops from the network and the second is rules not working as expected. Do I have this right?

Let's tackle the network one first since we kinda need that stable to diagnose the second. If you can get to the UI you might try a couple of things under network setup. If your speed is auto-negotiate try setting it to fixed 100mbps. And try turning on DHCP auto reconnect. Mine is set for 30 seconds (though it has never disconnected).

1 Like

What @brad5 said, but I would, add do you have a dhcp reservation for the hub, are you on the latest firmware and z-wave stack. Also do you have a vlan(s) in place?


Did you submit a help request to support, or just here on the forums? While staff often is on these forums, they don't read every post. The support email is a valuable step in getting help. .

My Hubitat has dropped off line three times in the last month. Same thing where the green light is on but it doesn't communicate with my LAN or any devices. This AFTER I removed WEMO devices and disabled WEMO apps. I currently have 43 devices, 27 z-wave and the rest virtual. It just recently started again.

As soon as I restart the HE with a power cycle, I get a CPU temperature high warning set to alert me when the CPU temp exceeds 120 F. It's like the code somehow gets locked in an infinite loop. I couldn't find anything notable on the logs.

I'm going to try selectively disabling various apps and devices, one at a time starting with the most recently added ones, to see if I can figure out which one it is.

Can you try downloading the latest 2.3.1 and enabling DHCP network reconnect from Settings - Network Setup? I assume you're using DHCP here.

You're right, hot hub likely indicates that some apps or devices are trying to reconnect repeatedly without any sleep between reconnect attempts.


I just upgraded to the latest version, I have been running up until now. I have DHCP and network reconnect was already enabled. I'll hold off on any troubleshooting for a week and see how the latest update works.


Have you looked at app stats and device stats (on the logs page) to see if there might be some clues there?


Great suggestion tony.fleisher, I found two suspicious devices that seemed to take more processor time than the others. One is hub information, which gathers data on up time, CPU temp, etc. The other device was a test device I made in an attempt to gather a list of historical data to display on my dashboard, and then I forgot about the device. The date the test device was made was just prior to the hub dropping off line again...I disabled it. I'll see how it works out.

Did you also upgrade your Z-Wave Firmware?

There is a button at the top-left on the Z-Wave Details page "Firmware Update" button (with these buttons) image that is only visible if there is a separate Z-Wave Firmware update. If you haven't applied that yet, you should also do so.

1 Like

Thank-you, I was not aware of that. I just applied the Z-Wave updates.

Another reason a hub can lock up is a corrupted database. To ensure it's clean do the following

1: Go to settings>>backup and restore and click the DOWNLOAD button at the bottom and save it to your PC. (The database is cleaned when downloading)

2: Goto yourhubip:8081 and do a SOFT RESET. Upon reboot you can restore and use the database you saved on your PC.

3: For giggles after restoring, shut down your hub from the settings menu and then unplug at the wall (not the hub) for 5 mins and then power back up. This will clear your z-wave radio.

See how things behave


It will take a while, and for some users may take a few tries.

If you have problems the first time:

  1. Restart hub
  2. Go to Z-Wave Details page
  3. Wait for 10 minutes (When you launch that page a bunch of messaging happens, waiting allows all things Z-wave to settle down berfore trying the udpate)
  4. Start the update

You should have no problems, but a small % of users had issues applying the update that waiting resolved.


Foolish outlook junking all these email responses…

Dhcp is reserved
It’s set to 100mb

Uptodate. I don’t think i have a vlan set up

Did you do the soft reset?

You would know if you did. It's non-trivial.


My HE froze up again two days ago. I'm trying not to make too many changes at one time with the hope of isolating the problem. I have a Raspberry Pi set up to text me if the HE drops offline, and I'm using an old WEMO device to remotely cycle the power if needed. I have previously updated z-wave firmware.

  1. I did locate a device, Minoston Mini Power Meter Plug, that was reporting power up to three times per second. I had it set to report data every minute, but it was ignoring that setting, so I replaced it with a Zooz Neo Energy Monitor with much better results. I'll reset the Minoston and try it out again in the future.

  2. Then I followed the helpful advice from rlithgow1, below. I'll see how this works out. :crossed_fingers: :slightly_smiling_face:

Download the Hubitat app