How To: Remove Ghosts using hub tools or a UZB Stick

@bcopeland recently told me that it's best to use Select Learn Mode>NWI when adding your UZB stick to the hub from PC Controller. May not matter in the case of your error, but worth trying that. I've updated the instructions a week or so ago and noted in the OP about the update, but it's probably not obvious enough.

Glad you got connected.

I was recently using my UZB stick and had a case where I connected the UZB stick to HE but only got a partial device list. Disconnected and reconnected and got the full list.

1 Like

Sorry to hear that, I've never experienced that issue, and don't remember others mentioning it.

So why is that? - just curious :thinking:

I've been using CLM for a while without issue but would prefer to standardize on the recommended way if possible...

I've just tried with "Select learn mode" then NWI and got exactly the same result I'm afraid.
Seems to have included - it shows up in the HE page as "initialising...." but then sits there for ever (it's taken a LONG time in the past, so I left it 5 mins).
When you go to the Z wave details page it's there with security "none", but hitting "discover" does nothing - the log shows the dreaded "Z-Wave Network responded with Busy message."
Rebooted the HE, but still the same...

I note in Z wave PC controller that the include reports:
22:56:31.053 Learn mode Added (Security Failed) completed in 00:00:52.486

Could the security failing be an issue? note that I've still not been able to change the region in the PC controller, and I'm guessing that it's set to US - not sure what the consequences are of that.
Note that I'm using a C7 HE here - in the doc, I think that @bcopeland 's comment "Just include your Z-stick and when it comes to the DSK portion
click "skip" so it gets no security… If the z-stick has no security, it cannot include with security." may be referring to the C5 hub which I think I've read would prompt for security settings?
Could this be anything to do with it?
Has anyone done this with a C7 - surely they have.... I've tried this 3 times now with identical results (BTW I do see all my Z wave nodes on the PC)
In the HE logs I see "discovery running", I do not see anything saying it's stopped, though the timer has expired.
When I click "discover" for the "SPECIFIC_TYPE_PC_CONTROLLER" showing in Z wave details on the HE, I again get "Z-Wave Network responded with Busy message."

It's late, I'm stopping for tonight & won't be able to progress till monday, though I'll read any comments - it feels like I'm so close.....

Using the secondary controller/stick you cannot include S2 devices with S2 security..

You can include the stick either with or without security - it will still be able to add non-secure devices as Bryan mentioned and also remove any faulty device on HE via the "Is Failed" / "Remove Failed" route including S2 devices.

Words from the wise below:

1 Like

I recently reported this issue - UZB stick not completing joining/creating a device when joining the hub...HE staff Z-Wave guru replied:

So it's aparently nothing to sweat over. Just as long as it shows up in your Z-Wave details (example below) you should be fine, it will do it's work from the PC Controller app, of course as long as you see your Z-wave devices/nodes in the PC Controller app. If you don't see them, unpair and try again.

So evidently a "nothing to see, move along folks" situation. :slight_smile:

BTW - I'm going to update the doc w/the info about not worring about the UZB stick getting a device assigned to it so hopefully this won't trip up others.


Yeah I noticed that happening sometimes - could see the devices populating in the Controller Sw but not showing up in HE directly. It worked so assumed it was fine, good to get confirmation though. Thanks!!!!

1 Like

This is nothing to be worried about though. It was my laptop which was causing it. Tested another one and it works just like that.
I'm still waiting my usb stick to arrive..

Ok. So now I'm at the point where usb stick is recognized:
..just an usb serial device.

If I got it right I should now change driver fro the device and then there is different possibilities:





Which one should I choose. Stick was not automatically detected as silicone labs CP210. Device hardware type is: ZMEEUZB. Box says it's ZME USB1 transceiver.

Ok got it. I did not need to change driver. Original driver was perfectly fine.
Managed to remove ghost device. There was issues when removing uzb stick. After all I just removed it from hubitat z wave page after clicking refresh. Thanks for the instructions!!!!!!


Yup - you should not need to change drivers, and glad you got things going (or got things like the ghosts) to go away. :slight_smile:

Thanks! More useful info.
The stick is including to the extent that I can see it in the z wave details list, though not the devices list. It seems this may well be fine...
I am seeing all of the devices in my z wave mesh via the PC.
I can add a new device via the PC.
Buy I can't make that appear in HE - I've tried clicking update...
I've tried this 3 times, including rebooting both hub and restarting the PC app...
Anyone got anything else I can try?



I have never done this but I wonder if you could create a virtual device, change the DNI to the Node ID (in hex) and then change the driver to whatever your device is..

You might also try going into Z-Wave pairing mode and see if that pops up anything. Rebooting usually did the trick for me..

This might apply to your situation...from the FAQ:

1 Like

I have been playing around with this with a UZB-7 and Zooz V4 Zen23.

Pairing the uzb-7 via NWI seems to not show up in the devices vs doing it the Classic way.. not sure why that is but it definitely can make it more painful when trying to remove.

Can also confirm the "update" works great too - just paired the Zen23 with no security via the PC Controller sw, hit the update button and everything appears to be groovy (bad pun, sorry) on the HE side..

edit: mmmm I wonder if hitting update when pairing with NWI helps?

1 Like

I'm away till Monday night, and will try again then, pairing both ways, but I'm pretty sure I hit update after including the new device...

1 Like

IF you pair NWI I'm suggesting maybe hit update right after that way it might show up in devices in HE. The only reason that is important is you might inadvertently create a ghost node with your z-stick and trying to remove it would be a real pain..

Just happened to me during testing but fortunately had another stick on hand so was able to remove the first one.. ... stickception


Wonder if @bcopeland has seen that (UZB stick ghost) before?

I would think a UZB ghost could be removed from HE as long as you killed power to the stick (remove from PC, or if battery powered, remove battery) and run a Remove from HE. Did you try that and it didn't work?

So I actually did it both ways - I was testing pairing with security/no security etc etc.. to be clear I was messing around with things so it was not a normal thing to happen. I ended up with 2 secondary controllers listed in the PC Controller SW and nothing in HE. Removed via "is fail/remove failed" using the 2nd stick.

The other time it happened, I did what you said - unplugged it and then hit refresh a bunch of times, tried repair, discover etc etc.. eventually it came up with a "remove" and that seemed to work. The issue is you could get stuck if not careful.

A BIG part of the problem is my lack of patience.. these things run a lot slower than I want so I tend to push which does not help the situation at all.