How To: Remove Ghosts using hub tools or a UZB Stick

As long as the devices populated in SS/PC controller then you are good.. I think if you reboot your hub you might see a "device" device appear. In terms of ghost nodes - look for devices without any in and out data under Clusters, then use the number between the parenthesis () in the Node column to match with the "Id" column in the PC Controller sw...


thanks for the quick response. i tried again, this time with select learn mode smart start - same behavior - never "finishes" on the HE side:

Screen Shot 2021-08-30 at 1.28.50 PM

It DOES populate devices in SS?PC:

Even after reboot of HE - I'm at 253 devices... run the exclusion and here's the log

Screen Shot 2021-08-30 at 1.45.25 PM

It never ends up as a manageable device in HE - very weird. Just tried factory reset of the z-stick - not sure that will help.

It will never be a usable device in the HE UI so don't worry about that you won't do anything with it. If the device list is showing up then it should be okay I think.

Okay, now off to ghost hunting - which was NOT the reason I even installed this - have a Zen17 coming this week and want to be able to set settings and upgrade - and on C5 I hear it's better from SS/PC - maybe.

1 Like

I have a Zen17 but have not paired it with anything yet so can't comment on that aspect.

My C-5 is Zigbee only but for giggles I turned on Z-Wave and paired a Z-Stick Gen 5 (non +).. It did the same thing as you experienced... no device popped up but the device list was there in my case just the hub and the z-stick. I think you should be okay even if it does not show up. Exclusion was the same as well..

Well that was cool test - thanks!

Here's another interesting tidbit - each time I pair the stick it increments the device ID - was B0, now is B5.

I am SUCH a geek {wife nods in agreement}

Yep I think thats normal. It will wrap around again once it gets high enough. Just to be on the safe side I re-paired my stick and it did the same showed up as 19.. but there were no other devices so the stick itself did not cause a ghost.

This may be "normal" but it looks weird. All my ZWave devices have one or more "in" addresses - but most of them have no "out" - here's a small sample:

I am suspicious my stick HAS ghosts - but catch 22 - can't find the ghosts with a clone of the ghost.

Can you control a device like a switch in the PC Controller SW? Highlight the device and try "Basic Set On/Off"?


Cool then the secondary controller bit is working and you know that device you toggled is too! Unfortunately I don't know enough to say anything smart about the clusters.. only that clusters has been removed from the Z-Wave details from 2.2.28 and forward..

So what make's you think you have ghosts?

Nothing in particular - was just looking for app to connect my zstick so i can do OTA and set params - but THE guide seems to be this one and i have had ghosts in the past - so thought i'd look for them again - didn't find anything (other than the odd behavior of adding the stick). Maybe the solution is to pair the stick with the network BEFORE connecting it to the PC?

Back to something you said earlier - no zwave on your C5... did you migrate all your zwave and keep the zigbee on the C5? i just ordered a C7 and realize i have 53 zigbee devices i will have to figure out how to re-pair.

I left the Zigbee on my C-5 because the radio is the same as the C-7. C-7 was for the Z-wave stuff to take advantage of the 700 series chip...

Migrating ZW isn't such a big deal as the device database is not stored on radio but on the hub so a simple backup old hub/restore on new one works - you might have to kick each device into pairing mode but thats it. Should pop up and be recognized.

Heres a post by Bruce about migrating if not using the subscription service:

Yeah, i saw that one - then I was thinking i'd use Hub Protect - then I thought about just keeping the C5 and migrating ZW devices to C7 - now I'm not sure which way I'm going.

I like having separate hubs - less overhead on both. You can share devices using HubMesh for rules and such.

I'm trying to et this going to do includes with no security instead of S0 on a C7 HE.
I thought I'd add some extra info as I struggle through.
1/ in Simplicity Studio, you MUST login before installing the Z wave tools, otherwise it will only do a partial install.
2/ I found it would not accept my login - it worked for downloading, but when I tried to log out of the profile in the browser and back in it failed. I had to create a whole new account in the browser with a different email, that then worked in the IDE.

I'm now at the point where I've got the stick (Aeotec Gen5 not Gen5+) showing in SImplicity studio, but it won't pair with the HE.
I'm within a foot of the hub, I'm clicking "start Z Wave inclusion" in the HE, and "Classic Learn Mode" in Simp Studio...

hmm- went back in to settings and noticed that the "version" was not showing, did a "detect", and then tried classic learn mode again and it worked!

It's not showing in the HE Device list, but it is showing in the Z Wave Details list.
Clicking Discover there has no effect.
Importantly for me, it shows in that list as security "none".
all of the nodes on my Z wave network do show in the PC IDE....

I cant login to simplicity. Tested to create new account like you said but that did not help either. Found ini file modification too, that did not help.

arg - I feel your pain - I'm maybe an hour ahead of you.
Test the account you're using by logging out and in again here:

using the little person icon top right - if the account doesn't work there, it won't work in the IDE

Both of my accounts works when logging in with browser but no go with software..