GE Z-Wave Plus Smart Switch not updating status when physical button is pressed

It’s currently on Generic Z-Wave Smart Switch which was the last driver I used before I posted

I also just hit configure and saved and still no status change

Thing is, I was involved with the founders of Hubitat and started the Hubitat FB group that is now their official group since shortly afterwards the first year, so I’m definitely familiar with all of this. Again, they used to work fine till the c7 upgrade last year. Then I just kept ignoring the issue. Now I just want to get it solved. I pulled the switch to verify the exact model. GE ZW4001

Might be a firmware update available that helps..?

It seems to be pre Z-wave plus and supposedly, according to the thread below, they were hit or miss on whether they reported on physical. @jasonjoel would know. :slight_smile:

1 Like

Sounds like Z-Wave+ to me, but the behaviour would make non-plus such an obvious easy answer.

Just for fun, could you post the data from the device page? Or just check that you have 0x5E as shown?



It’s 0x25 actually

only 0x25, or is 0x5E listed anywhere in that list (I'm not positive they're listed in the same order for all devices). 0x5E signifies Zwave Plus.


Here’s the whole string:

  • inClusters: 0x25,0x27,0x73,0x70,0x86,0x72,0x77

This would indicate it is an old Z-Wave switch, not Z-Wave+. Can't explain why you saw a Z-Wave+ logo on it (should be on the back, not the side).

Anyway, best solution would be to replace with a newer switch, like the Zooz ones you've been adding. As a temporary fix, search these forums for "Z-Wave poller ". Maybe you had installed that on your old hub and just forgot?

1 Like

If you provide the entire "data" section, I can look it up and find out the exact specs. deviceId, deviceType, and manufacturer. Instead of all this guessing.


Hi, I hadn't installed anything special for the 2 GE switches. They just worked. Over the years with Habitat, and working with my friend Eric from Innovelli, I've definitely had my fair share of customer drivers though. lol

Hi Jtp,

Sorry, no one had asked that. Here's that info, thanks for your help:

  • deviceId: 13619
  • deviceType: 21079
  • firmwareVersion: 3.25
  • hardwareVersion: null
  • inClusters: 0x25,0x27,0x73,0x70,0x86,0x72,0x77
  • manufacturer: 99
  • protocolVersion: 3.40
1 Like

It is a GE 45609 / ZW4001: Z-Wave JS Config DB Browser

Here is another thread talking about them, indicating they are non-plus: Polled z-wave switches showing "failed: true", won't update status - #7 by kharrison

I think you should use the "Generic Z-Wave Switch" and set them up in the Z-Wave Polling app.


Thanks Jtp. I'll give that a go. I've got probably 35 smart switches and many of these GEs (which most are now Zooz), have been solid, so I've been reluctant to change them. Also exercises less waste, thanks for your help.

The Z-Wave Poller doesn't see, but 3 z-wave devices out of 50ish, and more importantly, that includes the two GE smart switches. I've used polling in Rule Machine, but first time for this app. Maybe I'm missing something?

Does the same thing, you can do it in RM if you want. The polling app is only supposed to show the non-plus devices.

Yeah, I figured it must only be showing non plus, but then those GE switches should be there, after proving they’re non plus

After you switch them (no pun intended) to the Generic Z-Wave Switch driver, they should show up in the polling app.

Ha! Good call :upside_down_face::blush:

1 Like