GE/Jasco firmwares available!

Maybe I’m late to the party, but: firmware/zwave/Enbrighten-GE at main · jascoproducts/firmware · GitHub

3 Likes

They were publicly shamed into releasing the firmware last summer by Linus Sebastian of Linus Tech Tips.

3 Likes

They’ve said they were coming for a while. But yeah, glad someone finally forced it. Though… do wish it hadn’t been Linus. Can’t stand that guy. Lol.

2 Likes

In this one case at least, his tendency to be irritating was a public service.

5 Likes

Hahahahaa.

Well played. :slight_smile:

2 Likes

Related, tried updating a plug-in outlet, ZW4201, using firmware here: firmware/zwave/Enbrighten-GE/ZW4201/14284 - Plug-in Outdoor Switch, 500S at main · jascoproducts/firmware · GitHub

and the device firmware updater just comes back with:
FirmwareMdReport(manufacturerId:99, firmwareId:28722, checksum:1848, firmwareUpgradable:false, numberOfTargets:0, maxFragmentSize:null, firmwareIds:[], hardwareVersion:null)

Obviously can see "firmwareUpgradable:false"... that mean it's really not upgradeable, or am I missing something?

1 Like

All my devices say that but yet still update. So just ignore it and try to run the update.

1 Like

do you have to try again, or does it just run finally? updater just threw that error like 10 times and never seemed to go anywhere.

Thats not an error, it is just probing the device and that is the response.

First thing to try if its not working is to shut down the hub, pull power for 10 seconds, reboot.
Also I would power the device off and back on if you can.

1 Like

I only use Jasco switches & dimmers, and also have their outlets and plugs, and I've never had an issue w/a Jasco switch, outlet, or plug. They've just worked. I've had a few of the older Z-Wave (not +) switches die and get replaced under their 5 year warranty, but zero general performance issues.

Maybe that's why they never released their FW updates to the public before - their sh_t just worked. :wink:

The only exception I'm aware of is I think there were some combined switch/motion sensors that had an issue that required a FW update to resolve.

Does anyone have an actual issue w/any of their switches or dimmers that a FW update fixed? Curious...

2 Likes

Same. Except zigbee. All about 4 yrs old. No issues.

1 Like

Good point, mine are all Z-Wave.

1 Like

Yeah, turns out it updated overnight. Cool. :slight_smile:

1 Like

You must have started it and it was just going very slow.

Yup. I watched the logs for a while and it never did anything. Ah well. Glad it updated. :slight_smile:

Yep, the fan switch blue led issue... :slight_smile:

The fan switches didn't allow for control of the blue led and it was set in the firmware to go blue when the device was on... many folks complained that they couldn't set those switches to be the same as regular switches and dimmers. they finally released a beta firmware that fixed that issue...

on a side note, i went through and updated all my Jasco/GE devices to their new firmware. not that i was having any physical issues with the devices, but like to have the latest and greatest. i did about 40-50 devices... I have over 100 Jasco/GE devices in total.

3 Likes

thanks! ordering 55252 z-wave plus for the apartment complex now. rock on!

I just had a 4005 die to faulty cap, but got switch replaced and then replaced the cap and stuck in my backstock. works great.

Just out of curiosity, is there an easier way to figure out which model without pulling the switch from the wall? I've got several fan switches purchased at different times but all from the same amazon page so that's no help. On the firmware page there are model ZW4002/14287 and ZW4002/55258 I'm thinking that if I use the firmware updated driver I can get a version report that will tell me the current firmware and that will give me an idea, but I was wondering if there was another way to tell the difference between them

not that I know of. it's annoying. the front of the switch says it in the upper left corner on the heatsink plate (so you just have to remove the faceplate from the switch). But yeah, there doesn't seem to be a cross reference I was able to find.

1 Like

Download the Hubitat app