First Device Fail - Switching from Indigo

Hello Hubitat Community!

I have an existing home automation network of about 20 devices - mostly ZWave. It has always run very well and I use Indigo running on a Mac mini. I decided to give Hubitat a try and I just received my C7. After reviewing the docs about properly setting up your ZWave network, I decided not to unenroll all my devices just yet and I figured I would set up a brand new device just to get my feet wet.

I set up Hubitat, updated the software, Enrolled the device (HomeSeer WD200+) successfully, set up a Dashboard and put my first button on the grid. Nothing works. Tapping the button does not turn the device on or off. If I go in to the device. itself, tapping the 'configure' or 'off' or 'on' also doesn't do anything. If I use the physical switch, the light works and it shows the current state, but nothing I do from Hubitat can control the device.

I watched all of the tutorials thinking it would be pretty simple to get started, but I am stumped. I tried:

  • unenrolling / re-enrolling the device
  • factory resetting the device
  • Updating Hubitat
  • turning the ZWave antennae off for a while and then back on

Not sure what could be wrong. Any ideas? I don't want to start unenrolling my current devices until I can figure out what I may be doing wrong.

Thanks for any help!

You won't notice anything, except maybe a log entry that it was initiated.

That should work.

Hold onto that thought for a second, we need to make it work from the device page first. But keep in mind that button might not be the best dashboard template for this device. Shouldn't that be a dimmer and not a button?

Couple quick questions:

  • What driver (Device Type in the device page where you did the configure and on/off) is this using?
  • What do logs show when you operate the switch physically and through the hub? Screenshot the log page while operating the switch and post it here.

Welcome, @jon441111! May you enjoy and benefit from this community as much as I have.


Hi and thanks for the reply!

Ok - I was thinking there was something more to configure in there. No log entry, though but no big deal

I actually tried a dimmer too. When I set up the dashboard it automatically picked a button, so initially I thought that was correct. But the device is a dimmer so I did try changing it. Still no luck when I did change it to a dimmer.

The device type on the driver page is 'HomeSeer WD-200 Dimmer'. The device is the '+' but I think that is just for the S2 security. I know there used to be a community driver for this device but in the forums, it was 'withdrawn' which (if I understand the community posts) probably means that the driver was built in to a future HE release and didn't need a community driver any longer.

Live logs show the physical button presses:

Also, on the device page, you can see that it registers the "current state" as on when the device is on. So, it is communicating (somewhat)
Screen Shot 2020-07-28 at 6.34.25 AM

The basics (driver etc) look correct to me, for whatever that is worth.

What do the logs show if you try to operate it through the hub?

Also, is this the only device on your Hubitat right now? How far away is this switch from the hub? I am leaning toward weak mesh issues, but there could be something else going on.

@april.brandt or anyone else have any thoughts?

When the check boxes come up, uncheck them all and try to pair without security. Have you tried that yet? I just skimmed the post quick.

I think it is pairing judging by the information above, but something seems to be wrong with communication.

try changing the driver to a similar type but different one than using currently and then change it back to the one it's supposed to be, clicking configure each time.

Otherwise I'm out of ideas
I don't have a C7

1 Like

Try using @BorrisTheCat’s Clean Device driver. Install it as a driver and then select this driver from the device page. This driver will clear all settings set by different drivers for the device. Once you’ve cleaned it, change the driver to be the one you want again


Nothing in the logs when I use the "on" or "off" or set the dimmer level from the device screen

Yes, this is the first device I enrolled. The hub is about 12 feet from the device.

Another interesting behavior that I am seeing. Many times, when I try to "Include" the device, it finds it immediately, shows the security screen and then when I click "ok" it says "initializing" but never finishes. Then if I go to the devices screen it is not listed. But I can go back in to the ZWave discovery page and choose "exclude" and it finds it and says "Unknown ZWave device excluded". Very odd.

That does sound like another known issue. Maybe post in that thread and tag bcopeland so he can dig into the root cause of it.

Yea, there's a "C-7 & Dimmer" issue that "they" are looking into.. but I've heard no new rumors. I assume there would be a hot fix if it was found and fixed.

Loaded the custom driver. Saved it as the new driver for the WD-200 and cleared everything out. Re-loaded the original driver but still the same behavior: trying to set any state on the device from Hubitat does nothing. No log info and no lights turn on / off.

Ok- thank you! I honestly hope it is a known issue... I feel like I've been banging my head against a wall a bit with this. I will post my issue there too and see if they can provide help. Thank you ALL for jumping in to help though - I think having community support for Hubitat is great and I hope to pay it back as I get more involved.

1 Like

It sounds like the driver you are using doesn’t support S2.. I would re-pair it and uncheck all the security key grants

I did try that and it would never pair - it would just stay on "initializing" and not complete. It looks like the other post had some steps to try when it hangs like that. I will give those a try.

Update: Tried to follow the steps recommended by @bcopeland, but was unable to get it to work. His recommendation was:

  • try to include the device with security unchecked
  • When it gets stuck on initializing, do a safe shutdown. (settings -> shutdown)
  • Unplug and re-plug the hub when it gets to the red light
  • After logging back into the hub go back to z-wave discovery and tried to finish discovery but it never completed.

Device never showed up in the devices listing after safe shutdown and going back through discovery.

So there was no un-named nodes in you z-wave settings?

Would you mind doing a screenshot of that page?