Everything Xbee

Using channel 20 as well. I’ll try turning the radio back on the c-5 to see if it will stay connected there.

Are you using firmware 100A and the latest configuration files I posted?

I am not, using 1008 or 1009 I think it was and using same configuration files I used to set it up originally (Would have been whatever was in the first post before the latest version).

Maybe do a full reset and try the updated firmware and files.
Hopefully my C7 will arrives north of the wall (Canada) sometime this week and I have a spare Xbee3 to test with it.

If you set it up as a router and do a scan is it connecting directly to the hub?

1 Like

Is there a trick to doing a full reset? I'm not immediately seeing a "reset" button in the software. I applied the router settings and it was connecting directly to the hub.

Edit: Updating the firmware and applying the newest configuration profile seems to have done the trick.


right on!

regarding the reset for future reference
after reading the Xbee3 you can just select default then write which puts all the settings back to default setting.
Update should do the same thing as below for the firmware.
At the top in the tools drop down there is Xbee recovery
product family : Xb3-24
function set: Digi Xbee3 zigbee 3.0 TH
firmware version: 100A


sorry I don't recall but one of the xbee settings talks about leaving the network after ....., I set mine to never leave, no matter what. I think it's CR and this comes into play with HE handling conflicts, so set CR to zero

Take a look at the settings I used. I changed some things to avoid getting locked in to one PAN ID and to give it normal rejoining behavior.

I was cluttering up the Xiaomi pairing topic with some XStick chat earlier, so thought I'd post it here.

I have a handful of Digi XStick2 USB adapters here, which at the very least I wanted to use to generate the XCTU network visualisation. Unfortunately I'd had no luck with any of the configuration settings found on here, but did get them working following these instructions on the ST forum.

It was as simple as using XCTU to load the .xml file (in step 3) with Profile > Apply configuration profile, then putting HE in pairing mode. :+1:

I'll include the .xml data in this post just in case it vanishes from the web one day, but this is down to JohnR over on the ST forum.

<?xml version="1.0" encoding="UTF-8"?>

      <setting command="ID">0</setting>
      <setting command="SC">FFFF</setting>
      <setting command="SD">3</setting>
      <setting command="ZS">2</setting>
      <setting command="NJ">5A</setting>
      <setting command="NW">0</setting>
      <setting command="JV">0</setting>
      <setting command="JN">0</setting>
      <setting command="DH">0</setting>
      <setting command="DL">0</setting>
      <setting command="NI">xStick</setting>
      <setting command="NH">30</setting>
      <setting command="BH">0</setting>
      <setting command="AR">FF</setting>
      <setting command="DD">3000C</setting>
      <setting command="NT">3C</setting>
      <setting command="NO">0</setting>
      <setting command="CR">3</setting>
      <setting command="PL">4</setting>
      <setting command="PM">1</setting>
      <setting command="EE">1</setting>
      <setting command="EO">1</setting>
      <setting command="KY">5A6967426565416C6C69616E63653039</setting>
      <setting command="BD">7</setting>
      <setting command="NB">0</setting>
      <setting command="SB">0</setting>
      <setting command="D7">1</setting>
      <setting command="D6">0</setting>
      <setting command="AP">1</setting>
      <setting command="AO">0</setting>
      <setting command="SM">0</setting>
      <setting command="SN">1</setting>
      <setting command="SO">0</setting>
      <setting command="SP">20</setting>
      <setting command="ST">1388</setting>
      <setting command="PO">0</setting>
      <setting command="D0">1</setting>
      <setting command="D1">0</setting>
      <setting command="D2">0</setting>
      <setting command="D3">0</setting>
      <setting command="D4">0</setting>
      <setting command="D5">1</setting>
      <setting command="P0">1</setting>
      <setting command="P1">0</setting>
      <setting command="P2">0</setting>
      <setting command="PR">1FFF</setting>
      <setting command="LT">0</setting>
      <setting command="RP">28</setting>
      <setting command="DO">1</setting>
      <setting command="IR">0</setting>
      <setting command="IC">0</setting>
      <setting command="V+">0</setting>

I'd like to have the XStick perform this task as an end point device to avoid messing up the routing, but the same settings do not work when running the End Device API firmware - the stick is discovered, but never completes "initializing" on the pairing screen.

Just setup a couple of XBee 3 Pros (one XB3-24Z8PT & one XB3-24Z8ST) and noticed that both show 13 dbm for transmit power with PL set to 4 (the default). Aren't the pros supposed to be 19 dbm?. Anyone have one of these radios and see 19 dbm? I'm in the US.



13 is hex converted to decimal is 19

1 Like

Shouldn't there be an 0x or something denoting hex (or maybe I just missed it)?

If you change PL to High(3) and write that value
then refresh the PP setting it will change to a more obvious hex value F

I got my hands on an Xbee PRO S2 module recently

By the looks of the user guide, it would seem that this module can be configured to act as a Zigbee router. Page 85 is interesting as there's info on hooking up an LED and a pushbutton:

While I don't have a devboard for the xbee module, I do have a regular FT232RL USB UART module
image, capable of supplying 3.3V. I use this for flashing ESP devices. It looks like one can hook up the VCC, GND, DOUT, DIN, RTS, and DTR pins and use the UART module to work with the Xbee module.

I'm going to give it a shot this weekend and see if I can get this to work with @NoWon 's steps above.
Btw: found another good reference here for messing about with X-CTU

Anyone know if you can set an XBee to route network traffic only and not to join any end devices to the network?

I think what your asking is if you can set the Xbee3 as a router to map the network (end device settings can not map the network) but not allow devices to route through it.
I have never set it up as such myself but you could try just setting the NJ (node join time) to zero
after initially joining the Xbee3 power it off only power it on when you want to map your network.

For the stuck in "Initializing" state situation I'd like to share something that worked for me.

I had saved a configuration profile a couple of months ago. Yesterday I was trying to setup a new XBee using that profile and hit the problem.
I spent a lot of time on the "Networking" and "Addressing" sections of the configuration, but in the end I found that:

was the missing config for me, once that was set it worked right away!

When creating a profile (if that is your case), I recommend that you avoid clicking "Create profile" on the first screen and go through all the "Next >" steps to make sure KY is saved and has the correct value.

Also KY property has a unique behavior. It seems to be reset or not shown in the configuration when you reload a device in XCTU. I'm not sure if it is just hidden for security purposes or really changed in the device.

In my case, when it is all good, it takes ~70 seconds between hitting the "Start Zigbee pairing" button in Hubitat and completing the "Initializing" phase.

@bertabcd1234 @Rxich @eibyer @myronwheeler72 @kilowatts @mwoo.t1 @jrfarrar @staze @aaron @andydvsn

Thanks for the suggestion. Tried that - didn't work - end devices still join when NJ is set to 0.

So I am 100% new to Raspberry Pi and coding. I am trying to use the;

  • xbee s2c x1

  • zigbee smart plugs x4 ( CMARS Smart Plug, ZigBee Switch Mini Smart Outlet Works with Alexa, SmartThings Hub, Hue, Echo (4th gen) Echo Plus (2nd) Google Home, Works as a Range Extender, Hub Required)

  • xbee explorer dongle for usb connection x1 ( Sparkfun XBee Explorer Dongle - Red)

I want to use this with a simple program on the raspberry pi to get the xbee sc2 to communicate with the smart plugs so I can use it through the raspberry pi and not alexa, google home, etc.

Please help me out if you can! I have been working at trying to figure this out for the past few days as my first project on Raspberry Pi. Much appreciated!

I assume you are using home assistant on the Raspi?
I have never got around to playing with HA or connecting my Xbee3 to my Raspi4 sorry.