Empty details on couple of Zwave Devices

I have a couple of entries in my Z-wave device list with no details. Is this normal?

First one is the hub, that is ok. Second one is a failed inclusion.

Ah, that might have been my old motion sensor that I thought paired but didn't. What can I do with that entry? I've already chucked the device and used a new one.

Hit discover. If the node fails, it will be marked as "Failed" and a "Remove" button will appear.

https://docs.hubitat.com/index.php?title=Z-Wave_Manual#Remove_a_failed_Z-Wave_node

2 Likes

I tried this yesterday. I clicked Discover but that didn't do anything so I tried Refresh. That one brought up the Remove button after a couple tries. Now clicking on the Remove button doesn't seem to do anything so I gave up on it because I didn't want to force stuff and wreck my working setup because of my ocd lol.

I checked this morning and the failed device is not on the list anymore. Did the hub do its housekeeping chores last night?

image

Yes

Might want to add a little warning to the 'Remove' button that there's no instant gratification :smiley:

It should be :slight_smile: But as Mike put it yesterday, "remove is a bit fidgety," sometimes :slight_smile:

2 Likes

Tsk tsk... ok fine :stuck_out_tongue_winking_eye:

2 Likes

@bobbyD I'd love to see the Force Remove button moved so it isn't were the remove button normally is if you go to try a remove again without exiting and reentering the devices page. I've accidentally hit force remove a number of times while fighting with removing a device. My hub will pair devices like light switches in their normal location just fine but removing them usually requires me to pull them and put them in a box on my bench which is near the hub to get them to exclude.

2 Likes

I now have a few more of those failed entries after failed attempts at pairing a Schlage lock. It didn't get cleaned up like the last one I posted. The entries have been there for a couple of days now.

Clicking Refresh and Discover on the last two entries do not bring up the Remove button.

Don't mean to derail this thread, but why, @bobbyD, does the Hubitat not recognize itself and put isomething in at least one of the fields (Device ID, Device Type, and Device) rather than leaving them all empty. Seems really odd that some info can't be provided to keep from confusing people - the way it is now the hub entry looks like the result of a failed join, I thought so at first and was struggling to "fix it" until I ran into the info in a thread somewhat accidentally. Seems really odd to leave it that way.

Well after getting bored and staring at the dang messed up list, I lied, more like I can't stand knowing those are there! I alternated between Refresh and Remove, few seconds in between... and one by one I got rid of the failed entries! This saved me at least 15 minutes per failed entry during a z-wave repair!

Not fun, glad you have it cleared up.

Any comments/info on this, @bobbyD? Thanks.

On my C4 hub I used to have a device 0x01 (hub itself), but it no longer shows up on a Zwave Detail Page - is this a sign of a problem developing? Platform 2.2.2.126

Not at all. It is hidden by "design" to reduce confusion, as too many people are trying to remove what it seems to be a ghost :slight_smile: Next update will hide the node 01 on C7 hubs as well.

2 Likes