Stuck Z-Wave Devices Won't Pair, Repair, or Delete?

New to Hubitat coming over from SmartThings. It took a bit of head banging to figure out the exclude / include process but I have about 50 of my 60 devices migrated over. I have one light switch that seems to be a problem child and I could use some help.

I have a C7 Hub running 2.2.3.148
The switch in question is a GE/Jasco Enbrighten Z-Wave Plus Smart Light Switch Model 43072. It is installed adjacent to other similar z-wave switches that paired without a problem but it is refusing to cooperate.

Initially I excluded it via the ST App and that appeared to work correctly. I then attempted to Include it via HE. It brought up the security options, which I did not change and then the ID entry which I made, but after that it never showed up in the HE Device List.

I made a couple attempts to Exclude and reinclude it again via HE but it appeared non responsive. I ran a Z-Wave Repair, I rebooted HE, made a couple more attempts and still no joy.

After that I went into the Z-Wave Details screen and found the following entries but I don't know enough about Z-Wave under the hood to know if any of these entries are the switch in question.

I tried the Remove, Refresh, and Repair options on each of these but that has no effect, the entries remain as is. I have attempted a couple different Factory Reset routines that I found here and on GE's site. I get no indication that the switch is resetting. Before resorting to strings of garlic and incantations I thought I would reach out to the community to see if anyone had a more reasonable approach.

Any advice or direction would be greatly appreciated!
Thanks!
Tom G.

Quick Update: I finally got the switch to do a factory reset but still no luck getting HE to recognize it.

Those ones with the blank IN:OUT clusters are probably ghost nodes (failed inclusion). You will probably want to get those cleaned up or you will have problems.

The usual suggestion is to depower this device that caused the ghosts, try a repair on those ghost nodes, and when they fail remove them. Once these are cleared up, then you can attempt to include this switch again.

A couple relevant threads.

1 Like

With the exception of device 0x01, which is the Hubitat hub. Not a good idea to remove that one.

2 Likes

I went through the recommended steps to remove the ghost devices multiple times. I managed to remove one of them. I still have the other three and can't seem to get them removed.

I've now updated my hub (a C7) to 2.2.4 and have started repeating the steps again but so far no joy. I still have the three remaining devices. All three show as Failed and give me the Remove, Refresh, and Repair buttons in the status column and the discover button in the device column.

Any other thoughts?

It depends on what “recommended steps “ you did. As Lewis Heidrick (@lewis.heidrick) has pointed out, apparently, when the hub can still ping the ghost device (now included at a different node address, often the next higher one), you need to remove power (battery?) from the device that caused the ghosting before the hub will be able to remove it.

Sometimes, when you are in really deep, it’s necessary to use the sure-fire process detailed by @danabw:

Ghost Removal - who you gonna call?

EDIT: Look on it as a rite of passage, an initiation that all of us eventually experience.

4 Likes

I only know of one physical device that did not get discovered correctly. I powered that one down as part of the process. I followed the steps I saw outlined in the how to remove ghost devices thread that you referenced.

I suspect the device I did power down may be the one out of the four that did get removed.

How would I go about determining what physical device the other three are?

Thanks for the additional reference to the "who you gonna call" document. I'll dig into that this evening after work.

As for the right of passage, I've always considered myself reasonably tech savvy and I'm not afraid to dive headfirst into most anything but, Wow, Z-Wave is really challenging me...

Again, Thx!

Well, Lewis Heidrick (@lewis.heidrick), about 16 hours ago, before he started a day of baking bread, had this suggestion to someone in a similar quandary:

1 Like

Me and @danabw look nothing alike:
image

2 Likes

My data rack and my primary WiFi access point are on a UPS so taking the sledgehammer approach is a workable solution. I just need to find a time slot to do it that won't cause a big WAF hit. :smirk:

Thanks!

Think of it as a WAF stress test and do it now to see what happens.

1 Like

Damn...do you have a camera on me!? How the hell did you capture my essence so completely?!!

image

1 Like

Sorry, Lewis, I didn’t recognize you without your clothes and hat.

2 Likes

I can only recognize him w/out his clothes and hat. :wink:

2 Likes

UMMM.

  • Keep it clean. Don’t post anything obscene or sexually explicit. FAQ - Hubitat

:laughing:

2 Likes

Download the Hubitat app