Empty details on couple of Zwave Devices

Sure about that? Have live logs open in another browser tab when you press Repair.

1 Like

Ahh, I am getting the "Zwave network responded busy"

There are several ways the Z-Wave busy can occur. One way can be multiple presses of Repair or Refresh while the hub is trying to push out its queue of commands. After a few (time spaced by a few minutes) of Repair, a “Remove” button will appear, then you may be able to remove the bad node, or go to the device’s page, hit the Remove at the bottom of the page. See if one of those work to get rid of the problem, then see if you can include the device with the hub in close proximity to the. device (first do a Z-Wave exclude in case the device thinks it is included, then factory reset the device). Then shut the hub down from the settings page, pull plug for 30 sec (this will cause Z-Wave radio to reboot), power hub & allow to reboot, and now try the include with the reset device near the rebooted hub.

1 Like

There is no device to go to really, It was a failed inclusion that the timer ended before the inclusion did. The device below that line is the actual device that was re-inclusion after.

Ok, then try Repair on that node a few times with live logs open so you see when it’s done each time before starting next repair. After a few tries with no device response, a Remove button should appear, allowing you to remove the ghost node. Let us know how that goes.

Ok, I tried 10-15 times to REPAIR the empty node. Always got "busy" followed by several battery reports on the contact right below the empty node on the above pic.

I then zwave excluded that contact that was right below the empty node in the pic, followed by several REPAIR on the empty node. Now I get all sucessful zwave repair starts and stops with no "busy" but still no remove button.

Did you remove the batteries or unplug the device before trying to do the repair on that device? If it is still "awake" (even if not joined) it might not think that device is failed.

The empty node has no device. Unless is really the below contact in the pic for the below contact was the successful inclusion of the emoty node which failed.

Right, that is the problem. The failed pairing is still looking for (and possibly seeing) the correctly paired device.

So try unhooking (presumably batteries) power, and see if it will then find the failed node.

1 Like

@neonturbo is right on. In other words....

If the hub can ping the device it will never go to FAILED. So if the device has power, you need to remove it and refresh until it is FAILED. Then remove it. Then you can power the device back up.

1 Like

Well it’s a recessed door gen 7 contact. It only pings when awake once a week I think. I went ahead and removed battery. I will give it 20 mins or so and try repair several times.

I would think there would be a manual delete option. I’m coming from a UD994i-zw

Try REFRESH several times, not repair.

Refresh always tells me zwave network busy no matter what.

Then you need to shutdown the hub, and remove power for 30s to reset the radio.

Then try the refresh/repair right after reboot before the radio gets fudged up again.

You need to get the device into a failed state, and do the remove, before your radio gets locked up and stuck in the busy mode.

It is tricky to do sometimes, and may take multiple power down - remove power - power up cycles.

FYI, I’ve got 3 of those, the driver has numerous bugs (I’ve turned in bug reports) that are supposed to be fixed in the 2.2.4 firmware, according to support.

Yea Ive tried 4 times,

Shutdown Hub, after orange LED is on, remove power, wait 30-45 seconds, power up, go straight to setting, zwave settings, scroll down to empty node and tried several refresh and repair. Never got a remove button.

Why cant we just have another button for remove?

I am supposed to be doing refreshes to try to get a remove button right?

1 Like

Refreshes should drive the device to FAILED (as long as the device is not powered up of course).

Once it is in FAILED status the remove button will show up.

1 Like

I do not know what I am doing wrong, I cannot drive a remove button. Maybe because there is no device for that node? Do I need to ditch everything and factory reset?

You don't say specifically, but it doesn't sound like your hub is bogged down badly and not working, at least you never brought that up if it is. If things are working OK but you just want to remove the ghost to clean things up, it's not worth a reset.

2.2.4 is in beta and will arrive (hopefully) in a reasonable amount of time, and it has improved ghost removal skills. I removed a ghost today using the Remove button. Had to click the Refresh and Discover buttons a number of times and the Remove button did show up. Then clicked that a number of times and it did remove the ghost. So it's better at getting rid of them in my experience so far.

However - I had a ghost today that 2.2.4 was not able to remove no matter how many times I tried. I eventually got a Remove button, but Remove never worked. So I had to use my UZB Z-Wave stick to kill it.

You might want to have a UZB stick available for problemmatic ghosts you might run into, possibly including this one, that the hub can't remove. Info at link below to a PDF write up I did w/help from folks here. Includes link to purchase the stick for a reasonable price.

Ghost Removal w/UZB Stick

I have two that DO show the remove button. I have hit remove probably 50 times over the last few days. Neither will go away. Any ideas for me to try @bobbyD

Download the Hubitat app