Driver code for Schlage Connect

I apologize in advance but I know absolutely nothing about this stuff. So I have two Schlage Connect locks (BE468/BE469 Lock). One worked great for the first couple weeks. I had a simple rule set up that automatically locked the lock 10 min after being unlocked. Now it doesn't work and I'm getting a error 500. I emailed Hubitat support and they said Schlage is no longer on their list of compatible devices. However, there are "drivers" specific to Schlage models to make them work.

I'd assume a driver is some sort of code. What I can't figure out is where to find this driver and how to apply it. I searched endlessly and I can't figure this out. Please help. Thanks!

The driver is built-in, so you do not need to add it. You can select this driver for your device using the "Type:" dropdown on the device page, and you can type in the box to search/filter to make it easier to find if you want:

Screenshot: device page with 'Type' dropdown

Note that after changing drivers, it's usually a good idea to hit "Configure," so I'd do that after you hit "Save Device" as well. (You won't see anything happen except maybe in the logs if you do this, and not all devices have this command/button visible, but unless you know of a reason not to, it's again normally a good idea.)

That being said, a driver shouldn't cause that problem with Simple Automation Rules, so this seems unlikely to fix it to me. You may want to re-create the rule to see if that gets rid of the problem (which isn't clear to me--where does the "Error 500" occur?).

1 Like

If you go to the Devices tab, and select these locks, there is a page that comes up where you can configure the device type, change the name and so on (the settings page).

On that page, there are some buttons where you can try the lock. Can you successfully unlock and lock from there? Does the current states (upper right) follow the lock and unlock?

I also circled where to change the driver (device type) on the right lower part of the screenshot.

If it works from there, that rules out the lock itself or the driver being the problem for the most part. From there, I would guess it is whatever app you are using (you didn't specify what one) is having issues.

Start with what @neonturbo said. One of the other issues is with these locks you should use beaming repeaters (put one as close to the lock as you can). Also check your z-wave status page for ghosts... If you had a failed pairing with these locks at any time (or with any device for that matter), it will cause a lot of issues. I have 3 of these locks and with beaming repeaters in place they work flawlessly. I'll also note, if you have anything less then firmware 7.8 you will have issues

I’m pretty sure I selected the BE468/BE469 Lock type when I initially installed the device but I went in and changed it anyway. Now I have the original device on my devices page but I also have a second one except under the name of it it says front door instead of device. Is this a ghost?

I tried removing the app and re-adding it. The app still does not work.

Yes when I am on the device page and lock/unlock it does reflect that accurately on that page. I can also lock and unlock the device from that page.

The app I’m using is just a basic rule.

Not necessarily, but if you don't really have two of these, then something is wrong. The fact that one says "(Device)" doesn't mean much--that just means you have a device name set that is different from the device label, and the label if present is used as the most prominent display name, with the name in parentheses under it. The device name is often the name of the driver the device originally paired with, but you can change either or both after the fact without affecting anything.

A ghost with new firmware is likely something on Settings > Z-Wave Details without a "Device Class" listed in the table or with important information missing from the "Data" field on under "Device Details" on the device page itself (zwNodeInfo or inClusters should always have something...though the best place to look for this info changed in the most recent firmware, and I think these are the best things to look for now). So if one of yours fits that description, it likely is, and getting rid of it should help. If nothing else, you can also use the commands on the device page to identy which one does or doesn't work, then either that's a ghost or you happen to have accidentally renamed and switched drivers on the wrong device at some point. :slight_smile:

Probably ought to get that straightened out first, that could possibly cause issues.

So I guess I would try either [RELEASE] Auto Lock Door or [RELEASE] Auto Lock If those work, we know it is Basic Rule that has an issue. And you get a working lock. From there, if we can narrow it down to Basic Rule not working and one of these apps do, we probably should report a (likely) bug.

I think both are available in Hubitat Package Manager, which is probably the easiest way to install them. [BETA] Hubitat Package Manager

Okay what the hell is the deal with HE? I have a Zooz motion sensor paired with a Zooz dimmer in my pantry that was working fine for about two weeks and now it doesn’t work at all. It seems everything I put in my HE works for a couple weeks then craps out. Is this normal? Does everything with HE require this much tinkering? I don’t really have the time to keep messing around with this.


No - at least by my experience. I’ve been a Hubitat user now for about 2.5 years. I did have a lot of teething zwave issues, but the last of these were sorted out around February 2020 (the cause was stranded and ghost devices).

Since then (2/2020), I’ve occasionally modified automations, and definitely added devices, but I’ve had no controller-dependent issues. I’ve also switched controllers from a C-5 to a C-7, without incident.


Which model of this? There were issues with some of these sensors being bad actors on the C7 hub and/or the 700 series of Zwave chipsets in general. They like to pair S0 and they send multiple reports which is quite bad for the mesh.

Maybe include screenshots of how you have this (Rule? Motion Lighting?) set up. Paired is not a term normally used for this function. It is always good for us to all be on the same page when we are trying to diagnose things. And again, what model Zooz switch? We cannot see your hub after all...

No, that isn't typical for most people.

Like aaiyar, I have played around very little with my setup other than things I wanted to add or change. Things were a little rocky at the start (back in 2019) because I didn't understand how the hub worked, or how rules worked, and so on. But after the first few "iffy" weeks, things completely stabilized and I really haven't had any issues since.

I wanted to have the advantages of the newer 700 chipset so I migrated at around Christmas from a C5 to a C7. Both hubs were and are quite stable. In fact, with the latest round of hub firmware, things are working faster and better than they ever have in my opinion.

So give us something to work from, and we will try to figure out what is going on with your setup.

1 Like

A screenshot of your settings, zwave details page would be helpful. I had 219 devices on a C5 and 246 devices on a C7 without issue. Several rules trigger nearly all of my devices such as my bedtime routine and they are pretty much instant. Delays or device ces not responding is usually indicative of one or more devices on the mesh misbehaving. Ghost devices generally being the worst offenders followed up by power reporting devices particularly if paired with S0.


Here are screen shots of my z wave device settings and the app I have running. The front door app to automatically lock after 10 minutes still isn’t working.

Well you have a ghost and that needs rid of. That could have happened when you had a failed pairing with your lock... It's likely why it's not locking properly

1 Like

Yep, it looks like 0x0A (10) is a :ghost:

And I would add that your RSSI (signal strength) seems very low on all these devices, things aren't likely to work well or at all with zero or worse yet negative readings. My amateur observation is that you should be seeing closer to +20 if not a lot higher for RSSI. I see more like +40 on my devices that are great repeaters for the mesh. If someone knows the official numbers, maybe they can chime in here.

I believe you need more repeaters in general, either dedicated ones or just line powered devices that repeat. The Ring Range Extender 2 is inexpensive, and seems to be a very effective repeater. I like dedicated repeaters as you can place them anywhere you have an outlet, and move them around to maximize their effectiveness. But some carefully placed light switches or outlets could be a good option if you need any of those.

1 Like

So I’ve already tried searching about how to remove ghosts but I can’t seem to find a definitive answer. Does anyone know how to remove a ghost? Thanks!

Make sure the device that created the ghost is powered down. Keep clicking discover till you get the remove bar. Click remove. Reboot hub

1 Like

Thanks everyone for the help. Unfortunately nothing has worked. I removed the ghost by clicking the remove button. Is this USB stick for removing ghosts really the way to do it. It seems odd that we have to jump through so many hoops to just delete something.

The app to automatically lock the front door after 10 minutes still doesn’t work, even after deleting it and making it again. The hub also seemed to brick my Zooz 4 in 1 Model ZSE40 motion sensor. Same thing happened to other schlage connect lock in the basement. They both are essentially paper weights now after 2 weeks.

I’m truly at a loss and ready to throw this thing in the garbage.

If it is removed without the usb stick then you don't need the usb. For me, the stick has been pretty much a full-proof way to remove devices when nothing else worked.

Looking at the details I see that you have a ton of route changes on those devices in the screenshots. You probably don't have a very strong mesh and are having communication problems. If you have your hub inside a metal network rack or around metal appliances, try relocating it. The route changes should be really low which leads me to believe you still have some mesh issues.

1 Like