Device stuck with wrong driver

Hi, I am trying to add a generic zigbee 1-gang switch and it keeps picking Aqara motion sensor driver when adding the device. I tried changing the driver after adding the device but it does not seems to make any difference. I can only see the state changing in HE when switching with the physical button. I had similar issue with another switch and I had to reset the whole hub and start from scratch.

Seems like the data for the added device is wrong and does not match with another working device. Is it possible for me to change these parameters or any guidance to fix this would be appreciated.

Working switch info:

Switch that keeps picking Aqara driver when adding:

Tried reboot. changed the driver to device and then reboot and then select the correct driver "Generic Zigbee Switch" but can only see the status and cannot operate the switch. Configuration, refresh does nothing.

Thanks in advance.

1 Like

You can try the latest dev, branch version of this driver :


Thanks for the feedback. Seems like it is to do with the "Past Log". I was able to make it work with soft reset and selecting the delete past log option. However, I cannot add and make it work if I soft reset and restore from the backup.

Is there a way to delete the past log without the soft reset.

Logs should have nothing to do with a driver (and device) working or not.

  • Maybe the device is not working because it is out of range, or a weak signal upon pairing.

  • There could possibly be remains of incorrect drivers. In this case, switch the driver to "Device" and use the buttons in the upper section of the driver to clear states, child devices, etc. Switch to the correct driver, and use the "Configure" button (if available) to bring in the correct device configuration parameters.

1 Like

I tried exactly this but still cannot get the device to work. The only time I can make the device work is when I soft reset the hub with the option of delete past logs. Even the soft reset without deleting the even logs does not help.

The problem is if HE selects a driver on its own when adding the device then no matter what I do, I cannot get the device shifted to the new driver and configure. The only way for me is to soft reset with delete the even log.

Range and signal is not and issue for sure. It is less than 5 meters away from the hub with no obstruction at all.

It worked for the first device I was having issues with. Now I am having issue with the other device. HE picks the Zemismart driver when adding the device for the first time. This driver does not seem to work with this device. No matter what I do, I cannot configure the device with the generic zigbee multi-end switch. the only way I can make this device work is if I soft reset the hub with delete the past log. Soft reset without deleting the past log does not help either.

OK, you are talking about two different devices, I understand now.

The second device ( that shows with endpointId:F2 on your second screenshot) has not paired successfully to HE... probably.

First delete it from the device web page and pair it again - close to HE hub.
Can you pair it 1-2 meters away (at maximum) from the hub?

When the device is found during the zigbee pairing, there will be a hyperlink 'more info'. Please click on it and copy/paste here all the information that will be shown in the popup window. This detailed information is shown only one time, when pairing as a new device.


Apologies for the confusion, The device I was having issues before was solved with the driver you told me (zemismart). Now I was having exact same issue with another device. This device kept picking up the zemismart zigbee 1/2/3/4 gang light switches driver when adding and it did not configure properly when I changed the driver. Only solution that was working was soft reset with delete past log.

I eventually kept deleting and adding (7-8 times) and in between kept playing with the drivers. Eventually, the device added with the correct driver (generic zigbee mulit-endpoint switch) and it is working fine now. For some reason, I can not change drivers on some of these device (generic tuya switches) and configure with the right driver unless the HE picks up the correct driver when adding.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.