[Deprecated] Xiaomi / Aqara ZigBee device drivers (possibly may no longer be maintained)

If you’re still experiencing issues, @gavin_robinson, I would bet my cat (I don’t have one) that it’s the wired Aqara wall switches giving you trouble. On my network things would randomly drop and stop responding. I took @markus advice to try without the wall switches in the network and everything is now working perfectly, including all of my Xiaomi battery devices alongside AlertMe and Tradfri kit.

I’m going to wait for his driver and keep them off this network for now. To stop them trying to reattach, because I can’t turn them off, I had to change Zigbee channel.

The setup is so reliable now I’m tempted to replace some physical switches with Xiaomi Aqara wireless wall switches and wire the ceiling lights on permanently with Tradfri lamps.

What other devices do you have on your Hubitat mesh? I have the WXKG03LM and WXKG11LM, so I don't have a direct comparison, but my recent experience just above has been that other, seemingly compatible, devices have caused issues.

My motion sensors, contact sensors and humidity/temp sensors, Xiaomi and Aqara, are rock solid. It's just these darn buttons. All devices are spread throughout the house which leads me away from the mesh.
This is why I asked specifically about the buttons.
I'll crack it. :+1:
EDIT. One of the buttons is now holding up ok. It's been 18hrs and all is good.
Getting closer. :wink:

EDIT 2. I even have a temp sensor in a freezer in my detached garage that is working brilliantly. I didn't realise they worked at -16.8 C!

While I was running these drivers I did have some issues with the gyro enabled button, it was the only thing that dropped regularly (couple of times a week, sometimes) while the motion and contact sensors were solid. I've since switched to @markus's driver release, it seems to have solved my issues as the button has been fine for nearly a month. In short, these drivers were excellent for everything except the button but I couldn't tell you why.

Just an update on my button issue.

Paired one up yesterday afternoon. Been working fine since.
Paired second one up this morning. Been working fine since.
Paired third one up this lunchtime. Been working fine since.
Maybe it was something to do with pairing them all up together. Who knows. They work and that is all that matters. (Tempting fate I know)!!!!!!!!!! :+1:

Thanks for the great drivers @markus.
I will continue to add more devices but at a slower rate. I love the presence capability.


I just thought I would post an update on here about this humidity/temp sensor.


@markus has released a series of drivers that include a "present/not present" capability.
These drivers will also try to get the device back on line should it drop off of your zigbee network.
As I wanted to try and use this capability on this device, Markus advised me to try his "Zigbee - Sonoff Temperature & Humidity Sensor".
I had a few issues initially but that was probably due to me playing with different drivers trying to get the presence to work.
When I changed to this driver, then did a re-pair of the device it worked and has been working faultlessly for the last 24 hrs.
I just thought I would post this info in case anyone else wants to try Markus's driver and get the facilities that his drivers provide.

EDIT: I was using the "Konke temp" driver mentioned in this post and this too was working faultlessly with no issues. Me being just wanted that little bit more.


I also have 2 of the Blitzwolf devices and I am also running @markus drivers and they have been working well so far, have had them connected for about 2 weeks now.


Has anyone had any luck including the Aqara WS-USC02?

I just attempted to add one of these as well with no luck. I can use the device on the generic Zigbee driver and it'll turn on and off, but it doesn't work with any other driver that I can tell.

Have you tried it with my Aqara Wall Switch driver?
I haven't added support for Aqara WS-USC02 specifically, but it shouldn't be hard to do (it may already support it) since that driver already support every other Aqara Wall Switch. If it does work, please post your device fingerprint. It complete one can be retrieved by using the Get Info command in my Generic Zigbee Device Toolbox driver.

The drivers in this thread are unmaintained since @veeceeoh doesn't come here anymore (last visit back in February). For currently maintained drivers see this thread:


Thanks but I don't think that worked. The device doesn't have on/off buttons in the settings page and this is in the logs

dev:3542020-07-27 07:37:46.996 pm warnUnknown model (lumi.switch.b2laus01) - PLEASE REPORT THIS LOG TO THE DEV - description:read attr - raw: 10F302000032050042146C756D692E7377697463682E62326C6175733031, dni: 10F3, endpoint: 02, cluster: 0000, size: 32, attrId: 0005, encoding: 42, command: 01, value: 146C756D692E7377697463682E62326C6175733031 | parseMap:[raw:10F302000032050042146C756D692E7377697463682E62326C6175733031, dni:10F3, endpoint:02, cluster:0000, size:32, attrId:0005, encoding:42, command:01, value:lumi.switch.b2laus01, clusterInt:0, attrInt:5]

dev:3542020-07-27 07:37:46.990 pm warnUnknown model (lumi.switch.b2laus01) - PLEASE REPORT THIS LOG TO THE DEV - description:read attr - raw: 10F302000012040042044C554D49, dni: 10F3, endpoint: 02, cluster: 0000, size: 12, attrId: 0004, encoding: 42, command: 01, value: 044C554D49 | parseMap:[raw:10F302000012040042044C554D49, dni:10F3, endpoint:02, cluster:0000, size:12, attrId:0004, encoding:42, command:01, value:LUMI, clusterInt:0, attrInt:4]

dev:3542020-07-27 07:37:46.468 pm infoNo VALID lastCheckin event available! This should be resolved by itself within 1 or 2 hours and is perfectly NORMAL as long as the same device don't get this multiple times per day...

dev:3542020-07-27 07:37:46.447 pm infoRecovery feature ENABLED

dev:3542020-07-27 07:37:46.340 pm infogetDriverVersion() = v0.8.1.0720

dev:3542020-07-27 07:37:46.311 pm infoinitialize()

Not sure if it's still helpful but here's the fingerprint

fingerprint model:"lumi.switch.b2laus01", manufacturer:"LUMI", profileId:"0104", endpointId:"02", inClusters:"0000,0003,0004,0005,0006", outClusters:"", application:"16"

Replied here.

@markus -

Just an FYI. After updating to, I'm getting the following error from devices with your drivers. I won't be home until tomorrow night, so I cannot confirm if the devices are working or not, but I will let you know as soon as I can. Let me see if I can send a friend over to test motion lighting.

That is very sad to see :frowning:
There seems to be a change in platform 2.2.3 which breaks the Recovery feature, set the Recovery Mode to disabled if you're on platform version 2.2.3 just to be safe. I will release a version of my drivers which disables it for the time being if on 2.2.3. Devices will not be as likely to reconnect once they drop with this turned off, but at the moment there is no choice.

1 Like

I'm on 2.2.3 on two hubs, and not seeing these errors. Everything seems to be working.

1 Like

I'm happy to hear that :slight_smile: Not a fun morning waking up to seeing this type of issue :frowning: It's probably because all your devices are fine, this only happens when the driver goes into recovery mode due to finding a device to not be online.

Didn't want to say it but I don't have any either. Maybe the error is specific to some particular device?


Yes, those that have dropped and my drivers start trying to get back online :frowning: As long as all is stable and no recovery-events are needed all seems to be fine. I will push a new driver update for all my drivers disabling that feature on 2.2.3. The update will be pushed in a few minutes.


This really sucks. You do something to help us keep devices connected and the platform has to block it.
Do we know if HE did anything positive to enhance zigbee stability or stop the frantic PAN ID changes in this last 2 2.3 update?

1 Like