Hub becoming more and more unstable

My hub has been becoming more and more unstable over the last month or so, motion lights not triggering or triggering with 30 second delays rule machine scheduled events not triggering at all, modes not changing at appropriate times (sunrise, sunset,etc), actions on buttons responding minutes after buttons are pressed, and dashboards taking multiple minutes to load or never loading at all.

Often times there are no errors in the logs when these actions fail to happen as they should, but this morning i finally saw one

Our towel warmer (lutron switch) is supposed to come on at 8am and didn’t, this was the error in the logs

java.lang.Exception: Unable to aquire lock to schedule run once for delayedActCancel on line 6871 (allHandler)

The app associated with the error is Rule Machine 4.0

I’ve made no changes to this rule since I originally created it months ago and it’s been working fine 99% of the time

That error appears to be a database error.

Edit: Also, based on what I posted yesterday:

What platform version are you running? And, I know you have some Xiaomi/Aqara devices - have you updated those drivers to the latest (especially if you're using or later).

1 Like

Hubitat Elevation® Platform Version

HPM runs every night at 4 am and automatically updates everything.

Had that same error on one of my 3 C5 hubs -- I downgraded to for that hub and all is well again.

It looks like there is a problem with the Xiaomi/aqara drivers:
From a post by @Marcus, "The Beta drivers have been updated so that they disable the Recovery feature when on platform version 2.2.3. The Release version will have that update in a few more minutes. There's 18 drivers affected."
and also "In order to not have to investigate this from scratch, I just want to ask, what EXACTLY are the limits? With 2.2.3 this limit broke the Recovery feature of my Zigbee drivers (I've disabled that feature when running my drivers on 2.2.3 for now):"

Feels like there are some bigger code hygiene and sandboxing issues if this unrelated driver/hardware issue is affecting rules and behaviors of the core system (mode, buttons, rule machine)

None of my slow/or now broken behaviors are related to any of my aqara devices or zigbee radios

How do you know that?

because none of my rules, leverage any logic related to these sensors. And all of the day-to-day automation don't query or have logic based on any zigbeen sensors.

Now the app is failing to be able to reach the hub

Have you opened a support ticket?


Not yet, as I’d historically had much better luck in the forums than support tickets (no replies, multi-week delays, “just restore it”)

Just restore what?


I am experiencing some of the same issues on my C3. Z-wave and zigbee are disabled, used as a app hubs via hubconnect. After updating the hub was stuck at 65%, then rebooted, stuck at 60%. Put the z-wave stick back in and rebooted and was able to complete a reboot. Eventually while working in the hub with the newest update it locked up and was unreachable. Rolled hub back to previous version ( via 8081 and tried reinstalling update with z-wave stick in, update and reboot went well. Eventual the hub became unresponsive again and unreachable Rolling back to previous version and will hope that I don't experience additional lockups.