Critical Notifications- Call my phone?

I've spent several hours combing the interwebs, trying to find a way to make Hubitat call my iPhone with a spoken message... even when Do Not Disturb is on. IRIS used to do this out of the box, and I really miss it. Has anyone found a solution to this? If my smoke detector or motion sensor goes off at night at my other house, I need to know immediately and loudly via my phone. Ideas anyone?
I've used pushover for text notifications, but that's not good enough. As far as I can tell, iOS only lets specified phone numbers through DND.

It has to be verbal? No way SMS can get you there? I ask because I'm doing HE to SMS on my phone. Disclaimer: I know nothing about an iPhone.

It needs to be a ringing phone, so it wakes me up...

Twilio will do this for you and you can trigger it via a http request.

It is a bit technical.

Pushover can break through the iOS DND/Silent mode. You have to enable the "Critical Alerts for high-priority" feature inside the Pushover App, via the three-dot settings menu (upper right corner).

Then, simply prefix your Notifications with either "[E]" or "[H]" for Emergency or High Priority. So, your Pushover Notification for a smoke alarm might change from "Smoke Alarm Detected!" to "[E]Smoke Alarm Detected!"

Using the [E] emegerncy prefix is probably what you want to use, as it will repeat until until acknowledged from within the Pushover App. You can adjust the frequency of the repeats and if it automatically should stop after a certain amount of time in the Pushover Device settings on your Hubitat hub.


Inside Pushover... OK, I think the [E] addition might be loud and persistent enough. If not, i'll try to tackle Twilio :wink:
Thanks all!

I must be doing something wrong... putting an [E] in the message seemed to work once, but it didn't play the right sound. Now it's not working at all. I think I better test this again when I have more time to figure it out.

Make sure you configure your Hubitat Pushover device's Emergency settings.

Also, make sure you set all of the Pushover alert settings to override the alarm sound.

You can set an iPhone to allow calls from all numbers when DND is active.

If you are still interested in an easy way to setup phone calls, then you should be able to use IFTTT and Woopla. I have not used it directly with Hubitat, but I have made some other IFTTT rules that use it.

As mentioned above, this feature is available via IFTTT if you are in the US or Canada. Not sure about other countries.

The calls always come from the same number for me so I add that to my favorites list so that it would get through even when DND is on.

I also use IFTTT to send SMS and Emails as well when needed.

@ogiewon, yes I have all those things set. @gavincampbell I was looking at the offerings in IFTTT, but did not see one to place a call from Hubitat. I did see a few that were specific to certain devices: place a call when a GE device triggers, for instance, but did not see anything that looked like it could alert me to movement or alarm triggers. Can you direct me to whatever applet you are using?

In IFTTT you will want to set up a webhook and tie it into a IFTTT call. That way when the webhook gets triggered it places the call.

I can't tell you exactly how to set it all up but here are some links to some IFTTT drivers that should point you in the right direction.

So.... this just does not work for me. The Emergency sound I've selected does not play. I only get the usual default sound. And it never repeats. But it's a moot point for now. I had to leave the location where this hub is installed before I got everything working.

Weird. It works for me on 2 different hubs, and has for many months.

1 Like

I would need to see the screenshots of the Pushover mobile phone app settings, the Hubitat Pushover Device settings, and a screenshot of the Automation your using (e.g. Hubitat Notifications, Hubitat Rule Machine, etc...) Very hard to troubleshoot without some additional data.

@rob121 Were you able to get this done in Hubitat? If so, can you share how you did it in Hubitat? Having a hard time to figure this one out. Thanks!

Sorry to revive an old thread, but I just updated my Twilio drivers to support voice calls. Please see this post for details:

1 Like

@ritchierich Finally got around installing your Twillio driver and it is working like a charm! This will be a great addition to some emergencies routine. Great work and great contribution to the Hubitat community. Please let me know if you have a paypal account.