Change IP address

I've been trying to change the IP address to a new fixed address for the last three hours. I had managed to set it once many months ago, but now I need to change it.

Settings, Networking ... enter the new fixed IP address . Click the save button.

Then, Settings, Reboot Hub. A minute or so later it comes back online with the original IP address.

The new address that I put in is still on there, but it is ignoring it.

What's up with that ?

Try shutdown, not reboot. I'd even pull the power once it's down. Give it a second and then plug it back in.

Force the NIC to go "off" then it 'should' check the settings.

Tried pulling power as well... no difference

Tried "shut down", cycling power ... same thing. It's still got the new info in there (yes, I did push the "save and switch to static Ip button") but it's still using the original address

I thought setting static IP's was a fairly new feature for HE.
Did you maybe set a reserved IP in your router that now needs to be deleted?



this tomayto, tomahto networking is killing me. :rofl:

1 Like

It's a new router... just installed it today. DHCP range is far from where I am trying to put this hub.

In that case you set you computer to static in order to talk to the hub on the old IP subnet, right? Sorry just trying to see where we are at. If you have all the IP's and subnet it would help answer some ???s

Have you tried a incognito /private window to make sure it's not cache?

Yes. The PC is on the same subnet... not much choice because Hubitat wont allow the Net Mask to be changed from (which sucks btw). I can talk to the Hubitat... just cant change the IP address. I am trying to change it to a different subnet, but it wont move.

Right now the PC is on and the Hub is on

Did you try the reset button on the hub?

Reset to DHCP , then set to static again maybe?

Might have to... I'll have to configure some Vlan settings on a network switch to make sure it lands on the right subnet... This is really lame

Use DHCP reservations, much easier than static for exactly this reason.

Deja Vu

that was exactly why I was trying to set it statically

It looks like it is not possible to change subnets simply by entering a fixed IP address from a different subnet. This is probably somehow related to the fixed network mask thing... which is a real problem.

I have a network that has grown so large that there is no way to keep it all in one subnet. We all will get there eventually. To be stuck with this fixed single subnet is horrible.

No "we" won't. :slight_smile:

Many of us with a lot of devices use multiple VLANs/multiple subnets instead of one giant one.

That said, I would still like Hubitat to make the subnet mask adjustable.


I'm up to 3 Vlans right now. :wink:

And you still have >253 devices in a single VLAN? wow

I have almost 200 IPs in use, but across 4 VLANs, so all are just /24 in size.

I was trying to move this down to 192.168.0.x all afternoon ... it simply wont let me.

I would give it a DHCP address on the new subnet first, then change it to static after. It very well could be the subnet difference that is ticking it off.


You can lead a horse to water....

1 Like