Change IP address

In re-reading this thread you are way over thinking it. You don't need VLANs to talk across IP subnets, if each device has the same static info. We set BS IP's all the time to reconfigure devices.

However, I still see no valid reason you shouldn't reset the $#@% hub to DCHP and set a DCHP reservation.

Do you just want to make things difficult?

EDIT: sorry long day. I'll move on now


I would love to do that... It wont let me.

So you held the reset button for 10 seconds and it did not reset? Just want to be clear.

It came right back up where it was, even though I changed settings. The new settings were still in there, but they were ignored

Sorry man, but you need to understand my time is free, and your not answering the question.

If you didn't push the flipping button for 10 seconds stop wasting our time.

ok I've obviously had enough. night night :zzz:

1 Like

Yes, that was tried

I got it to move... it was a game of chess... first get it to do DHCP on the same subnet, which took several tries of what seemed to be the exact same sequence. Then change the router's DHCP range, reboot it a few times before it came up on the desired subnet. I left it as "assigned DHCP" for

It has lost contact with my Hue Hub... They are right next to each other in addresses, but so far the discovery hasnt worked.

.. been about 6 hours... time to give up for the night


Dunno. :man_shrugging:

As I test I moved one of my dev c7 hubs from one subnet to a other, and back. Worked fine for me (using DHCP, I didn't try static). Something must have been really stuck on yours.

1 Like

I finally got it set to a static address on the preferred subnet where hopefully it will never have to move again.

I then found that if I connect both the Hubitat hub and also my Hue Hub (same subnet) both to a managed switch, they cant find each other. I did find a post about this already, so I am not the first to realize this. I dug up a 4 port unmanaged switch, plugged it into my managed switch, and plugged both the Hubitat and also the Hue up into the unmanaged switch... Hubitat was then able to find the Hue hub.

It just seems like Hubitat wants to run on a very simple network (unmanaged, no extended subnets), which is somewhat counterintuitive to a lot of power users with managed networks I would think.

I have worked around it however. It's not how I wanted to do things, but it was resolvable. Live and learn.

Dunno. I have all unifi managed gear, and multiple vlans. Have never had an issue (that I know about) other than when I messed up the MTUs (which was my fault). Hubitat DEFINITELY does not like it if packet sizes are not what it was expecting - jumbo frame mismatch, etc.

Not sure why an unmanaged switch would be necessary. But if it works, it works. :man_shrugging: