Hub has disappeared?

Greetings all. I'm lost and frustrated. I have a Deco mesh (M5), and Hubitat connected to one of the nodes. All was working perfectly until this power outage. Everything has been offline for several days. Now we have power but the system is having trouble. Most routines seem to be working. Although I have a couple in-wall dimmers that appear to not work at all, even manually. The Hub seems to be hidden. By that I mean I cannot get to the apps and devices page. Alexa works with some devices but not all. I can get to the cloud dashboard and it seems to mostly work. I try "finding" my hub with no success. If I log in to Hubitat, I see my hub there and the IP address is different than before. Typing that address into Safari reveals no result, it just searches until it times out. Complicating this, I just updated to OS Big Sur. I don't know if the Big Sur update is the problem or if the power outage caused something.
Advice is appreciated.

What’s the color of the hub’s LED? And did you have a reserved IP for your hub in the routers DHCP table?

2 Likes

Thank you aaiyar. The Hub's LED is solid green. I believe the hub is working great. The routines all seem to function as set and expected. That's a solid plus for the Hub. I just can't access it. The interface between it and Alexa is spotty or inconsistent. Some things work, some don't. Not being able to access the settings to the hub I can't check or rebuild those connections. I do not have a reserved IP for the hub, although I like the idea.
Here is a screenshot of the hub I can access. It is there.

2 Likes

Do you have an ISP router and Deco mesh nodes? By default Deco use the 192.168.68.x subnet

169.254.x.x is not a routable IP. Your hub might have come up before the Deco nodes. Unplug your ethernet cable from the hub, wait 3 seconds and plug it back in. That should force it to ask for a new IP. Give it about 2 minutes and check the portal again to see what the IP says.

EDIT: Default Deco IP should be something like 192.168.68.X

2 Likes

This. 100%.

@robertsonslodge

Thank you for posting that screenshot - I'm sure at @TechMedX would agree - a picture like that is worth a thousand words!

Also - do set a reserved IP for your Hubitat.

2 Likes

I highly recommend DHCP reservations as well (much easier to keep track of things). However, in order for your DHCP server to set the reservation all networking nodes between the hub and the router, need to be "up". If one or more nodes are still "booting" the request packets will not be received, and the hub will be forced to use a local link IP (169.254.x.x).

If you network consistently loses power (you should get some UPS), and you have to do this often, I would break down and set a Static/manual IP on the hub (label it on the hub) and be done. Again not my "go to" solution, but an option if things don't want to co-operate.

so true, I had about 15 questions that were all answered with that pic. :clap:

3 Likes

Thank you all. I am glad the screenshot was so helpful. It helps to "see" what the guy in need sees. I am trying this now. I'm in Texas and the power grid fiasco is why we've been without power for several days. It has otherwise been stable and rarely do we have such an outage.
I like the idea of a static IP but am not sure how to set that. Once I get this other issue corrected, maybe I can ask for advice with the IP question as well. My router is a CentruryLink combination modem/router. I turn the radio off on the router and let the deco handle the wireless assets.
Thank you for being there!

1 Like

I have a similar setup except I am using a Verizon FIOS router and a Linksys meshed network. Where you control static IP addressing depends on whether you have the meshed network issue IP addresses or whether they pass those requests through to your CenturyLink router. In my configuration I run the meshed nodes in bridge mode so the FiOS router and the meshed network are on the same subnet, and the router does all the IP address administration.

You can set a static, or reserved, IP address through your router's management interface. Each router is, unfortunately, a bit different. Usually it's called something like DHCP server, IP Address Administration, or something similar. It is sometimes found on an advanced configuration screen. Usually you can scroll through a list of attached devices, find the HE, and click on a button or checkbox that ensures every time the HE asks for an IP address it gets the same one.

I took a quick look and CenturyLink supplies a number of modem/router combos. If you know the model # and manufacturer of yours we should be able to find the manual online and look it up.

You guys are awesome! I disconnected the LAN cable as well as the power from the Hubitat, waited about a minute, reconnected the LAN, then the power. It restarted correctly, found a usable IP address and is now accessible as it should be. Thank you! This was making my eye twitch. SO much better now.
My router combo is Zyxel C1100Z, CenturyLink 1370. I know this isn't so much a Hubitat question, but if you have advice, it will help.

3 Likes

Excellent! Thank you all so much.

2 Likes

Use DHCP Reservations first like @thebearmay posted. If needed check out this post to setstatic. If you have questions feel free to ask.

Stay warm! :fire:

1 Like

Sorry I missed this early. I hate to spilt hairs, but the technician in me says I must.

While a "static IP" and a DCHP reservation may result in a SIMILAR outcome, they are not the same.

Static IP Address - is set on the device itself. Once set the device will NEVER ask for an IP address, it will use what you set it to. No matter what network the device is connected to (or if it 's not connected at all) the device will ALWAYS have the same manually set Static IP.

DHCP Reservation - is set on the DHCP server and given out via MAC address. Each device MUST be able to contact the DHCP and request an IP address. When the DHCP server gets a request for an IP, from a given MAC address, the reserved IP is given. If the device moves to a new network, or cannot communicate with the DHCP server, a different (or local link) IP address is given to it.

I still say DCHP Reservations are the best way to go 99% of the time. I just wanted to be clear about a major difference between the two. It can be problematic if you do not fully understand them, and deploy accordingly given the situation.

4 Likes

Yes, good point. I generally use the terms interchangeably even though they are not the same. And yes I agree that a DHCP reservation is the way to go when at all possible. Thanks for the clarification.

3 Likes

OK on the LAN cable. Never just power off your hub. Always shut it down properly via Settings / Shut Down Hub. Otherwise, Bad Stuff Happens!

4 Likes

I appreciate all of this information. This is very helpful to have a better understanding of how this works and some "backstory". You guys have addressed my original issue that had me pulling my hair out and I didn't want to make matters worse. You have also given me a huge step forward in setting reservations (and thanks for the power down reminder). Thank you, everyone.

2 Likes