Cant create Dashboard

I just got a new Hubitat this week. I am a first time user.

I have the Hubitat Dashboard App loaded.

When I click in the App in the App list, and then click on "Create a New Dashboard", it sends me to an Error 404 page. The URL is a local URL (, not a cloud URL.

When I try creating one a different way... Clicking on the "Dashboards" icon on the left side of the screen, it brings me to my empty list of Dashboards. I click on the + sign to create a dashboard that way. It asks me for a Dashboard name and I give it one (OutsideMotion) and click where is says "Add New Dashboard". Up pops another screen that says "Hubitate Dashboad, THis Dashboard is Protected, please enter the pin". I did not add a pin. It accepts a blank pin number when I hit submit.

Then, up pops a mostly black screen with a heding on top that says "Dashboards". There is no mention of the "OutsideMotion" Dashboard that I am trying to create. The "+" option does nothing, the gear icon brings up a one line box that I cant do anything with.

I have tried this with Edge, Firefox and Explorer... nothing gets better with different browsers.

Again, I am all new to Hubitat. What am I doing wrong here ?

If you don’t have a single dashboard successfully created/loaded, I’d suggest removing the dashboard parent app, then reinstalling. If that doesn’t solve it then there’s something else at play, but maybe the initial app install was messed up for some reason?

Remvoved and installed it 3 times so far... no change.

from the error log...

2020-07-26 11:53:38.266 am errorhubitat.exception.NotFoundException: Child app not found for namespace: hubitat and name: Dashboard on line 916 (createDashboard)

FWIW, the tutorials and various videos that I have run across seem to show different screens that what I am seeing. I am assuming that the latest code made changes and they no longer are in sync with the documentation

hello, im trying to create a dashboard with the new c7 and im getting this message "Child app not found for namespace: hubitat and name: Dashboard"

first time user, not very techy. any ideas how i can fix this?

Looks like it's not just me :frowning:

Tagging @bobbyD.

1 Like

Hi there, sorry for the troubles. Would it be possible for you to try with Chrome as well? Legacy Microsoft Edge as well as Explorer are not supported. Also, if you didn't do so already, please go to Settings and click Hub Reboot.

1 Like

Rebooted hub, no change.

Tried Chrome, no change.

Same error message "hubitat.exception.NotFoundException: Child app not found for namespace: hubitat and name: Dashboard on line 916 (createDashboard)"

I did get a status message that says "Damaged database detected, unable to restore from backup.".

Not sure if that is the issue... how do I fix ?

In that case it sounds like a soft reset is in order. When did you get that notification?

Hub documentation re: soft reset is here:

Ideally you restore a backup that was from sometime before you got that notification, at least.

Do you have any backups stored off the hub? It keeps several of its own but not an unlimited #.

1 Like

I just plugger it in for the first time an hour ago... Havnt been able to get anything to work, so no backup. I didnt notice the error notification untill I did a reboot.

If the hub’s acting that way while essentially brand new, I’m out :slight_smile:. You’d be in better hands with @bobbyD to get you to the correct solution.

Edit: is yours a new C7 hub like @rq208 mentioned he/she is using?

Problem solved with Chrome, thanks for your help!!


Tried to do a soft reset. It wanted the Mac address as a password. I grabbed the mac address out of "hub details" and tried both pasting and also typing it in/ Both ways it says "incorrect password"

Yes, Brand new... opened box this morning

OK... I dont get this, but I rebooted it again and I was able to create a Dashboard this time with no errors...

Very weird.

Something is not right. Please send us an email at so we can further investigate.

@rq208, glad to hear you problem is solved.


@bobbyD didn’t work for me in chrome, or after a reboot, any ideas? I would rather not lose all the devices I just added to hubitat. Maybe backup and restore?

That's odd, have you removed the pre-installed Dashboard? If so, please remove it, then reboot and re-install.