Cant create Dashboard

And flush browser cache?

1 Like

@bobbyD I have tried uninstalling and reinstalling the dashboard, but it never worked. I have also tried restarting while the app is installed. But I didn’t try it in the order you stated. Now it is working.

I did:

  1. Uninstall dashboard
  2. Restart
  3. Reinstall dashboard
  4. Restart

Now it works even in safari


I'm having exactly this problem. I just plugged my new C-7 in last night. I found this thread by searching for "Child app not found for namespace: hubitat and name: Dashboard".

A reboot seemed to make the problem go away.

I am first time user, trying to setup the brand new Hubitat which I bought two weeks ago. Getting " This Dashboard is Protected, please enter the pin" error. I don't remember setting the pin, tried login password but didnt work.

Check your dashboard’s settings page from the hub’s admin page. That’s where PIN codes are set.

I navigated to app list page I went to dashboard and clicked on the "create new dashboard" . And getting 404 error.

Do you have any dashboards created already?

Trying to create first time.

Which web browser are you using?

Removed the dashboard app multiple times from both safari and chrome. Same result. Asking me to enter PIN , When I submit with empty pin it says loading devices but nothing shows up. And dash board is not saved.

From the clicking the "Add new dashboard" from APP List -> dashboard app. Getting 404.

No PIN setup option found under App List - dashboard app-> settings

Did you try what I wrote in the post immediately before yours? If a reboot doesn't work, then try what was written in the post immediately before mine.

If it’s not as simple as switching to chrome and confirming it’s working fine, then...

1 Like

Worst, I can't get the reboot working from :8081 port address. I tried the Mac address with and without " : " . I made sure I copied the Mac from device registry info. Also validated against the Mac address printed on the device back.

You don't really need to go to 8081 to reboot. You have an option to do it from Settings >> Reboot Hub (Shutdown also available).

As for not being able to log into the Diagnostic Tool, please go to below path while on the local network to update the Diagnostic Tool:


*replace yourHubIP with actual IP address assigned to your hub.

1 Like

When I had this problem, I was only using Chrome. All I needed to do was reboot (not reset) and it worked.

Got the 404 with a brand new hub I just brought online. A reboot fixed it.

I was having this problem as well. Not sure if this helps but here goes:

It seems to happen when first installing the dashboard app

  1. Remove app
  2. Install App and select "Done" - Don't adjust any settings just yet.
  3. From here, you should be able to go back to the dashboard app settings and create a dashboard.

I hope that helps. First time user here. Just arrived in AU today.

1 Like

Got the same problem with a rand new C-7. Did a reboot, and all is well...

Same issue after Hard Reset. Reboot helped

I did a hard reset, and now it is doing it to me as well.. reboots did not correct the issue so far.

edit: I did the uninstall, reboot, install, reboot and then went to create a dashboard.. That seems to have worked.