C-7 Diagnostic Tool

So I thought I was going to slick and backup/restore the C-5 to the C-7. Was a little wonky so I tried restoring to the previous backup on the C-7. Still was acting funny. So I decided to try out the Soft and/or Hard resets and ran into a bigger issue.

I cannot log into the Diagnostic Tool page. I have tried every combination of mac formatting with no luck. I even tried the C-5's mac in case it somehow overwrote it during the restore. No dice. I can log into the C-5's page perfectly fine though.

Probably will open a ticket, but I was curious if anyone else has tested it yet.

I offered this yesterday and it did fix at least one C-7.

1 Like

Ah, I'll let it sit and see if the Tool activates and updates. My C-5 is on 1.0.75 and the C-7 is on 1.0.72.

1 Like

Sorry for the troubles. Please let us know if you continue to have problems logging into the Diagnostic Tool. For others having hard time logging into or guessing what how to format the MAC address, the way I do it, is by going into hub's web interface: Settings >> Hub Details, then copying the MAC address and pasting it in the Diagnostic Tool :slight_smile:

Currently, it is still at version 1.0.72 and cannot log in.

You can also get the MAC address from the portal's hub details as well. :slight_smile:

1 Like

Can you please PM me with your MAC address or HUB UID?

Thanks to @bobbyD for the help getting the Diagnostics Updated. Login is successful afterward.


Glad to hear your problem is resolved. If anyone has problems logging into the Diagnostic Tool, please go to below path while on the local network to update the Diagnostic Tool:


*replace yourHubIP with actual IP address assigned to your hub.


I see the first post talking about backing up from his C5 and restoring to his C7. How can this be when the

Hub Protection Service

still shows 'SOLD OUT'?

I tried updating the DiagnosticTool but got

success true
message "No Update for Diagnostic Tool Available."

Where are people getting the Hub Protection Service?
I've had my C7 for a week and I'd REALLY like to play with it!!!

Announced, but not yet released.

Wow, that was quick!
So how did jhciotti get a copy and, more importantly, how do I get one??
(feeling sooo leftout)

Not sure what you mean. There is no “copy” it’s a subscription service. It’s not released. No one has it.

1 Like

There are a couple different things that sound similar.

Hub Backups will only back up the database, which mainly includes your rules, automations, and other apps. There will be placeholders for Zigbee, but they will have to paired again. However Zwave does not transfer over this way, it will all have to be paired from scratch, and you will have to fix all rules and automations that have Zwave devices in them. This is the way things have been done until now.

The Hub Protection Service, which is not yet released, is in theory supposed to do full backups. That includes paired devices, along with automations, rules, Zigbee and Zwave radios, and so on. It is supposed to be a full and complete backup and way to transfer to a new hub.

Edit just so it is clear, the OP is doing the first method.

1 Like

Sorry, I saw the word 'Restore' and got all excited.
So how do I get to the Diagnostic tool and why can't I update it?
I had assumed this was part of the Hub Protection Service.

Oops, I did a search and discovered

Hubitat Diagnostic Tool

but still not sure why I can't update it. Do I simply not need to?

What version is your Hub Diag Tool on? Normally, users never need to manually update this tool. It happens automagically in the background, if your hub is connected to the Internet and registered to the Hubitat Cloud server.

My hubs are all running 1.0.75 of the Hub Diagnostic Tool.


Yes, that's the version I have.
Thanks for all the very quick help. I had no idea the Diagnostic tool even existed.
So many new toys...

1 Like

My C-7 shipped with 1.0.72 which wouldn't allow me to log in with the MAC address. Updating to 1.0.75 using @bobbyD's instructions up above fixed things.

1 Like