Built in Aeotec MultiSensor 7 driver might have a bug?

Aeotec MultiSensor 7 built in driver seems not to implement the sensor capability which is impacting how other apps and such "see" it and what you are do with the Aeotec MultiSensor 7. They see it as "other" or "generic." I did a diff on data coming from the Aeotec MultiSensor 6 vs Aeotec MultiSensor 6 and it seems the 6 shows "capabilities" include "Sensor" and 7 does not.

Is there a community driver for the multi 7? I'd love to reduce the motion reset time as it's about 3 minutes, too long imo. I've looked but can't seem to find anything.

I’d like to reduce mine as well. Was going to look into it to see if it could be done but haven’t gotten there yet.

Hi, I figured out how to reduce the motion active reset time on the multi 7. You can use either a zwave parameter tool, or download the "multisensor 6 (advanced)" driver. In the multisensor 6 (advanced) driver, there is a field to enter the number of seconds before the motion resets. However, in this version of the driver, it states that 20 seconds is the minimum valid value. This is incorrect for the 7, and if you enter 20 it will not stick. Use 30 for the min value and it should work, it did for me.

1 Like

Also make sure you have the latest firmware early firmware was rubbish

1 Like

@mike.maxwell wouldnit be possible to update the built in driver for the Aeotec MultiSensor 7 to include the ability to modify the timeout value?

if its listed as a parameter on the zwave alliance site then yes, otherwise no...

How do we know if it’s listed?

https://products.z-wavealliance.org/products/4088/configs

It would appear the default is supposed to be 30 seconds

1 Like

I’ll add this parameter

5 Likes

Thank you!

Mine came from the factory set to 240s.

In the manual on page 8 Parameter 3 shows the default is 240.

Looks like they changed this after the pre-release they sent me and certified with… I’ll be adding this to the parameters so it can be changed..

1 Like

I hope it's appropriate to post this here, but I just want to throw it out there... These Aeotec multi 7's are bad. On paper they looked great, and I was anticipating them for over a year. Now that I got my hands on a few, it's just more problems, just like the 6's.
I wanted to like these because I think the Recessor kit looks really slick, combined with the ability to mains power. After patching up my ceilings from the three Recessor kits I had installed with multi 6's, I smartly installed the 7's only temporarily with double sided tape. Yes I've updated to the most recent firmware, and what I'm finding is these units sometimes seem to be stuck in a sleep mode and don't fire off motion events. Once they're awake they seem to work just fine, but if I leave a room for over a day, and then come back, the automation to turn on the lights doesn't work immediately, and I have to wait at least 30 seconds or so before the Multi 7 starts sending messages.
With that said, I'll just throw this out there. Someone, I forget who, turned me on to NYCE motion devices, and yes those have been rock solid performers. The ceiling mounted motion sensor may not recess like Aeotec's, but they're small enough it's really not a huge concern.
Unless I just have something configured totally wrong, I am marking this product a dud and I'm done with it.
...And I've been testing two of these 7's, they both act the same so its not a bad unit...

1 Like

These Aeotec multi 7's are bad.
I could not agree more. The Euro model I have identifies as an energy monitor switch. When I select multisensor 7 it provides the temp and humidity, I cannot get any other features to work.

If connected to the Aeotec smart things hub it is capable of this.
You can configure how often its sensors will be reported, the sensitivity of your motion sensor, and when motion sensor will timeout and allow for retrigger.

  1. Find your MultiSensor 7 in your SmartThings dashboard.
  2. Tap on your MultiSensor 7 to open the device page.
  3. At the top right, tap More Options (3 dots).
  4. Tap Settings.
  5. You can configure these 3 settings:
  • Motion Sensor Delay Time - Allows you to set the timeout of motion sensor.
  • Motion Sensor Sensitivity - Sets how far/sensitive your motion sensor is.
  • Report Interval - Sets the timeframe in which all other sensors are reported (temperature, humidity, light, UV).

The blame for these capabilities not being available must point directly at Hubitat for sloppy coding. Aeotec announced this item months ago, It was listed as compatible by Hubitat and Aeotec and Vesternet in the UK. I have encountered the same issues. My question to Hubitat is "should it really be down to independent hobbyists to correct / modify / improve the sub standard drivers provided. The industry is being held back because of non co-operation between the manufacturers. Last month seen a big player in the UK go bust (Aurora) while Tuya devices and wifi devices proliferate.

Update: I updated my hub and updated the Z-wave and it now identifies as a multi 7, the facilities available are just the same as they were after I changed it to a multi 7 manually. Just as described by others. Temp works, humidity works (so does the sonoff for 1/4 the price though) motion is sporadic and frankly unacceptable. Lux works if the delay is acceptable to you, UV and vibration forget it, it might as well not have these features.

This is unfortunate to hear. I was following @guywmartin’s posts over the last year

I was hopeful these would solve the issues I have with my MS6’s in ceiling recessors. I almost bought a few over the summer but now glad I didn’t.

Any idea on timeline?
As you can appreciate I have paid £65 / $65 for an Aeotec multisensor 7 that I now need to make the difficult choice of (return as it is not fit for purpose) or (keep and hope Hubitat unleash the power this device has). Changing the temperature refresh is also important to me as I plan to use this to control a TRV.

1 Like

The answer is and always has been basic zwave tool driver
My 5. 7's have bee working faultless for nearly a year using this to set them up.

Download the Hubitat app