Bug in simple automation 1.1, firmware version

I hope I'm wrong.

I created a virtual switch that is turned on and off by a contact sensor open and close.

The virtual switch changes state from off to on when the contact sensor closes, but then never opens as the contact sensor is cycled.

I noticed the same behavior when I did an off line test with two virtual devices (the wife is asleep).

test virt is the virtual switch and test cont is the virtual contact sensor.


1 Like

Here's another log with app logging turned on.
It seems to turn on the switch, but not off, despite the option chosen.

I guess I'll have to make two apps, but this used to work, just a little while ago.


Could someone else verify this? @bcopeland ?
edit: I tried lengthening the delay, to no effect.

Same here


So, I'm not losing my mind, lol.

Found another one.
I now have to go through and create separate "turn on" and "turn off" rules. That is, if I don't want the wife to get pissed off, again. Or, until this gets fixed.
edit: A second rule, a "turn off", work with turn off after x minutes.
edit2: I've got a few of these. Hopefully, I can do work arounds until bug is fixed.

Blue works. Red does not.


Can’t find the thread right now, but I thought I read where someone said they had to set the number of minutes to a value greater than zero to make this work.

That was the one below. Didn't work for me.
Try it yourself and see.
Thing is, just like the sunset thing, this is a very common usage-not exotic at all.

This one, motion sensor (vs contact sensor) with delay of 3 minutes works.
Maybe a clue is in the different formats, lol. But seriously, something changed.

I tried it with zero off delay after motion and that worked as well.

Something is definitely afoot here and here.

Changing the timeout as I had first thought doesn't actually help; the back garden lights are still blazing away out there.

Our problems are similar though.

For me, if I make apps to turn things off, using only the blue circled parts, things work. So I can still get in a delay that way.

And for me, motion still works.

Oddly, if I have an opening contact sensor trigger the closing of a switch, it works fine.

Still not working with .148
@bravenel , @bcopeland or someone, could you please look into this when you have the chance?

This seems to have been fixed in .151 (I've become a beta tester only because things aren't working too great elsewhere, lol).


great .. anxiously waint for .151 then to test with my setup with the same issues.. did they say what was changed.

z-wave stuff

Thing is I changed a lot of rules from starting with turn something on, to turn something off, only because that worked. Now, should I change them back? lol

1 Like

so does contact open
(door or motion) with ecolink to turn on lights work consitently now in .151 with no delays or are you not sure yet? As you know the problem was intermittant like something intermittantly spamming the zwave mesh and delaying crap. With nothing relevant showing up in the logs ... of course.