[Broken] MyQ Lite Application

Anyone else have a non responsive garage door with 403 errors in the log using HE but it works with the MyQ app? Unpluggling then repowering my MYQ 828LM device seems to fix it.
Update: repowering the 828LM does not fix it!

See this thread

403 error is also happening on other platforms



They changed the authentication.. it no longer works. Moved to local.

1 Like

May I ask what you are using?

Local Control Options for MyQ Garage Door Openers - :bellhop_bell: Get Help - Hubitat


Ah great… So awesome when they do that…

Yeah, i gave up on the MyQ last week when I couldn't even get the MyQ app to talk to it, and the GDO wouldnt rejoin the Wifi when I reset. I'm using a garadget, a Zooz multi-relay and the Zooz GDO application. So far its been great!


1 Like

Can you clarify?

Presumably you’re using the Zooz relay to control the door via a pre-wired Security+ 2.0 button sold by Garadget?

And not a Garadget opener itself?

I'm using a smart implant.

1 Like

Exactly -- the garadget sold prewired Security+ 2.0 button, thus:

As recommended in this thread: Local Control Options for MyQ Garage Door Openers

Thanks Ashok. :slight_smile:


1 Like

I had spoken the company they will even set you up with a wire for turning the light on and off. You may need to ask them.

The light on mine is motion sensor connected. I also have 2 led bar lights on a Zooz switch which i could trigger on door activation or motion if necessary....


I removed power from my MyQ 828LM device and the Android MyQ app correctly shows the door status with a big qustion mark. However, the HE MyQ app and device continues throwing 403 errors when attempting to open the door with the HE device's Open command.

Kindly help me out here, I'm confused. Unless the HE MyQ app/device is not using the MyQ 828LM device's cloud connection, can anyone explain why or how it is possible to get a 403 error with the MyQ 828lm device disabled? I would expect a timeout or something similar.

Update: Answering my own question. It's not using the 828LM or builtin door opener cloud connection

Woohoo I think I fixed the HE Myq app 403 error! Following instructions in this Reddit thread, I changed the following MyQ Lite app version 3.1.3 statements at lines: 1035, 1068, 1122, and 1157. Seems to be working for me.

Lines 1035, 1122, and 1157 From:
headers: ["User-Agent": "null"],

To: (or whatever user agent string you want)
headers: ["User-Agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/117.0"],

Code at lines 1067-1070 to
headers: [
"User-Agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/117.0",
"Cookie": cookie

Reddit solution follows
Thanks @lygris, that did work.

  • docker exec -it homeassistant bash
  • cd /usr/local/lib/python3.11/site-packages/pymyq/
  • cp request.py request_bup.py
  • vi request.py
  • i to enter insert mode
  • Modify line 34
    • Was self._useragent = None
    • Is self._useragent = str("anytexthere")
  • Esc key to exit insert mode
  • :w + enter to write the changes
  • :x + enter to exit VI
  • Restart Home Assistant

Yes, thank you! That worked for me as well.

1 Like

Here are a couple of observations from my experience.

MyQ Lite stopped working a few days ago. Today I went into MyQ Lite app and tried to edit my account - that failed, likely due to the error 403 folks have identified. That said, after walking through the app and hitting done - it magically started working again.

After it was working again I followed @arnb instructions and now I AM able to reconnect My Account in the app. I initially missed the fact you have to change the headers string on ALL FOUR lines @arnb identified.

I believe there are multiple "things" going on here. The fact folks could not control doors from the native MyQ app on their phone (not HE) likely means there was a back-end issue going on. Over the last 3 years there have been several instances where MyQ stopped working - sometimes for many days - then started working again.

The fact the Redditers identified the header issue should allow MyQ Lite to continue working for as long as Chamberlain doesn't permanently break the functionality.

We know MyQ Lite is "no longer maintained" - but any chance someone could update it with this fix so future users won't have to manually edit the app code?

1 Like

I’ll second that ask - That would be great for future users. :slight_smile:

Hey @jsarcone do you have any issues with your local control?

I tried going local a couple years ago, Zooz Zen17 and the Security+ 2.0 from Garadget. I have/use a tilt sensor today with MyQ Lite. I also have NC sensors for both open and close position of the door (though I removed the Zen17 long ago after MyQ Lite was working again).

The biggest problem I ran into was having multiple "triggers" pushing the "button" and causing the door to misbehave. Specifically, a second push during an 'open' operation causes Liftmaster to stop. A second push during a 'close' operation causes the door to reverse and leave it open.


The repository storing these files are still on Dman2306's GitHub. Only he can edit them. You can make a PR and if/when he sees it, he'll take action.. which includes ignoring it :slight_smile:

The second option is to Fork the repo, which a lot of people have done already, apparently. Anyone that wants to can become the new maintainer that way. The problem is in getting the word out... how many conversations point to this Topic? and everything in this topic points to the existing repo.