[Beta] Wink Relay - LAN Integration

community_app
community_driver

#43

So this thread is awesome and the app is great!

But I am very new to Hubitat and I am missing something. How do I add say Relay 1 off a hacked relay to a lighting scene or to a dashboard command? This seems like something trivial to do, but I am just missing the place to do that. You can associate the device to anything, but you cant specify the relay to trigger from what I can see?

any help would be awesome.


#44

Also, I have one Relay that wont update via Wink... how important is doing all the updates to this process?


#45

For Rule Machine, you'll need to create a custom command to control the individual relays.


#46

Really great app/driver!
I'm a recent Wink refugee, and I can't believe I waited so long to switch. I've converted the first of my 3 wink relays and now I'm trying to figure out capabilities. I've figured out how to use a custom command to turn the screen backlight on/off.

But I can't figure out how to read the proximity value from the relay. I see that it's displayed in the device information, and can even see it updating. But I guess I'm new enough that I can't figure out how to get to the value for use in rule machine.

Any tips?

Thanks!


#47

Thanks for the kind words and glad to hear that my custom app has helped in your transition.

I don't personally use Rule Machine (and my Wink Relays are all back in their boxes), but you might get better luck posting in a Rule Machine thread. :grinning:


#48

@josh I don't know how complicated it is or not but any chance you can kinda explain how to modify the code get the both relay switches show up as separate devices or child devices in Hubitat? Or point me to some docs I can look at. I realized you not using the Wink relays anymore.


#49

What have you researched so far? After a quick search on the community, it looks like this would be the approach for parent-child devices on Hubitat:

Based on a quick look, it seems to mimic much of the SmartThings approach to child devices, so my STWinkRelay code from SmartThings which uses a parent-child approach may be helpful to you as a reference as well:


#50

Hi,
I'm very new to Hubitat, coming from Wink. I've never used Android and I think I got stuck in the process at the point after "adb install -r STWinkRelay_0-3-0a.apk". This command seemed to work pushing the file into folder /data/local/tmp/. However the app doesn't appear on the Relay screen. Do I need to "install" it first? I don't know what to do as the next step. Again, I've never used anything Android. How do I make the the new Relay appear on the relay screen, and how do I start the app?


#51

Can anybody offer help?


#52

Where are you stuck exactly?

  1. Open a command prompt as Administrator on your PC and navigate to the C:\ADB folder.
  1. Type adb connect ipaddressofwinkrelay and hit Enter. If this fails to connect, reboot the Wink Relay using the small button at the very bottom and try again once it comes back up.
  1. Once you are connected, type: adb push wink-projectone-release.apk /data/local/tmp
  1. When it completes, open an ADB shell by typing: adb shell
  1. Type SU to elevate your permissions: su Note: You'll need to Allow su to run as root by tapping Allow on the Wink Relay screen after typing this command.
  1. Change your working folder: cd /data/local/tmp
  1. Mount the file system as read and write: mount -o rw,remount /system (Note the space)
  1. Copy the old Wink app to tmp folder and rename it: cp /system/app/wink-projectone-release.apk /data/local/tmp/wink-projectone-release-orig.apk
  1. Remove the old Wink app: rm /system/app/wink-projectone-release.apk
  1. Copy the new Wink app into place of the old one. cp ./wink-projectone-release.apk /system/app/wink-projectone-release.apk
  1. Set permissions on the new Wink app to allow it to work: chmod 644 /system/app/wink-projectone-release.apk
  1. Clean the Dalvik Cache to remove all traces of old app: rm -rf /data/dalvik-cache/*
  1. Exit ADB shell by typing: exit (Note: You may need to type this twice, pressing Enter after each one to get back to the C:\adb prompt)
  1. Reboot the Wink device: adb reboot

#53

These steps aren't necessary. When rooting the device, you can stop at step 32.

We end up installing a custom app that replaces the Wink Relay built in app, so the steps you quoted aren't necessary.

Did you see the STWinkRelay app installed in the app drawer of the Wink Relay? If you installed Nova Launcher per step 16 of the linked guide, you should be able to open the app drawer and see the installed app.

The ADB installation approach is also more of an advanced approach. Any reason you didn't just want to install the app from a web browser installed on the Wink Relay (also should have been installed in step 16 of the linked guide)?


#54

Thanks for trying to help.
I completely missed these steps because I could not find "Root Package Disabler (VuDanThanh)"

"33. Open APKPure again and search for Root Package Disabler (VuDanThanh) and install it.

  1. Open Package Disabler, and swipe left to the System category. Scroll down to find the WinkUpgrade (com.wink.winkupgrade) service and check the box. You'll also want to disable the Uber Widget (com.wink.widget.uber) and the Fitbit Widget (com.wink.widget.fitbit)."

I found and downloaded an app called "Disable Application" but when I started it it didn't find the services mentioned in the description (com.wink.winkupgrade etc).
I did all the following steps after.

At "42. Type SU to elevate your permissions: su Note: You'll need to Allow su to run as root by tapping Allow on the Wink Relay screen after typing this command." there was no message on the Relay screen so I couldn't "Allow" anything.

When i reboot the Relay the old Wink app starts automatically.

My homescreen apps look like this.


#55

Here's a download link:
https://apk.co/vudanthanh/root-package-disabler-119


#56

Hmm, now I can't connect to the Relay anymore. That worked before. Yes, the IP is correct.

  • Andres-iMac:Downloads andre$ adb connect 192.168.1.62:5555

  • failed to connect to '192.168.1.62:5555': Connection refused


#57

Just to reiterate, you should stop at step 32. There is no need to install and package disabler, custom patched Wink Relay app, or anything.

All you need is to get the device rooted and then install the custom STWinkRelay app from this thread. The custom STWinkRelay app will handle disabling the built in Wink Relay app and then takes over all the functions.


#58

Hmm, ok that wasn't clear to me.

OK, I was able to run the install. But the app doesn't show up on the Relay screen.

Andres-iMac:Downloads andre$ adb install -r STWinkRelay_0-3-0a.apk

Performing Push Install

STWinkRelay_0-3-0a.apk: 1 file pushed. 0.4 MB/s (1211447 bytes in 2.735s)

pkg: /data/local/tmp/STWinkRelay_0-3-0a.apk

Killed

Andres-iMac:Downloads andre

I'm not sure if "Killed" means it needed to kill the installation or if the installation was successful. But the app is not on the screen.


#59

Did you try installing it from the browser?


#60

Nope, I'll try it right away.


#61

Wow, that worked. Happy Camper here. Thank you so much. Greatly appreciated.


#62

Did I miss how to get a hubitat dashboard loaded up in full screen on the rooted relay?