Aeotec ver 7 repeater question bad handler?

I just added another one and noticed a couple of issues.. Apparently becuase I updated my firmware in the hub this one paired as the aeotec ver 7 repeater.. But the on off for the light is not working and there is no refersh like the older generic zwave repeater.

I occastionaly use refersh and then check the logs to make sure it is still working.. and the generic also reports it is on the mains.

The specific one. reported nothing.. lights not working , nothing in the logs at all. I think there is a problem with it.. Anyway is there any reason it is better than using the generic zwave repeater driver?


Most driver changes require clicking configure after the change. Do you see it in there?

No I did click configure it was a new install/pairing. must be loosing it.. ignore my ramblings it is a user device handler that i must of installed at some point .. I have changed it to the stock one (same the other sensor is on) If i want i can add refresh to the user one and also report to who posted it that the light on/off is not working.

One thing I will note is that there is a defect with the indicator light in the 1.01 firmware for the RE7. Aeotec released 1.02 about a week ago or so, which fixes the defect.

You don't need a driver for the device to function. However if you want to control the light, there are a couple of drivers around. If you are okay enrolling the device insecurely, I have one here:

@bcopeland also has one that presents the indicator as if it were a switched light. You can find it here:

I don't know whether Bryan's works with secure enrollment or not. However if anyone's would, it would be his.

1 Like

Where did you find this? I couldn’t find any firmware update for the RE7 on the Aeotec website.

His driver, which I use, has the code for secure pairing, but I haven’t tried it on my C-7, which sits powered with no devices until things stabilize. I didn’t try secure pairing on my C-5.

Ask Aeotec support for it.

1 Like

My driver has similar code, but I have it disabled because it didn't work. I've subsequently started to think that it may have been an issue with earlier firmware either the C-7 or the RE7. Haven't had time to go back and re-test. Been too busy with other issues. Soon. :slight_smile:

1 Like

Support ticket submitted. Thanks.

if you get an updated firmware please let me know as I would like it as well.. take care

I spoke with Aeotec support, and they said I could give out the GBL file. PM me and we'll figure it out.

i decided not to update.. i plugged in the aeotec control and found the deice but in order to update it . i would have to unpair it and repair in non secure mode, then unpair and repair again in secure back to hubitat.. Seems like a lot of work just to get the swith working.. Were you sucessful in updating.

in addition. the pc controller s/w does not recognize the .gbl or file as a firmware file.

I've updated RE7s several times with PC Controller as a stand-alone. You need to have PC Controller 5 to support gbl.

The RE7 may need to be securely paired in order to update the firmware. I've not been able to do it insecurely, but I haven't worked too hard at it. Outside of the potential firmware update issue, I'm not sure I see much of a reason to pair the RE7 securely.

iI Am running 5.38 or something. when i click on the upgrade firmware from file.. not the web based on and it prompts me for a file .gbl is not one of the recognized extensions.

Is it possible you’re clicking on OTW instead of OTA?

ive tried both ota and otw this is as far as ive gotten ota doesnt find anything and otw doesnot recognize the .gbl type

Select the device, then click on Get in the Current Firmware section. This should fill out the current firmware info. Following that, click on the file folder icon, and select the gbl file. If the Update button is greyed out, you need to select the firmware target (there is only one). You can then do the Update.

The update takes a long time. You'll know if it is working if the X of Y (6144 IIRC) counter increments. All my successful updates have been done as a stand alone controller with the RE7 securely paired and in direct range of the stick. Your mileage may vary.

1 Like

Ya never comes back with any info

You're saying that when you select the RE7 node, and do a Get, you don't see any information returned?

Yes exactly

Do things like Node Info work?