[RELEASE] Aeotec Range Extender 7

Hello,

If anyone is interested, I have released a driver for the Aeotec Range Extender 7.

Code can be found here: GitHub - dennypage/hubitat: Hubitat drivers and applications

Please note the issues in the readme regarding limitations in the current firmware.

Denny

5 Likes

The driver has been updated to version 1.2.0. This version brings the following changes:

  • Range test improvements. The test will now show as "pending" until the device has responded indicated that the test is actually underway. Feedback on the number of frames received is also provided.
  • Power level set changes. Power level set has been changed from a preference to a test command with timeout. The preference approach was based on my misunderstanding of the intent behind the POWERLEVEL_SET command. Thanks to the engineers at Aeotec for clarifying this to me.

The firmware bug with the indicator light is still outstanding. I have tested a fix from Aeotec in beta, but they have not yet indicated when new production firmware will be released.

I'm getting an error about missing a required parameter when doing a range test.

Also, I don't quite get the comment about being securely enrolled vs. S2.

S2 is more a mode of operation than security. However, with S2, you have several options for more security. As an "S2" generation of the device, you'd certainly want it using that protocol and Z-Wave standard.

Perhaps more clarity on exactly how it should be paired would be useful. Thanks!

On the driver page? Or in the log?

I was in the Device Page. I entered a Node and clicked the button to do a range test.

Secure enrollment, such as S2, does not affect the device's behavior as a repeater. Repeaters are unaware of encryption for packets they forward.

Secure enrollment would cover the ability to turn the indicator on/off, and to conduct a range/power test. One could argue that a range/power test could be used as a form of DOS, but I would generally consider that to be of little importance. There are much easier ways to conduct a DOS attack on a Z-Wave network.

Note that the driver described on herein does not currently work with the RE7 enrolled in secure mode.

So, I need to uncheck even the "unauthenticated" S2 versions and go only with the "S0" one?

So, you entered a node in the node field below the Range Test button, such as node 1, and you pressed the Range Test button. Where do you see the "missing a required parameter" text?

If it says "Please complete the required fields." this means that you have not entered a target node.

The RE7 does not support S0. It supports S2 authenticated, S2 unauthenticated and no security. To enroll without security, simply uncheck all the boxes when prompted for which security method to use.

I got a pop up for "Please complete the required fields." I def had a target node entered. But, that was one I had set up for "S2 Unauthenticated"

I put 7A in that field for the node. I assume I don't need to convert from hex to decimal.

The "Please complete the required fields." comes from the hub software. The driver has no control over the imput operation.

Seeing that messages means that you didn't have a node entered, or what you entered wasn't a valid integer (decimal) number. If you see it again, please post a screen shot.

Ah. Yes, it is type "NUMBER" which is a decimal value.

1 Like

I speak computer--so I think Hex is a number. :slight_smile:

Got it all sorted out now. You might look at clarifying all that in the doc. :slight_smile:

Good suggestion. Thanks.

1 Like

what is the range test supposed to do . I tried it with two different repeaters i get this in the logs then nothing.

dev:5452020-09-07 04:43:18.200 pm infoRange test pending with node 72: sending 10 frames at power level normal

dev:5452020-09-07 04:42:33.177 pm debugConfigure

dev:5452020-09-07 04:42:32.154 pm warndescription logging is true

dev:5452020-09-07 04:42:32.150 pm warndebug logging is true

dev:5452020-09-07 04:42:32.145 pm debugUpdated preferences

--- Live Log Started, waiting for events ---

also when i do refersh on the stock generic repeater driver it reports that the device is on the mains so i know it is working.. this one does nothing.. can you add that?

ok then what is the point if having teh range test and power test and switch. if those only work in secure mode and the driver currently does not support secure mode? Confused

Is it paired securely? The driver does not work with it paired securely...

Not sure where the concept that range and power test only worked in secure mode...

The driver currently only supports insecure enrollment. I.E. uncheck all the boxes when enrolling on the C7.