ZWave repair/ failures on devices when repair all, but succeed if done 1 at a time


I am doing a zwave repair, and if I try repair all, I get errors on some devices.

But if I repair those devices 1 at a time, the repair succeeds.

Unrelated, there are 3 devices that I force removed and now are just there in the zwave info as nodes.

See if you can remove the now-missing nodes and if that helps. If you don't see a "Remove" button already, try a "Refresh" or two and you should. If not, it's likely the device is still online somewhere, and unpowering it or resetting it will need to be done.

That being said, if you've already done the repair on all nodes, a network-wide repair won't do anything different, and per-node for only relevant nodes when/if needed (rarely with Z-Wave Plus unless you want to speed up the automatic process) is usually recommended anyway.

1 Like

Force removal usually end this way, unfortunately. Assume you know this, but just in case, always try to exclude Z-Wave devices (put hub in Exclude mode, put device in exclude mode) before you resort to a force remove.

If the hubs built-in Remove option on the Z-Wave Details page fails to remove the left-over nodes from the force removal (we call them "Ghosts") then take a look at the post below for more details and options to remove the ghosts.


For these 3 devices there is a button “discover”

What does that mean?

We're talking about the "Status" column, where one of the above buttons should be. If you see a "Discover" button in the "Device" column, it means that the hub does not have a device in its database for that node in your Z-Wave device table. In your case, this was likely caused when you force-removed the device instead of doing a regular exclusion.

Yes. It's called a ghost. You need to remove them for your mesh to be healthy otherwise you will have major issues. Can you post your z-wave details in it's entirety? Use windows snip

Usually, you can use the hub to remove Z-wave ghosts, but some are stubborn and resist removal. If that happens, it might be necessary to use a Z-wave USB stick and the free Silicon Labs Simplicity Studio 5 software to remove the ghosts. I have no idea why SiLabs named the software as they did as there is nothing simple about it. However, once you figure it out, it does get the job done when you have tried and failed with other methods.

I had to remove one today. Even loading up my laptop from scratch, the overall process took around 5 mins from installing the software to removing the ghost...

Sure I can post. Is it just the webpage? Zwave details?

It looks like I can only capture the part of the screen that is visible, but the webpage is much larger than one screenfull.

I just take multiple screenshots, one of each section that fits on the screen, as you scroll down. There's also tools to let you capture entire scrolling screens, but I can't remember the name right now. and use Scrolling Capture feature.

1 Like

Here are the screenshots. I also ordered a zooz usb stick

There are 3 devices that have the discover button

Well you definitely have 3 ghosts which are likely trashing your mesh...

So was able to remove the "ghosts"

As an FYI

  1. Mac is not supported, the Hubitat Ghost removal doc mentions Mac. Simplicity Studio does install on Mac, but when clicking on the PC Controller icon, message states only supported on PC. I tried Simplicity Studio 4 and 5 on Mac

  2. Need to be logged in into the app in order to use the pc controller module. Tried to do this on my work computer, and the apps login screen is blocked or something so that the ability to login was blocked, so was unable to do this on work computer.

  3. Some computers are USB C only, so I had to buy a USB C to USB A dongle to be able to plug in the zwave stick to the computer that I was able to get working.


The Silabs download page for Simplicity Studio 5 indicates a version for Mac. I do not have Apple product, so I cannot test.

1 Like

See the message just above yours...seems like Simplicity Studio may install on a Mac, but that PC Controller is not supported. More wonderfulness from the people who named the most annoying and confusing software ever developed "Simplicity Studio." :wink:

1 Like

And did not work on Windows 7. Not that this is a requirement but I had an old PC running Windows 7. I was unable to get the zwave USB Stick recognized without an exclamation point on Windows 7.

1 Like

You're making me miss Win95... :wink:

1 Like

That’s funny, yes, I remember windows 95 :slight_smile:

1 Like

Windows 10 and 11 do a great job of supporting most USB devices plug and play without having to install drivers. Windows 7 was not nearly as good. The USB Z-wave stick might work in Windows 7 if you had a suitable driver to install.

1 Like