Zwave repair doesn't look right

The more times I run z-wave repair, the more duplicate messages I am seeing. Does not seems right.

Could you go to your z wave devices list and tell us what device is node 14? I saw this before with non z wave plus devices but it should work just fine after the z wave repair, or maybe node 14 is weak of signal?

Node 14 is a GE Zwave switch. The more time i run zwave repair, the more message I get. and it always seems to stop at node43 but I have a few more device after 43.

Ok, so the problem is general with all devices, some nodes will not show up if they are battery powered(you must wake up them when doing the repair to show up), I'm not sure why are you doing so many repairs but if you finished your installation then you don't have to do any repair after a repair. I suggest to reboot your hub. Why are you doing so many repairs? Any particular problem with the mesh?

Just trying to figure why it's not repairing all the way to the end. It always stop at 43.

I get dups on repair too. Actually quaddrups

Try operate node 14 switch while looking at the log. Possible it's a logging issue. Couple of people seeing multiple log for ON/OFF.
I would reboot the hub and start a clean Z-Wave repair for node 43.
Also give support a call.

Node 14 is one of these and I am using "Aeon Outlet" as the device type for it. I don't see anything in the log page when toggling the switch on and off.

As for node 43, it's just a GE dimmer using the generic zwave dimmer device type.

@cuboy29, you might want to take a look at this thread on the stated in that thread, I ended up replacing the Aeotec with some Dome On/Off Outlets with energy monitoring. They work great and are fully supported within Hubitat.

Hope this helps.

Out of curiosity I just ran a Z-wave Repair. The results only show 3 devices where I have 21 Z-Wave devices.
My only conclusion is the devices that don't need repair are not listed.

OR they are the first two devices listed on the Z-Wave repair page. Don't know if that is meaningful.

My Log:

sys:12018-09-04 16:49:05.627:traceZ-Wave Node 3: Repair is done.
sys:12018-09-04 16:49:05.607:traceZ-Wave Node 3: Repair is requesting node neighbor info
sys:12018-09-04 16:49:05.604:traceZ-Wave Node 3: Repair is adding return route
sys:12018-09-04 16:49:05.601:traceZ-Wave Node 3: Repair is deleting routes
sys:12018-09-04 16:49:05.557:traceZ-Wave Node 3: Repair is requesting device associations
sys:12018-09-04 16:48:56.940:traceZ-Wave Node 3: Repair is updating neighbors
sys:12018-09-04 16:48:55.751:traceZ-Wave Node 3: Repair setting SUC route
sys:12018-09-04 16:48:55.723:traceZ-Wave Node 3: Repair pinging
sys:12018-09-04 16:48:55.718:traceZ-Wave Node 3: Repair starting
sys:12018-09-04 16:48:49.346:traceZ-Wave Node 35: Repair is done.
sys:12018-09-04 16:48:49.330:traceZ-Wave Node 35: Repair is requesting node neighbor info
sys:12018-09-04 16:48:49.328:traceZ-Wave Node 35: Repair is adding return route
sys:12018-09-04 16:48:49.318:traceZ-Wave Node 35: Repair is deleting routes
sys:12018-09-04 16:48:49.112:traceZ-Wave Node 35: Repair is requesting device associations
sys:12018-09-04 16:48:41.504:traceZ-Wave Node 35: Repair is updating neighbors
sys:12018-09-04 16:48:40.764:traceZ-Wave Node 35: Repair setting SUC route
sys:12018-09-04 16:48:40.657:traceZ-Wave Node 35: Repair pinging
sys:12018-09-04 16:48:40.652:traceZ-Wave Node 35: Repair starting
sys:12018-09-04 16:48:40.454:infoStarting Z-Wave Network Repair

If that is the complete log output, it doesn’t look like the repair completed. There will be a message that says something like β€œZ-wave network repair finished.” I have about a dozen z-wave switches and it takes a good 10 minutes or so to do the repair.

I've never seen a Zwave Repair Finished message on Hubitat...

Is zwave repair a utility that can be called multiple times and they all run in parallel? I've been trying to run multiple repairs and i'm seeing the number out of sequence now in the log.

@mike.maxwell @bobbyD any thoughts?

I reran the Z-Wave repair, left it for a hour. No change.

If it matters, on the Z-Wave Settings - Z-Wave page a banner showed "starting Z-Wave repair...."
when I finally got back to it the banner was empty.


I'm trying to replace the older GE switches to newer GE Zwave Plus switches which is why I am running so many zwave repair. Just trying to figure out if the process is really working or not.

replace all your devices, then run it once.
then go through each switch, turn them on and off, if you find one that doesn't work run repair again.
you don't need to run it that often, don't worry about what the logs say, if all your devices work, then thats the end of it

Only on the live log if you left it open during Z-Wave repairs. I have 80+ Z-Wave devices and it took over 2 hours but I do get Z-Wave repair finished at the end.

I have 2 of these devices. I have one using generic Z-Wave switch and the other Aeon micro switch. Not using the power reading but no issue with the 2 Drivers above.

The engineer in me is constantly looking for strange pattern and this is one that will keep me up at night until I know why. LOL ...

sure, in the mean time see if everything works, then get some sleep!