Zwave PC Contoller issue

On the heels of my question last night about leaving devices included and unplugged, I went in today to remove the two I had questioned. I noticed that the last time I used my UZB7 I must have forgotten to exclude it. I tried to do it tonight and I got this error screen. Does anyone know what it is or how to fix it?


I tried uninstalling and reinstalling SimplicityStudio, and that didn't work. any thoughts or suggestions?

I tried using that, it was a mess. I wound up with Z-wave PC Controller 5, much easier to figure out.

Back to your problem. Did the PC detect the serial device(UZB7) ? If not reboot and try again. Try the USB ports at the rear, as opposed to front ones.
Sometimes trying again, logged on to another account(create one if you don't have an alternate account) on your PC

There's a direct way to get that? I thought you had to get it through Simplicity studio.

Yep, then when I tried to open the Zwave PC controller, that's when I got that error.

Oh God they don't make it easy. Have to create an account and Googled for 25 minutes to find the link. I can't find it now but Silicon Lab's motive for "hiding" it is nonsense. I followed the link from another thread, that used to go there but now goes to studio.

Now I'm getting that error before I even put the Uzb7 into the USB port.. As soon as I open the Zwave PC controller it pops up (i have tried both with the UZB7 in then opening the Zwave PC controller and also with the controller open then inserting the UZB7).

** EDIT **
To clarify this was after rebooting my PC.

Now that I'm fully awake and rereading this. Are you saying my stick is fried?

Nah, I suspect something with USB/Serial communication, especially with the same error without the stick. Can you see the UZB stick in device manager under Com ports

yep. Also happens no matter what port I try to use .

Hmm, You have to uninstall and remove all files related to the install, not sure if uninstaller does this.
Also check C:\Users\YourAcctName\AppData\Local, look for silicon_labs folder, and delete it.
Reboot , reinstall SIlabs

1 Like

Another option to try for giggles is create a new user on your windows PC, this will create a clean profile in case SL SDK did something to your profile. Uninstall the SDK, reboot, log back into the new profile and install the sdk (make sure you make the new user an administrator of the pc when you set it up) and see if that works. If it does then you know your original profile is somewhat borked and can just move all your files over to the new one and keep on chugging. (Not saying this will work but it's a possibility) Another option is to try uninstalling the SL and then searching the registry for all references to it and deleting them and reinstalling.

1 Like

Download the Hubitat app