Zwave get updated 7.17.1

Looks like Silabs has fixes the 700 issues, I have just updated my USB stick.

Hope we can get this for the C7

7 Likes

Very interesting thread to read through. So many issues mirroring what you see here with regards to the C7 and Z-Wave. Although the solution those folks were using was to flash 500 series firmware onto their 700 series sticks, and then have to reverse the process in the last few days as this new firmware for the 700 series sticks seems to have fixed the issue. Looking forward to getting the update for me C7.

1 Like

I'm sure @bcopeland is all over this.

3 Likes

My secret hope is that this'll be in 2.3.1. Or hopefully sometime soon!

1 Like

I bet they are carefully studying it, if not already testing internally.

I will predict no. That firmware just came out a couple days ago, and Hubitat will certainly run this for a while internally to verify that it helps and that it doesn't break anything. Who knows, maybe this Zwave firmware might get another update next week, or next month when more bugs are discovered by this initial firmware fix.

I would think that they are fairly far along in 2.3.1 development, it has been a while since the 2.3.0 release. We are probably getting close to Beta testing 2.3.1.

More realistically, we probably should expect this updated Zwave firmware (provided it works) in 2.3.2 unless for some reason they decide to hold up 2.3.1 release for another month or two (unlikely IMO).

1 Like

I’d say you’re pretty close on time line if I had to guess - 2.3.2 at the earliest. This isn’t something you want to skimp the testing on, as attempting a fallback could be painful.

2 Likes

Yup - has not shown up in any beta yet, so won't be appearing really soon.

1 Like

Links to the US 7.17.1.344 UZB FW are here for those interested in updating their UZB sticks. If you have the Silicon Labs stick the instructions are in the Ghost Removal doc.

And EU here:

2 Likes

FWIW, just updated my SilLabs stick (SLUSB7000A) to 17.1 using PC Controller/OTW method. Didn't seem to run into any issues w/the update.

image

2022-01-31 09_17_03-

2022-01-31 09_17_25-COM3 - Z-Wave PC Controller

2022-01-31 09_17_32-COM3 - Z-Wave PC Controller

2022-01-31 09_17_43-

2022-01-31 09_17_52-COM3 - Z-Wave PC Controller

1 Like

Yeah I updated my UZB-7 SLUSB7000A over the weekend. It is not being used for anything major at the moment though, but it does still work so the updated was a success. Just used the OTW option in PC Controller, was very simple.

Reading the update notes and comments though it sounds promising. Hopefully we will get to try this out in Hubitat soon.

3 Likes

1 Like

Oops - edited my post above.

1 Like

I wanted to report that one of my 2 UZB7's failed to update via PCS.. tried the Tera Term route but no go.. I don't get the menu just a bunch of chars.

Looks like a corrupted boot loader maybe? The stick works otherwise. My other stick updated via OTW with no issue. They are both SLUSB7000A's

And you can see the stick on your COM5 port? Have you tried rebooting? Perhaps PC Controller or your computer thinks the other stick is attached.

Yes, I see COM5 in the header.

Yep did all the stuff.. I tried the updates on the "bad" stick before for the good one as it was the one that was connected to my HE. I did make sure I unpaired from HE first..

What's weird is it works fine as a secondary controller (and also a primary like in HA).. maybe it's missing the Serial API but I cannot communicate with it via Tera Term - SiLabs suggested comm app.

edit: I can't use the upgradable UZB-7 stick in Tera Term either so that was kind of a useless adventure. (115200,8 bit, no parity, 1 stop bits, flow control: none)

Nice stuff!
Actually does anyone know if its possible to use the UZB-7 stick USB as the primary z-wave controller on the C7?

I don't know if it's possible on a C-7 but on a C-5 you could use a Y-cable for the old Nortek stick (which was used here in the US). The issue is you would lose Zigbee capability..

No, the C-7 does not work with external Z-Wave sticks (like the C-5 and earlier did).

2 Likes

Can confirm! I just tested on both.. cause I was curious and had some downtime.

Using the Y cable:

  • Shutdown C-5, added UZB-7, started back up. Included my other UZB7. shutdown hub and removed power. fired up the PCS and NOPd the primary - which was showing up as "Pc Controller" not Gateway. It failed as expected. Switched UZB sticks and confirmed the Hub UZB contained the secondary controller.

  • Did the same with the C-7, device remained active on the hub regardless of the status of the hub UZB7. Also checking out the Hub UZB7 with the PCS showed no included devices. Therefore my conclusion is it's not being used just like @bertabcd1234 said it would not be.

edit: on the C-5 the secondary UZB7 would not include with S2 security...also did not verify whether Zigbee was working or not.

1 Like

where is the fw download to update my stick thanks

Download the Hubitat app