Zigbee device not leaving pairing mode

Hi to all!

I have some switches and outlets that are not leaving pairing mode after being found by the Hub.

I can set a name, they get their network ID and they can be saved but cannot be controlled by the Hub after being found, no matter which drive I use.

Devices:
Outlet: https://a.aliexpress.com/_mMRPnvo
Switch: https://a.aliexpress.com/_mPyxuGi

Drivers tested:
System Default Generic Zigbee Drivers (outlet/switch)
Oh-La-La Labs Generic Zigbee Switch/Outlet (with presence)

Need help!

No solution for now, see here and here.

2 Likes

Thanks for the reply @kkossev

Got some expensive paperweights here….

Can you post the Data details of the non-working devices in Brazil? ( model, manufacturer, application version, but also the first 6 digits of the MAC address - see the samples in the linked posts above).

@gusthepenguin did you return these devices?

If not, we still need their exact models and manufacturer's data details. Thank you!

Hey @kkossev
I away from home, but will be getting back in a week.
Will post the details as soon as I get home!

Have a great 2023!

1 Like

Ok!
Finally posting the info…

About the “generic” basic switch:

https://a.aliexpress.com/_mNEutjs

  • endpointId: 01
  • application: 02
  • manufacturer: eWeLink
  • model: SWITCH-ZR02

The Power Metering outlet
https://a.aliexpress.com/_mO7MPqq

Shows Nothing:
• endpointld: F2
• application: unknown
• driver: v0.8.2.0914b
• manufacturer: unknown
• model: unknown
• powerCluster: none

?!??!?

1 Like

The Power Metering Outlet may work with the patch implemented in the Tuya driver - have you tried it? Make sure you have updated to the latest dev. version of the driver.

The eWeLink seems to have a problem like the other devices from the second group described here.

Please try to make a screenshot (better copy&paste as a text) the information that appears in the 'more info' hyperlink, when you pair the devices as new. You will need to delete them first ( click on "REMOVE DEVICE" button at the bottom right of the device page) and then pair again close to the hub. Save the information from the 'more info' popup window before you continue with naming the device.

eWeLink data:

Device pairing info

Manufacturer: eWeLink
Endpoint 01 application: 02
Endpoint 01 endpointId: 01
Endpoint 01 idAsInt: 1
Endpoint 01 inClusters: 0000,0003,0004,0005,0006,FC57
Endpoint 01 initialized: true
Endpoint 01 manufacturer: eWeLink
Endpoint 01 model: SWITCH-ZR02
Endpoint 01 outClusters: 0019
Endpoint 01 profileId: 0104
Endpoint 01 stage: 4
Endpoint F2 application: unknown
Endpoint F2 endpointId: F2
Endpoint F2 idAsInt: 242
Endpoint F2 initialized: true
Endpoint F2 manufacturer: unknown
Endpoint F2 model: unknown
Endpoint F2 outClusters: 0021
Endpoint F2 profileId: A1E0
Endpoint F2 stage: 4

About the metering plug: does not exit pairing mode.

Lots of funny things:

  1. HE finds it, lets me add it. But the device does not exit pairing mode. Tried lots of drivers (Tuya Metering and others) with no luck.
  2. I delete it from HE. Take it out of the outlet, plug it back in and put it in pairing mode… HE finds a “previously joined device”…

Seems like the metering plug has two-problems-at-once :

  • the endpointID is incorrectly determined by HE hub as F2 (instead of 01)
  • It does not stay connected to HE (leaves the Zigbee network and changes the NWK during the pairing process)

It's ideal sample to be sent to Hubitat engineers

Help needed - Zigbee devices that do not pair correctly in HE

Download the Hubitat app