Zen 32 Scene Controller extremely slow to respond or non-responsive

I have a Zen32 scene controller that I have set up as a 3-way dimmer switch in a room where there is no traveler wire. I use the big button to toggle on/off and the smaller buttons for four levels of dimming on the master switch. It has always been flakey - slow to respond or no response at all. I recently changed out the master switch to a new Leviton ZWave Plus dimmer and simplified the programming using the Button Controller app, where each button simply sets the dimming level on the master switch. It worked perfectly for a few days, with less than a 1 second delay, but then suddenly started behaving the same as it did before - slow to respond or no response at all. Has anybody else experienced this and do you have any ideas or suggestions for fixing the issue? I've used both the the built-in basic button controller app and the one below. Thanks in advance.

Turn on logging for both devices and the app involved. You should be able to see where the delays are in the log. I suspect you are dealing with Z-wave latency, not the hub itself.

Also, lets see your Z-Wave details page. If you have a lot of Z-Wave devices, at least the two devices you are working with. Also check for any nodes with no device listed next to them, lets see those also.

Thanks so much for trying to help me out. Here are the logs from pressing a couple of buttons. The first press worked. Subsequent presses did not. I'm getting an "unauthorized on line 483" error.

I do have a TON of Z-wave devices and a lot of nodes with no devices next to them. I once cleared them all out using a USB Z-Wave stick but I've lost my stick and don't know how to clear them up without one.

What is that app 298? Click on the red error text and it should open it up. The error is indicating an http error, which neither devices are web based so it is possibly some cloud integration?

Looks like in this area the hub is getting the message from the zen32, but the light did not adjust until after the 4th press. If you had logging enabled on the button controller app we could see more details. I suspect the BC app is sending the command to the switch but it may not be getting it, or there is a lag so then you press the button multiple times before you see it work.

The ghost nodes are possibly clogging up the zwave radio and causing the delays.

Follow this below from the ghost removal how-to post (these are my instructions that got added to it) to try and remove as many as you can without the USB stick. If you get stuck on one that wont remove just move on to the next. Removing SOME is better than doing nothing.

1 Like

App 298 is my Thermostat. It keeps losing its wifi connection, which is why the error. It has nothing to do with the button controller issue.

I actually am only pushing the button once. I just tried it again - pushed the button once and only once, and this is what I got in the log for the controller and the switch:

It makes no sense. Also, Tried removing those ghost nodes to no avail. I will need to find the Z-Wave stick I think, because I have a lot of ghost nodes, and it will take forever trying to remove them one at a time the way you described.

Here's a link to my button controller app. It's pretty straightforward:


Ok so that tells me that the device is not getting the acks back from the hub fast enough so the message is being re-transmitted. Then all the messages must be getting to the hub eventually. That's why you are seeing it multiple times.

I never understood why some drivers check the sequence number of the message and drop duplicates, I guess this is why.

Removing them one at a time the way I described is the only way to do it from the UI, so I am not sure what else you would have tried??

There is no point in troubleshooting any further until you clean up your Z-wave mesh.

Appreciate the help. The thing is, those ghost nodes are not affecting anything else on the system - it all works fine. Using the Z-Wave stick I was able to remove them very rapidly. I tried removing one node three times through the HE UI and it didn't work. I'll try again.

If you post the zwave details for at least the ZEN32 I can take a look, but right now everything is pointing to a zwave mesh issue.

1 Like

Ok thanks. I'll try to clean up the nodes.

Ever get this sorted out? My Zen32 has been awful. If I'm lucky lights respond a few seconds later

I would enable logging on the device and pull up the logs on mobile. Press a button, see how long it takes to show up in the logs. You need to determine if the delay is with the button press getting to the hub, or something afterwards.

Also if it shows multiple times like shown above, then the device is struggling and sending the message out multiple times to try and get through.

Nope. Glad it's not just me. Sometimes it's instant and sometimes it never responds

As you know, I did that. I get multiple presses show in the logs even though I only pressed once. I have ghost. Odes which I will get rid of shortly. But for reference, I have a large system with over 75 devices, and dozens of scenes and automations. I have zerio problems with any other devices responding in this manner. I have many devices that act only when triggered by another device, and the response is always within one second. It has to be something with the way this Zen controller is designed. Very disappointing.

I doubt it's a (widespread) hardware/design issue - I recently replaced my 700 Z32 with the new 800 version, and both work equally well. I don't have any delays or wonky behavior with either version.

My last reply was to the other person @waffles

You could try the community driver if not using it already, see if it makes any difference.

Did the previous 700 version one cause you problems?

No problems with either version. Both were/are paired S2, and I've always used Robert's driver (linked above) with latest firmware available.

I updated to the 800 version when it was on sale recently just because I figured it was the heir apparent in terms of future support.

Ok, so I have updated information. First, I am using the custom driver shown above. So, I went to the device within Hubitat and selected button numbers to "Push" using the app, and it works perfectly and instantaneously every time. But, when I go to actually press the physical button, I get either no response or a crazy delay. So it has something to do with the message from the physical button push to Hubitat. Any other ideas given this new information?

This still applies

I did that before. What exactly would you like to see? In the meantime, I just ordered a new Z-Wave stick and will remove all the ghost nodes and see if that does anything.