Z-Wave Switch works manually but does not work from the hub

You should try removing those 4 nodes that do not have a device attached. Click the refresh button until you get a Remove option. Then click remove once and wait. They may not remove due to having neighbors.

What what node is the one you are having issues with?


1E (the last one in the list)

Refreshed until I got a remove. Clicked it once. Did not remove. Now what?

For some reason nodes with neighbors usually refuse to remove. If you had checked the logs, it probably said node is no longer in failed list.

There is a chance a full repair would help clear out the neighbors tables. You might need to do a shutdown and unplug for 30 seconds again first, then after it boots back up do a full z-wave repair.

It will take a little bit to notice any changes, the updates to the z-wave details are not instant.

You can also use a USB stick as a secondary controller to force remove them:
-- How To: Remove Ghosts using hub tools or a UZB Stick

Alright, got home last night and none of the automations had worked. Shut the C8 hub down, disconnected power for 5-ish minutes. Powered back up and did a Z-Wave repair. It found a whole lot of nodes that didn't work. It seems like everything is working at the moment, but we'll see. Also, ordered a UZB stick and downloaded the Simplicity Studio while I wait for it to arrive. Gonna get this figured out. :slight_smile: Thanks for the help so far.

1 Like

I would not necessarily do a full repair after each shut down, that was a one time suggestion to try to re-establish the neighbors tables. If anything you may need to wait 10-15 minutes after booting before doing it.

I will definitely be curious if removing those dead nodes helps with the lock ups at all. Might change some of my theories a little.

1 Like

Definitely was not planning on doing a Z-Wave repair more than once. I did the Z-Wave repair kind of at your suggestion AND as a last resort. If that didn't work, I was probably going to reset to factory settings, exclude all devices and start over. I don't have that many devices so that would probably be the fastest, but I don't think I'm going to have to. We'll see tonight. Will keep you posted on the ghost removal.

Hey all,
Still testing, but the Z-Wave repair seemed to correct my situation. I also replaced a Zigbee outlet with a Z-Wave outlet to see if this helps the communication between different ends of the house. Question" Since I've added a new Z-Wave device, should I re-run the Z-Wave repair? (I still have a Z-Wave device that is fairly far from the hub that isn't working)

No - Running Z-Wave repair is an exception, not a generally done activity.


1 Like

I'm Dana...Roger isn't here right now.

(Oh, I am SO funny to myself.)



The above device is what I am worried about, It seems to take a very circuitous route to get to this device and ultimately fails. The light does not come on during the nightly app turn on of the outside lights. All the other outside lights respond. The new Z-Wave device I added has replaced a Z-Wave device that died (and is much closer to this device than the route it's currently taking.)

For a single device that isn't working reliably, you can try a repair of just that device. That may nudge it to find a new route, and if it does, that can take days rather than minutes or hours to occur. It takes some patience to wait and see if the switch finds a new, reliable path. As a part of that you may need to add or move an existing repeater between the hub and the switch, I believe the recommended placement is a little closer to the hub than the switch.

Another quicker option if you have the switch in a lot of automations would be to use the Settings>Swap Apps Device feature to help wiuth removing/re-joining the switch:

  1. Create a virtual switch (Add Device>Virtual)
  2. Use Settings>Swap Apps Device to swap the virtual switch in for the real one
  3. Exclude the real switch
  4. Re-join the real switch and ensure it joined properly - check on the Z-Wave Details page that it looks normal, has routing in the last column.
  5. Use Settings>Swap Apps Device to put the real switch back into your automations

If you only have the switch in a few automations it will be faster/simpler to remove it from those automations, do the switch excluce/re-join, and then put it back into the automations. If you get the same routing then that would likely indicate a need to move/add a repeater between the device and the hub and see if it will choose the repeater.

1 Like

Yeah that device is only showing 2 neighbors. If one of those is not the new device you added then I would run a single repair on both of those devices, hopefully they will see each other and be friends.

Once that happens, when the device tries to re-route next hopefully it will route through the new device. If that new route continues to work it will stick with it.

If you can get a device at least 4-5 minimum that seems to be when they are most reliable for me.

Welp, it's up from 1 neighbor, so I guess that is progress. I'll move the extender a little closer still and see where we end up. Do I need to repair each of the individual devices (extender and switch in question) when I move the extender?

It will sort itself out eventually but doing a repair on both will help to speed that up.

Still cannot seem to "get" to the device that is farthest from the hub, even with an extender one room away (about 15 feet away).

Have you power cycled the device and hub?
Then try a a single repair on the problem device. The repair sends out a bunch of discovery packets, so if its reachable it should eventually reply back.

If still not working you could try to exclude and include it. Warning, exclude will remove the device from the hub and possibly break some rules.