Z-Wave stopped working C5 with USB stick

Hi everyone, hopefull someone can help

Everything was working fine until yesterday, today morning nothing worked though.

This is what I've done so far:

  • I disabled the Z-Wave network, waited 15 secs and then enabled it again, my Z-Wave network disappeared.
  • I panicked and did a hard reset (unplug power cable) to reboot the Z-Wave stick (EU version), waited 30secs and power on again, still no Z-Wave network.
  • I restored from a backup from a couple of days ago, still no Z-Wave network.
  • I shutdown the hub from the menu, waited 15 minutes and power on again, the Z-Wave appeared, but nothing worked.
  • I'm currently running a Z-Wave network repaired, it's been running for 45 minutes so far, through 5 nodes. None of them are working. I have 30+ devices, so at this speed the full repair should take about 5-6 hours, when the system worked it lasted between 4-7minutes.

So what I do now? I hope I don't have to include again every device...

Are you on ??

Yes,, C5 hub

There’s a hotfix (.158) out for something that sounds similar (Release 2.2.4 Available), but only mentions the C7 so not sure. I have seen a few people reporting similar issues today though. Copying @bcopeland @gopher.ny to get a more official viewpoint.

Thanks, do I have to wait for the repair to finish to update?
Waiting for @bcopeland, I opened a ticked as well

IMHO I don’t think the repair is going to resolve your issue, but it isn’t going to break anything either. So your call on continuing.

I’ve seen a couple of people were reverting back to a previous verion of the firmware and then restoring a backup made under that version. Not sure I’d do that before someone from support chimes in, but might check to see what versions you have backups for in case they ask,

1 Like

Fortunately or unfortunately, depending on how you want to look at the problem, nothing has changed in the Z-Wave firmware for C5/C4 hubs. This sounds like the USB stick may be failing or may be simply disconnected (it happens often). Have you tried unplugging and plugging the USB?


Electrical connections are the bane of electronic devices.

1 Like

For what it's worth, I also had my first z-wave failure yesterday morning, but I only lost 1 single device and it was recovered with a repair. I am on C4 with

I also had an issue a few weeks back where the hub became unresponsive, but then recovered.

This then leads me to what @bobbyD is saying above. Could it be that hubs slowly deteriorate over time ? Can it for example be ralated to NAND flash write times ? This would then be similar to what has been happening to some Tesla drive computers where the flash has reached it's re-write capacity.

Of course this is just wild speculation.

Repair took almost 3h, but didn't repair anything

I tried unplugging and pluging the USB as well, it didn't work either.
How can I test is the stick?
Can I replace it by any model, or has to be the HE model?

But all of them failing at the same time? It could be one, or even two devices, but all?
I was about to install the device watchdog app to detect issues like this.

I would suggest that you reach out to support and ask how to move further with this. I would hesitate to suggest a troubleshooting step in case it will cause further harm.

I see BobbyD is already aware of your post here, so perhaps register a new ticket and point towards this thread ?


OK, I've updated to, and now my zigbee network is not online
Screenshot 2020-12-07 09.50.47

But the radio is enabled:

and the Z-Wave table is empty again:

Reboot without the stick then reboot with the stick helped me for z-wave. (I know its not a long term solution.)

1 Like

I was thinking of the usb stick. I understand your frustration, everything is going along fine then BANG everything stops and one feels helpless. Kind of like when the car dies while on the road :frowning:

OK, this is what I did:

  1. Unplug the usb
  2. Reboot Hub
  3. After reboot, Zigbee network was online and working
  4. Plug USB back
  5. Reboot Hub
  6. After reboot, Zigbee network is still online and working
  7. Started Z-Wave repair, this one went much better. It got stuck on node 35 only and it took 11 min (when healthy it took 5min).

Node 35 does not work, rest seems to work fine.

Is it possible all this issue has been caused by a failing device?

1 Like

Seeing my previous post, could I discard a failing usb stick?

IIRC you would need to exclude all of the devices from the stick and then include them to the new. Might want to read this thread if you decide to go that route: Migrating a Z-Wave Network