Z Wave Routing Defies All Reason

I'm getting seriously fed up with the way this device is handling Z wave routing. I thought that adding devices would help build the mesh and make things work more efficiently, unfortunately the opposite is true. When I started out a couple of weeks ago, all devices except one had a direct path to the hub. Now after adding a few devices the mesh is a complete mess.

Example 1: Device 3 > Device 2 > Hub, but when I look at Device 2 - Device 2 > Device 3 > Hub. It's clear that both devices 2 and 3 have a direct path to the hub so why on earth are they routing through one another? (that's an example using different addresses to the actual ones)

Example 2 - I have an outlet in the living room (device 16 on the topology) with a direct optical line of site to the hub (14 feet away). Instead of connecting directly, it routes first to a light switch (8 feet away no obstacles), then goes backwards on roughly the same line through itself and a double cavity wall into the garage (12 feet), then back through the same double wall past itself again and the previous light switch, through another solid wall and floor to the landing light switch (22 feet) before finally travelling back through two walls and the floor again to reach the hub (16 feet)

Needless to say the topology chart looks awful. Z wave repair just assigns the same routes or something even more ridiculous. I this going to sort itself out or will I have to exclude the lot andd start again. It's not really an option to do that as the exclude function doesn't seem to work on the hub and I have to power up my old smart things hub to do the exclusion as it when I've tried previously it didn't work on the Hubitat.

Are the devices working? If so, who cares what route they are taking? Go outside and play

If they aren't working, have you tried a zwave repair on those nodes?


One of them won't work at all (though the hub receives power reports). The other (example 2) just took 8 seconds to switch on so is unusable. Z wave repair does nothing helpful - just assigns the same route again. I do feel like going outside and playing....with the traffic :slightly_frowning_face:

The thing I have to keep reminding myself about when looking at routes, is that the device is looking to minimize hops and therefore tends to favor devices that are near the edge of it’s rx/tx sphere, i.e. the biggest hop possible for lack of a better visualization.

1 Like

Could you post a screenshot of your Zwave details page please?

Here you go:

Just upon a quick glance, you have 3 lights paired as S0. S0 is the worst way to have something paired, it sends triple the traffic of other security methods. Only locks or garage doors should get paired S0. If at all possible, pair these with no security.

Also curious how far away the Lounge Lamp and the Drive Lights are from the other devices (and the hub). They are using the maximum allowed 4 hops, and they don't seem to show as sharing much on the topology map (especially true of Lounge Lamp).


Thanks for the info. I did read about S0 not being ideal. Unfortunately when I included those devices I wasn't sure and so simply accepted the default options that were checked. I believe there's a way I can amend that in the app (again I read a post somewhere on this forum detailing it) but I cannot find it.

Yes that's my point with regard to the Lounge lamp. The house isn't large - approx 40' x 20' ground floor and 30' x 20' first floor.

Lounge Lamp is 12' from the hub, 8' from Lounge Light, 10' from Hall Light, 6' from Garage Door, 8' from Lounge Curtain

Drive Lights is 16' from the hub, 4' from Dining Light, 12' from Dining curtain. Both of those devices is in close proximity to others.

Unfortunately, you have to exclude and re-include them to get different options. I definitely would do that, it will cause issues if you leave them.

The other thing I would suggest after doing all that is to give it overnight to settle. You didn't say how long it has been since you added all this, but I would do an individual repair on the Lounge Lamp, Drive Lights after fixing those S0 devices, and then just leave it alone for a while.

By the way, which device is the power reporting one that isn't working, and what brand/model is it?

1 Like

I'm sure I read it's possible to get the security options screen back up - but only in the phone app not using the web browser. It's becoming unworkable because the exclude function simply does not work. I have to start dewiring everything and removing the modules from behind the switches. Very time consuming.

I've already tried an individual repair on the Lounge Lamp but it did nothing (was added this evening - Neo Coolcam Outlet), Drive Lights is the same outlet also added today.

The power reporting one that's not working properly is the Stairs Lights - it's also a Neo Coolcam outlet and has been in for about a week. the issue has started when I've changed the driver from Generic Z Wave Outlet to the model specific one - I think that driver may be new as I didn't notice it before the latest raft of firmware updates.

Did you hit the Configure button in the device settings page after you did this? If not, you should. Then save preferences again.


It is definitely finicky. It does work though - I've paired, and then excluded, upwards of 75 times on my dev hub. Usually works, sometimes doesn't. Sometimes needs a shutdown and remove power 1st, sometimes doesn't.


I tried it a few times and got nowhere. I just got the countdown timer and then when I tried to exclude something - Fibaro with triple button click - nothing happened, no confirmation and it timed out. Always works first time on SmartThings.

Yeah I did but I'll give it another bash. I switched the driver on the other devices without issue.

You cannot find it because it doesn't exist. This is from the Hubitat Zwave developer himself.


OK thanks - I guess thats Sunday morning taken care of

1 Like

Based on these stats, it appears that most devices are responding pretty quickly (at least the ones that seen messages since the last reboot).
All of the devices except the curtains are z-wave plus.

Which device or devices are having problems?

Remember that if S0 is the highest level of security supported by the device, S0 will be used, if possible, without any prompting or the ability to change it. (I didn't see any details on the make/model of these devices, so it isn't clear if this is an issue with these or not.)


Unfortunately.. And it’s at the SDK layer..


I can change them from S0 to none. Simply my inexperience with HE that they ended up as S0

1 Like