Z-wave repair - brand new to HE

Brand new HE user here. Feeling overwhelmed right now is an understatement lol. I'm coming from a background of the Iris by Lowe's system, then to Smartthings, and now to HE since ST went down every few days due to their cloud service.

I just started with a C7 hub and tried to follow what I've been reading on here is the best method. I have reset each device manually, excluded it, and then paired them. I started with the hardwired Zooz switches closest to the hub, which I believe are Z-wave Plus. Then some Zooz plugs, which are Z-wave Plus as well. I the. Added some of my older Iris 3210-l plugs, paired them via zigbee, and then as the z-wave repeater. I also have a CT-101 thermostat, linear (iris) garage door opener GD00Z-1, and an iris V3 keypad. I also have my Kwikset 916 deadbolt. I powered down Hubitat, found a long ethernet cable and paired it within 12" like it recommended.

Everything seemed to be working well, and then every z-wave device went offline. I then tried a z-wave repair, and it showed every Z-wave device as failed. I then restarted the Hubitat, and tried again with the same result. I then tried powering down Hubitat, waiting for it to turn on, and everything shows up except for a bunch of "failed nodes", even though everything seems to be functioning fine.

I'm not sure what to do next, as I haven't paired any of my other devices yet, since I figured I should figure out what's wrong beforehand.

To be honest, I don't know most of the terminology within Hubitat, and am pretty overwhelmed at the moment lol.

I have screen shots of the failed nodes before and how it looks currently. For whatever reason, the old Iris V1 zigbee plugs always worked, even when the entire z-wave network was down.

I really appreciate any help!!

First, welcome to the community!

Do you know if the failed nodes (from the 2nd repair) are battery devices? Those will often fail as they need to be awake to repair. Battery devices spend most of their time sleeping and wake-up only when necessary - to conserve battery.

Also, when you have Z-Wave issues, you may want to add a step to the shut-down / power-up process - pull the plug (from the wall) for about 1 minute to ensure the Z-Wave radio does a full shut down / reboot.

You also want to see if you have any “Ghost” nodes. When you look at your Z-Wave details, those will be nodes that have essentially no information. You want to remove them or they will cause issues with your Z-Wave Mesh.

Finally. If you have devices that pair at S0 security, be aware that those can cause some issues - especially Zooz motion sensors. Unfortunately, Z-Wave does not currently allow for hubs to unselect S0 as a security, but this can be done with a separate Z-Wave (UZB) stick paired as a secondary controller. If you have one of those, you can use it to pair S0 devices with no security.

1 Like

Thanks for the reply, probably a dumb question, but how do I figure out which node is what device?

I do have a ghost device. Not sure how to find out which one it is from the z-wave details page. Should I try to "discover", "repair, or "refresh" it under the details page?

Looks like three devices are marked S0 for security, the garage door opener, the deadbolt, and a Fibaro motion sensor. Not sure if it's relevant, but the deadbolt is a Kwikset 916 model, but is listed as "Schlage FE599/BE369 Lock".

The only battery powered devices are the deadbolt and Fibaro motion sensor. Not sure if the Radio CT101 is considered battery, since it has batteries but is wired for low voltage to the hvac too.

That is hard to tell for sure, but usually it is caused by issues during pairing, so it will be caused by a device after the ghost in the list, and usually the next one. You will need it to be powered down (battery removed, air-gapped or breaker off if mains powered) for the removal to work.

You just need to remove them at this point since you more than likely were able to pair them later on.

The Ghost devices are probably a causing much of your issues. I went through this and things settled down less than 1 week after the Ghosts were removed and the problematic S0 sensors (Zooz in my case) were paired without security. You don’t seem to have too many, so should be okay.

The Fibaro motion sensor could be an issue but see first if removing the ghosts helps (unless you have a Z-Wave stick of course...). The other 2 should be okay - you need security for those, especially the deadbolt!

If it works, don’t worry about it. If not, see if changing the driver to Generic Z-Wave Lock helps.

FYI - Here’s a link to Z-Wave network repair in case it is of interest to you:

Just so I understand, to remove a device is selecting "remove" under the z-wave details page, after I've unplugged or airgapped the device in question?

I remember I had trouble trying to reset a Zooz dimmer switch, and couldn't get it to exclude and then include at all. It's located in my detached garage, but I had the other z-wave and z-wave Plus devices pair at that location just fine. Maybe that would be the ghost device.

Also, without the z-wave stick, the Zooz devices and anything greater than the S0 security can never be more secure?

Thanks again, I appreciate it. My caveman brain is slowly turning on now lol.

Might try uplugging these. The z-wave side is know to cause issues with the mesh. If after unplugging things start settling down, I would remove the z-wave side of the plug and keep the zigbee.


Yes, it is very possible that this one was the cause of a ghost. I have had similar inclusion issues cause ghosts when I transitioned to my C7 hub.

The hub will allow devices that have S2 security to be joined with or without security (there’s a box that comes-up during their pairing providing those options). So devices that support it can be secured with S2 security, which is not known to cause issues. S0 triples the communications going from the device to the hub, so it can cause issues with the mesh.


I've tried methodically unplugging/removing batteries of every device one at a time, hitting "remove", and have no luck at all removing the ghost device. It always says "pending" after the page refreshes.

I don't know what to do next other than start completely over and be hyper aware of a ghost device showing up.

Really not looking forward to starting all over again, resetting every device, excluding, and then including.

The thing is, currently, and for almost a day now both all my z-wave devices and zigbee are working 100%, but that ghost device is still there. I assume I should stop before pairing all my other things, and it seems I can't get rid of the ghost so I guess I should start completely over.

Can the security settings be changed after the device is paired, or does the option only show when it's paired initially?

Security settings have to be done at inclusion; to change them you’d need to remove/exclude the switch and then re-include.


Sometimes it will take a little while, so I would wait a minute or so and refresh and see if it was actually removed. Also, some people have had success with a shutdown, remove power for a minute, then restart and try to remove again if it is still showing in z-wave details.

Finally, there is a special endpoint at http:// hub IP /hub/zwave/nodeCleanup that sometimes works to get rid of ghosts. It will return OK and then may take a minute or so to complete.


One thing I'd add is that for me it sometimes took many clicks on Remove for it to work. Like 5-10 tries. So if you've been doing one, two, or three tries w/Remove you might have success w/more persistence. Might not too. I had a ghost device that persisted, Remove never worked, I finally removed it w/a UZB stick.

I also had a "quiet ghost" that had no effect on subsequent pairings of devices or functioning of my mesh. I could have just left it, but eventually OCD got to me so I removed it w/UZB stick. Others have reported the same. :slight_smile: In a case where "things just work" despite the ghost being present, and you can pair new devices w/out issues, this might be a case where you can (if OCD permits) just ingore the toothless ghost.


Can a device that appears to be working, that shows as an actual device I recognize, cause a ghost? For example could there be "device 1" in addition to a "ghost", even though they're the se single device?

Also, if I do start completely over, should I select no security, since it seems that S0 is basically no security anyways?

I would assume the UZB stick might have too steep of a learning curve for me, and if it won't let me select a higher level of security anyways I don't know if that would help me out really.

I just watched the official Hubitat mesh building video on youtube. It recommended excluding devices from a previous hub, prior to starting with Hubitat.

I did not do that with Smartthings. I was told by the vendor I bought HE from to unplug my ST hub during the whole process. I just reset, excluded, included in HE.

I was also doing z-wave repairs after a few devices were paired. It recommended not to automate anything for a while, but I'm pretty sure I automated one or two things soon after pairing.

Not sure if I can anymore or if any of that would even be an issue?

Again, I appreciate the help and I apologize for the barrage of questions!

If the other hub is going to be used still, it is better to exclude from that hub so it doesn't suddenly have missing devices.

As far as the device and Hubitat is concerned, there shouldn't be anything that excluding from the previous hub would accomplish that isn't done by a device reset before inclusion, so I don't think this is likely related to your issues here.


S0 is security just very noisy high bandwidth security.

If a device doesn't support security it will join without security. If it only supports S0 it will join as S0, no way around this with the series 700 chip. The work around is to use another z-wave stick as a secondary controller this bypasses the hubs regulated security.

However if the device supports S2 (current highest security) then you get ALL options. You can join it S0 or none as well as all the variations of S2.


Yes...a ghost may be left behind and the next device in the details screen can be the "parent" of that ghost.

As noted, S0 security is an older security type, and is very noisy/chatty. Older Z-Wave devices often only support S0. It's not the end of the world to have S0 devices. I have two older Z-Wave S0 devices- a front door lock and a garage door controller, and my mesh works fine. But if you are buying new devices you should generally avoid ones that only support S0. If you get Z-Wave Plus devices you will generally be fine.

If you have a newer Z-Wave Plus device that support S2 security, you'll see this dialog appear when you join it to your hub. The general recommendation (except for locks and garage door controllers) is to de-select all checkmarks and join without security. So it looks like the dialog below.

As noted, you'd have to exclude and re-include a device to change its security level. And if a device only supports S0 then that's what you'll get unless you get a UZB stick and use a different process to join the device to your hub. Probably not worth it unless you find your mesh doesn't stabilize after you finish getting it set up.

1 Like

So, 5 hours later I have my first 20 z-wave devices online. Happy to say, I don't have that ghost device any longer. I have no automations or anything yet, as per the Hubitat youtube video.

After I wait the 2-4 hours and then run a repair, can I start adding again?

I also read on here that some devices that are reporting voltage, amperage, watts, etc might cause issues. Is it safe to change all my Zooz plugs to "no reports" and hit save changes?

Congrats! :slight_smile:

Don't run a Z-wave repair unless you have a device w/an issue, and always (w/C7) start w/an individual device repair if you have a device that is causing issues. W/Z-Wave Plus devices give them a day or two to work things out on their own - that's what Z-Wave Plus devices are designed to do.

Set reporting to as low as you need, and if you really don't need any reporting for some devices, turn it off. I only allow reporting by devices that I'm actually monitoring in an automation, otherwise it's just noise in the system. :slight_smile: Peace and quiet on your mesh is very good for it.


How is this actually done? If the device is pairs with the secondary controller how will HE find it?

What are the exact steps? I woul like to also change my S0 devices to None

You pair the UZB stick to your hub, and it pairs as a secondary controller.

Then you use the UZB controller to add devices to your hub.

Adding S0 only devices w/out any security may not work for all devices (or at least I'm not aware that it's been proven to work w/any S0 only device). There are some devices that support S0 that offer a way to tell the device to pair w/out any security during pairing - e.g., like double-tapping a button on the device during pairing.

What S0 devices are you interested in pair w/out security - if they are "barrier devices" like locks or garage door controllers I would leave them as-is.

You can see the UZB pairing steps in this doc that lays out using a UZB to remove ghosts, also has some limited info on using UZB to add devices to your hub.

UZB Ghost Removal and more