Z-Wave Issues / Stubborn Ghost / Cannot Add Devices C8 - Fixed!

Ok, I've been struggling with some Z-Wave Issues for the last week. Hoping someone might have some suggestions in addition to the 1000 things I've already tried...

Tagging @bobbyD @gopher.ny also...

So I've upgraded to latest platform versions as soon as they come out and recently migrated from C7's to C8's...

Everything was pretty decent, except I noticed a lot more routing and slowness on the C8 with my Z-Wave devices... I figured it just needed time to settle in...

About a week or so ago, I had some power failure issues. That led to several of my older GE/Jasco outlets and switches to fail... There are threads on all that and in fact I've actually had them replace many of the previous failures, but I still have many in that same year and time frame that seem to be failing the older they get... I digress...

Anyway, when they fail, as you may know, there is no way to remove them from the network. You have to do a force remove as the radio dies with the device...

I forced removed 3-4 of them and was able to remove the ghosts left in their wake... However, I there is one persistent one that will not remove. It shows a route in the details page, but I can assure you it is physically removed and sitting on a shelf in the garage...

I let the system sit for a few days as I was out of town, did many many complete shutdowns with power pulled and also tried reverting hub versions back to 2.3.4...

Here are some more details... I have a Zooz 700 Stick that I have used for ghosts in the past. NO MATTER what I do, I cannot get the stick to add to the hub... Even after tracking down the latest version of PC Controller and updated the firmware on the stick itself...

Then I tried killing the power to several rooms and nodes that the one ghost claims to be routing through... Of course, that didn't work and blew out another GE switch upon flipping the power back on.

Since then, I have not been able to add any Z-Wave devices... I get network busy messages, etc. And again, I have powered down the hub and pulled the plug, even after all this... Still no dice.

My network is slow and I can only assume it is because of the now two ghosts I can't remove.

Any thoughts on anything else to try?

As it stands right now, I can't remove the ghosts and can't add any z-wave devices including replacement switches I have on hand for the failures and of course, my stick...

Geez...not a good time for you, sorry to hear about all troubles. (Aside: Those older GE Z-Wave switches definitely had a weakness. Don't toss the GE stuff out, they have a 5-year warranty so hopefully at least some of them are still covered. GE will send you new Z-Wave+ replacements for free. Given the number of switches involved you might get a sympathetic customer support person to offer some coverage on out of warranty devices.)

Regarding your situation, you've done the right things, but haven't been rewarded w/the right results.

I assume you've moved the stick near to the hub (like a couple feet away) during pairing.

Have you tried pairing UZB stick in PC Controller via both the Select Learn Mode > NWI flow, and and via Classic Learn Mode?

Tagging a few smart(er) people: @csteele @jtp10181 @bertabcd1234

Thanks for the suggestions @danabw. I did try to pair the stick close to the hub using a pc and laptop with the same results... I did not try classic learn however and will try that next...

Yeah I have about 90 GE switches, dimmers and outlets... All plus models but most all purchased back between 2016-2018. So many have failed over the years... I sent about 25 back last year and they replaced them for me. However, most of those and the ones failing now are all from 2017, so being 6 years out, I doubt they will replace anymore. before I got the replacements and as they failed, I replaced them with newer models so I have about 20 of the replacements they sent me waiting for when others fail... That seemed like a pretty good deal last year when they replaced all those, but I was recently looking at the date codes on the replacements and realized they sent me older stock, mostly from 2021... I still think they are better and hopefully fixed the capacitor issue by then, but it wasn't like they sent me brand new 2022 models...

Anyway, I'll try including the z-stick with classic mode and see if I get any further... Thanks again for your help.

1 Like

There are videos on the interweb showing how to replace the capacitors... :wink:

Not holding my breath, but worth trying if for no other reason than ruling it out. Good luck.

I had 2 ghosts hanging out on my C-7 for an almost a year, probably due to the same power failure, but after my move to the C-8, they went away. I didn’t see you mention a Z-Wave network repair, but have you tried that now that you’re on the new hub? Maybe try that right after a power down and reboot… I think that’s when my ghosts disappeared. But it only took a few days for them to disappear, which sounds like it’s already been longer than that and many attempts for you.

Yeah I saw those videos... I'm not that great with a soldering iron but I might have to if my pile of broken devices grows anymore...

no luck with classic learn mode...

I read a few other threads that seem to follow along with what I am seeing...

Once other thing to note... In the last few days of messing with all of this, I forgot to mention I have seen random hub reboots... full reboots where the login in UI comes up...

The following is from my logs when I tired to include a device a few hours ago

sys:12023-04-02 14:57:47.686warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:44.686warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:41.689warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:38.686warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:35.692warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:32.692warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:29.684warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:26.684warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:23.684warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:20.686warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:17.684warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:14.686warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:11.684warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:08.684warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:05.684warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:57:02.684warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:56:59.685warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:56:56.686warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:56:53.685warnZ-Wave Network responded with Busy message.

sys:12023-04-02 14:56:50.767warnZ-Wave Network responded with Busy message.

hey brad,

i've tried a few select z-wave repairs on specific devices... including the one device my ghost is supposedly routing through... but i havn't tried a full repair... still operating off the belief that was not a good thing...

here are two other threads with very similar issues...

Post your zwave details page. If you want to get it all in one screenshot use https://getsharex.com/ and the Scrolling Capture feature.

I have done it quite frequently (every few months) in the past. I think the biggest issue is the immediate stress on the network during the repair process, but I haven’t seen any lasting negative impacts… quite the opposite. In fact, when I do it, I usually repeat the process a few times until I receive no device repair failures. I know someone might chime in and provide some more info, but my thought is, why would the feature be there if we should NEVER use it? I think just sparingly when needed is the answer, and this might be the use case! I would just do it when nobody else is home and nothing critical is happening where the devices are required.

Here ya go... I have sorted based on the device name. That puts the ghosts at the top... You can see one of the ghosts retains routing info no matter how many times I shut the hub down or even kill power to that device it thinks it is routing through. (front porch light)

EDIT: hold on, trying to figure out the sharex thing...

Having a hard time getting any screen capture/scrolling app to work... but this was the best i could do...

Just to continue to rule things out and reduce the number of potential issues...have you done a hub local backup/restore?

Download the backup and then immediately restore it. If some of your "adventures" have resulted in any DB corruption, doing the local backup "cleans" your database.

Regarding full vs. device-specific Z-Wave repairs...I look at it from the perspective of throwing your entire mesh into potential re-routing at one time vs. operating on one or a few targeted devices. In general the recommendation from staff has been that starting w/individual repairs is the recommended approach.

1 Like

I'll try the database backup and restore... haven't done that... i did roll back firmware, but didn't mess with the database... I'll try that next.

hey @danabw, are you recommending restoring the backup to include the zigbee and zwave radio settings? I did a cloud backup and started to restore, but when I got to that option I stopped and figured I should ask... I was just going to do the regular database restore... in fact, are you recommending a local restore or cloud for that matter?

Just local backup-restore. Not cloud! :slight_smile:

got it... ok... :joy: :grimacing:

1 Like

May not help anything... But easy to do and does no harm.

1 Like

@rlithgow1, get your butt in here and help! :smiley: Forgot to tag you earlier.

Just tried to add my z-stick again and got this error...

Z-Wave Inclusion timed out, status:7

However, on the PC Controller side, it partially added and there are a handful of devices showing... nothing on the hubitat side other than the error...

EDIT: I immediately hit the include buttons again on both sides and got the same error on the hub but PC Controller added several more devices... I tried a third time when the counters hit zero and this time, PC Controller deleted all the nodes it had added and reset the stick back to 1... Again, nothing visible on the hubitat...

I'm no expert by any means, but there just might be something wrong with the z-wave stack on these C8's.

Have you done a full power cycle? (shutdown then unplug for 5 mins) to clear the radio? Also remember when dealing with the software don't confuse hex for dec.