Z-wave issues after upgrading to C-8

Are you rebooting or doing a full power down? Try a full power down and pull power for 10+ seconds then boot back up. If its going downhill that quick just let it run for 30 minutes then get a screenshot, or get one right before you reboot next.

If you have any power metering devices or any multi-sensors try powering them off as well, they are the most likely culprits of excessive traffic.


It would also be beneficial to post screenshots of your Z-Wave details page.

1 Like

Screenshots of the Z-wave detail of the devices?

Settings, then Z-Wave Details.

It'll be a single table of all your Z-Wave devices.

1 Like

Oh boy...
See all those entries with the "Discover" button? Those are failed pairings that never completed and then you tried again, and again, and again, and finally got it to work from the looks of it.

First step is going to be to try and get rid of as many of those as possibly the normal way. First open logs on a separate tab/window. Click REFRESH ONCE, wait for page to reload. Find device again, if it does not have a REMOVE button, press REFRESH AGAIN. May take 2-3 refreshes to get the remove. Once you get the Remove, again, click it ONCE and wait. You can watch the logs for a success or fail message.

Do not get hung up on ones that are stubborn, just try and remove as many of them as you can first. This should help get you going a lot better even if you only remove 50% of them.

This post a compilation of a bunch of info about the subject including how to forcefully remove the stubborn ones with other software: Z-Wave Ghost Removal using a UZB-Stick - How To

1 Like

You have a total of 14 ghosts. Likely transferred from your c5. I'm surprised your c5 worked at all. You need to get rid of them. As @jtp10181 says you can try removing them manually or you will need a z-wave stick to remove them.

1 Like

I actually went back to C7 after using C8. My old C7 had the antenna mod and I got at least twice the range over the C8, even tried 3 different antennas.

So I went down the list of my Z-wave devices following this instructions and I was able to remove just 4 ghost devices. all the rest are either stuck with the remove button not doing anything and getting a "Z-Wave Network responded with Busy message" and the others are just in a "NOT_RESPONDING" mode. looks like I will have to order a Z-wave stick.

You can also try shutting down the hub, powering it off for 5 minutes, them power it back on and try again.

1 Like

I got the same results after the second try. worth a shot though!

You will need to use a z-wave stick to remove them then. :frowning:

1 Like

With as many problems your Z-Wave mesh has, you might be better off resetting the radio and rebuilding the network. Your hub will be happier in the long run and could benefit tremendously from starting with a solid mesh.


I did think about that for a minute, but some of my RGBW controllers are in very difficult places to access, at this point it would be a last resort.

Do you have a USB Zwave stick you can use? Any model should work, 500 series chip or higher possibly 300 even).

Just ordered the aeotec Z-wave stick from amazon, should be here by Saturday.

May I suggest that you try again to remove those ghost devices?
It does take time, and more importantly patience.
You can see from the logs if the remove button has worked.
It's best if you do it at a "very quiet" time, i.e. nothing is happening in the z-wave world.
Keep on trying to get rid of them. Eventually you should be able to get rid of most (if not all) of them.
It may even take a few days. Whenever you see the remove button, try it.

Tried it again yesterday around 2am, though it was worth trying while i wait for the Z-wave stick to arrive, unfortunately i just got the same results, I tried a complete shutdown and unplugged for 10 minutes, afterwards i did the whole Refresh/Remove process.

Are you also removing power from the devices before trying to remove the ghosts?

1 Like

I didn’t the first two times, but I gave it a try last night again. I went to my breaker box and shut off the rooms with z-wave devices but no avail, im still stuck with the same ghost devices. Worth a shot.