Z-Wave devices will not pair correctly. Routes appear/disapper

If, after multiple attempts I can get a honeywell z-wave zw4008 to pair, sometimes.

Z-wave and Hub firmware are up-to-date.

If I just uses generic exclude/include, its comes up as a Jasco dual outlet. If I try to make it a GE enlighten switch, it comes up ok, BUT WILL NOT OPERATE.


I'm new and so far very disheartened by the poor connectivity of Z-wave devices. SmartStart is worthless and brings up a perpetually pending inclusion that never completes.

When I do manage to get an outlet connected, with a route, It will NOT operate in the devices or dashboard. When I run a repair, it says "Node can't be found"

I've had other outlets seem to pair but lose their routing. Reset the z-wave settings several times.

I'm starting from scratch and am starting to think I have a bad hub.

I must be doing something wrong. Please help

Based on details provided, it doesn't sound like you are having a bad hub. Because you are starting over make sure that you are following the instructions in the following document:

https://docs.hubitat.com/index.php?title=How_to_Build_a_Solid_Z-Wave_Mesh

It sounds like your device may not be able to include properly or is outside of the range of the hub. Starting adding devices close to hub is the only way to ensure good Z-Wave connectivity of your devices. Also, if a device is giving you troubles when you are trying to include it, be sure to check your logs (past logs) - there could be clues as to why the device isn't including properly.

Thanks,

The the end of building a solid mesh, I've got my hub in the open center of the house. The first wall switch (Honeywell ZW4008) and Multisensor HSM200 are line-of-sight to the hub. If I can get these two up and running, it will be the start of a good mesh.

Alas, the switch got mislabeled as a Jasco Dual Outlet. and does not work. Dashboard only shows question marks for each.



The question mark on the Dashboard means that the device status is missing. If you go to your Device Details page, you may need to select "Configure" button. Also, the hub picks the driver that is closest to the device details it knows. It could be that your switch fingerprint matched the outlet. Changing the driver type on the Device Details page should resolve that problem, just remember to select "Configure" after you update the driver type. If device doesn't work, you may need to exclude, then include again. As previously mentioned, screen your hub's Logs while including the device, it might try to include with S2 encryption and it fails. That may explain why is not working.

So, the "change type" and "configure for the 'Jasco Dual..' seems to have worked.

Anecdotally, Of course I had removed the old ADT Pulse box but-I finally remembered to unplug the old ADT control box (with the wires and transformer and battery). Now the device turns On and Off in Devices tab and in the Dashboard and changes colors there, like a real Z-wave system!

I was losing hope.
Thanks!

1 Like

....and then trying to exclude a nearby outlet-The wall switch (labeled and all) popped up as excluded! Grrrrrr. I'm trying to get it back again.

The exclusion process is a handshake between the hub and device. Both must agree to leave the network, one cannot kick the other out of the network. Are you sure a different member of your household didn't operate the switch at the exact same moment when you started the hub exclusion mode? I can't imagine that the switch remained in exclusion mode, unless it has a hardware malfunction.

1 Like

Right?! but that's what happened. Anyhow. I've gotten it back, but it only works to turn the light OFF. I've seen that elsewhere on there chats.

When I run a repair, I get this:
Screen Shot 2022-03-25 at 7.45.30 PM

I've tried a couple different device drivers. The UltraPro switch is my best interface, but still only works to turn off and now, won't communicate.

You have a couple of unresponsive devices, so is normal for the one device that appears to be connected to the hub, to fail. Reset the radio again and start over. Don't move to the next device if the newly added device doesn't work as expected. Also, check your logs while you are including devices, and if they are giving you hard time during the inclusion.

Check this post to learn more about why the repair in your case isn't helping you:

4 Likes

I Followed your advice. Started from scratch. Got up to four connected devices! Each one stable and working from device/dashboard interface-Then 3 lost routes and the fourth (HSM200 Multisensor) makes a question mark on the dashboard.

Does is matter that my HE is plugged into a Google WiFi 'puck' on the middle floor of a 3 story home. Other 'pucks' are upstairs at modem and downstairs to cover the whole house.

Is there some IP address assignment I should have make or something? This can't really be how tempermental the HE system is with z-wave, right?

The puck wouldn't have anything to do with z-wave. From all the issues you seem to be having, likely you are going to need some beaming repeaters like the Ring V2. Everything I'm looking at is that your mesh isn't cohesive. Start with something close to the hub, work your way out, adding repeaters as necessary

2 Likes

I’ve ordered two Aotec Range Extender 7 to help with mesh. I’ve got 4 devices, including the Ring V2 contact sensor, added and stable with routes (not ghosted yet!).

The HSM200 multi sensor has only ever made a dashboard tile with a question mark.

I’m going slow with this trial.

Aeotec's tend not to want to route... not sure why. Ring v2's are more reliable, and they have batteries so if that circuit goes off it can be used as a trigger

3 Likes

I get many folks here prefer Ring v2s over the Aeotec RE7s, but my RE7s are routing other traffic fine.

They're on the latest Aeotec firmware (1.05) and are paired with "None" security (i.e., not S2).

Anyway, if you already have the RE7s enroute, they should work OK. If you'd rather return them for Rings, that should work too.

In any case, be patient when looking for results -- it's almost certainly not going to be immediate gratification.

"Be patient" is a good mantra for all things z-wave with Hubitat -- the latest z-wave stack firmware available with Hubitat helps a ton overall, but when building out your z-wave mesh, use good technique and trust that it'll work. Don't keep looking at the routing information and expecting to see immediate results -- it can take sevceral says for a device to really "settle in" your mesh.

Build your mesh out near to far from the hub, place repeaters strategically, and carefully monitor each individual new-device inclusion for 100% success -- going too fast and ending up with device ghosts (due to botched pairing) is a sure-fire way to end up with a mess of a mesh right from the start.

Patience is key :wink:

5 Likes

Same.

1 Like

Did anyone say patience? In case no one did, patience and perseverance are prerequisites when tackling any home automation project. The rewards are infinite for the future of your elevated environment, and your hub will thank you time and again.

5 Likes

_butiwantitnow

4 Likes

A general suggestion to simplify your process while you're trying to get devices connected and working, @JayInPtown.

I typically don't start setting up dashboards until my devices are settled and configured. That way if you're making any changes on the device side you don't end up with dashboards littered with disconnected devices and incorrectly configured devices etc., that can add to the confusion.

Just a suggestion that you start with getting your devices joined properly and confirm that they can be controlled properly from their device pages.

Once things are hunky-dory with all your devices then go ahead and start building out your dashboards.

Just a suggestion, everybody has their own process, but I think that would help you.

4 Likes

I was able to swap out the Amazon order for Ring V2. Probably best since I also bought a six pack of Ring V2 contact senses.

That’ll be here Tuesday. Till then, I’ll keep trying to build out my mesh beyond the one room that all 4 current devices live.

Thanks

1 Like

I was so excited once I got the new Ring V2 repeater paired! Now, Suddenly, I've got a lot of lost routes.

Everything was working before the Repeater, now....

Suggestions? Refresh/or repair individual devices? Remove and re-include?

Thanks


Download the Hubitat app