[Withdrawn] TP-Link Tapo Device Integration

This integration is being withdrawn for new installations. Unfortunately, TP-Link has chosen to change the encryption/handshake technique on at least some of the devices and I can not guarantee any devices will work into the future.

I am working on the KLAP encryption and will come back when the integration can use either encryption type.



Should be quite useful, sadly ditched my Tapo stuff on the donors. I take it this won't be happy with pre C8 hubs?

My experience of the Tapo stuff is it's easy to use and very reliable, except in cases of WiFi or Internet issue..


1 Like

These look absolutely identical to their Kasa conterpart but what is different inside? Do they need to be pulled like the Kasa ones?

The Tapo devices use different control and information commands (api) than Kasa. Additionally, the Tapo devices add RSA-based key exchange and encryption of command strings (unlike Kasa).

1 Like

Developed on my C7 Hub. I will eventually install on my C8.

1 Like

Cos the ones I had are Wi-Fi based, unless they've changed their protocols and setup. But if the dev work was on a C7 then they'd be great, if I had any left. Still I have plenty of LSPA7 smartlife wifi sockets and probably a spare WiFi bulb that can be used as a bridging trip.

Mostly G.Home controlling hubitat > tuya zigbee and Smartlife Wi-Fi legacy with bridges between the Hubitat and Smartlife via G.Home. Planning to prototype a smartlife RGBW bulb as a bridging trip too.

Tried to get the broadlink to play with Hubitat and couldn't. Too ill to be mucking around with it now, and prospects bad..

Do you mean Broadlink bulbs? If you're talking about that hit me up by PM and maybe we can figure it out. If you're talking about remotes, please post in my thread for those.

Let's keep the chatter in this thread to be related to @djgutheinz's Tapo work, another great contribution to the community!


Still don’t understand why this would matter.

The bulbs are connected to the LAN, wirelessly. Hubitat hub is connected to the LAN either through Ethernet or WiFi. The C8 has built in WiFi, the C7 was able to use certain USB dongles. But unless I’m missing something, that’s irrelevant.

There is no direct communication between the WiFi bulbs and the hub.


Update to Version 1.0 RELEASED. See top of thread.

Recently bought the Tapo Hub (H100) and installed your app/drivers (using HPM). The app installs and configures with my login and password, but when I try to discover devices nothing ever shows up in the drop down list. I’ve captured the debug-enabled log for you to see. I will send it off list.

Finally needed another smart plug so thought time to try the tapo range...

So I have my P100 in installed in the tapo app and it's working.

Installed this integration through hubitat package manager. Installed all drivers. Entered credentials in the integration. No devices found when trying to add them.

Went into tapo app and realise two factor authentication was on. Turned it off..

And unfortunately still no devices found.

I've waited patiently for a few minutes.

Any ideas?

Edit: Seems I'm not the only one. I enabled logs but I didn't see any errors.. But maybe I didn't wait long enough for something to be generated.

Read your post. Children for the hub are not on the LAN. They are connected via a separate technology. Installation is via the Hubitat HUB instantiation. Instructions have been updated:


Check you LAN and Wifi Settings. If you have place the devices or hubitat on a protected vlan, then Hubitat will have a problem.

After confirming LAN security is not an issue, try again with debug logging. Without data, I can do very little.

Note: Also try exercising the device just prior to installing. Sometimes the devices may go into deep wifi sleep and do not catch that first command. (the driver retries commands if they fail the first time, so not an issue there) I am looking at methods to solve this in the application - but it is hard to test because of the word "sometimes".

Thanks for the reply. The issue isn’t children of the hub, it’s the hub itself. The app never shows the hub to install. Here’s a log with debug on. Right now the hub is the only Tapo device I have.

No vlan for me. Is it best I PM you my screenshot if log? Or text based?

I don't see any error in the log. A warning for a tapo cam I have but no warning or errors for the plug. The correct IP is shown in the logs for the plug but I don't see anything in the drop down box.

I see an error. In the app, select "Modify LAN Configuration". Set the host as below. Something at the first address (1) is replying and it is an invalid message.

If this fixes your issue, I will close. But I will still modify the code to isolate the error better.

Is this cloud based or local to the tapo switches


1 Like

I just narrowed down the IP range to below and above the static IP address of the hub and it found it. Thanks for the tip!