Will GH Mini's Play MP3's?

I tried to use Message Central to play an MP3 through a GH Mini but when you click on which speaker you want there is nothing in the list. I have GH Mini's working.

Where did the speaker list go?

How do you have the mini's integrated to HE? There are two ways that you can do it. If using the native integration, you can use the "Play Track" command in the device page itself. In order to use this, you would have to create a custom command but the first step is getting your MP3's hosted. They have to be on a web server that is accessible my your GH mini. I use github for mine. Then, when you create the custom command, enter the file's url as the parameter. You can test it out first by putting the URL in the command on the edit device page.

You can then trigger this action anywhere in Rule machine.

If you want to integrate your speakers using Cast-Web-API, there's an app called MP3 Event Player you can use to play the tracks that way. Still have to have them on a web server accessible by your GH mini. This can be triggered off different things. It's 6 of 1, half-dozen of the other really.

Thanks Ryan, I will take a look at where I can store them.

What custom command did you create to play a hosted Mp3 file?


You have it right there... Play Track. You can't play from Google drive unless it's a public file. Try github instead.

Ya, I could not figure out how to share an mp3 from github, I must be missing something.

I use Github desktop to sync my repo with my desktop. Then you have to get the raw file path.

Do you get the RAW file path from within Github Desktop, I am working with it now and like it actually :slight_smile:

I figured it out, I was making it harder than it needed to be :slight_smile:

No, you have to get that from Github but the general formula is:
https://raw.githubusercontent.com/USERNAME/REPO NAME/master/FOLDER/FILENAME

all of the bold items would have to be swapped with the real values. Oh, and don't put any spaces in your files names. They will get swapped withe %20. Just use underscores instead.

OK so everything tries to work, but the Lenovo Smart Screen starts to load the Mp3 then does not play it, not sure why but I did get it to play on other Google Mini's in the house.

Tried to load it and doesn't play? Does it post an error? Any errors in the logs?

No just buffering:

Have you tried a different MP3 file? I dunno what to tell you. If it works for a Google Home mini, maybe it's a problem with Lenovo.

I can say this....you're URL is missing the http:// So, I don't understand how it is playing at all.


Ya I was trying it a few ways with and without the https. I did notice that lenovo has some issues with buffering and queuing though. It seems to get "clogged" more often from TTS.