WEMO Link Device

Greetings earthlings!

Just fired up my Hubitat and having a play with a few lights with great success.

I also have some (Belkin) Wemo lights which use a WEMO link device to connect and control them. I have searched through the community and found the WEMO connect app that @Jason0x43 kindly provided and somehow managed to install this. However, it does not detect them. Just wondering if this version of WEMO lights are supported in any way. It may be easier to replace them :slight_smile:

Any help greatly appreciated

I replaced mine. They have always been problematic and they never stayed synced with hubitat. I was always find ting them off when they should have been on and vice versa.


It seemed to slow down my hub a bit. Especially as I added more devices.

1 Like

I have 2 WeMo plugs, 2 dimmers, 2 3-way switches and 2 regular switches that I bought before getting my HE. All of these were discovered with the WeMo Connect app and I've never had any issues controlling them. I've also unlinked WeMo from my Google Home and added them back through the Google Home integration app in HE, completely cutting out WeMo servers from my automations. This sped up responses and cleared up issues I was having with Google not connecting to WeMo.

so no bulbs ?, did you need the link for the dimmers and switches ?
I have bulbs here I thought I had to use the bridge for so I didnt add them back in when I got my HE.

No, all my bulbs are Hue bulbs. The switches didn't need the link either.

I haven't tried the WEMO bulbs without the WEMO link (bridge). I will try tonight and see what happens.

ah - his question was for bulbs though. If they can work without the link or to toss them.

Alas, HE found nothing with and without the WEMO link. Not overly concerned.

I noticed that the App caters for;

Maybe it just doesn't cater for standalone bulbs


1 Like

Yeah, there isn't currently a driver for standalone bulbs or the Link hub. I've only ever had a first generation WeMo switch and a WeMo motion sensor to test; everything else has been a bit of trial and error.

Thanks for the update. I will just give them to a friend.

Wemo bulbs are Zigbee and, once reset, should be able to connect directly to the HE without need for an App or a Driver.

Reset the bulb... Once the bulb has reset, set it to off then go to:
Devices -> Discover Devices -> Zigbee

Once the HE is in pairing mode, turn on the bulb... and The bulb should be detected and added...

To Reset a Wemo bulb to factory settings:

  • Start with the WeMo LED on
  • Flip the switch off and wait 1 second before flipping it back on.
  • Wait 3-4 seconds, then repeat two more times.
  • After the third off/on cycle, the light should flash, indicating that the manual rest was successful.
1 Like

Wemo bulbs are wifi.

1 Like

They are discontinued now, but the Wemo F7C033 bulbs were zigbee.

That explains why I couldn't find them listed anywhere. :stuck_out_tongue:

1 Like

The model I have (MZ100) appear to support with or without the WEMO link bridge.


Just still not clear if these ones are wifi or zigbee. The reset worked but HE still didn't find them. I might have one more go.

All wemo bulbs are Zigbee... They are intended to connect to the Wemo Link, which speaks Zigbee HA1.2 to the bulbs and connects to the local network/internet via WiFi. Because they were designed to work with the Weno Link, they were advertised as "WiFi Enabled".

As mentioned, the bulbs and the Link are long discontinued.

That has to be the most deceptive advertising I have EVER seen!!! I saw these all the time and always thought they were wifi bulbs! Good lord...i'm surprised they weren't sued over that one. That's terrible.

Bingo! After trying the Reset again, they popped up. Set as Generic Zigbee devices and they are up and running. Thanks @cybrmage! Much appreciated!

you got the bulbs to connect ?