Webhook POST to Synology Surveillance Station

Need some help here, please :slight_smile:
When I hit this link (fictive example) in my browser some snapshots are taken in my Synology surveillance station (--> the link is working)

https://192.168.158.213:12312/webapi/entry.cgi?api=SYNO.SurveillanceStation.Webhook&method="Incoming"&version=1&token=NSEjblablablablamqqJw627ww6

I can not make it work using a send GET or send POST in rule machine

If I try send GET, I only can paste the link, this does not work

I geuss I need to use sent POST

How do I need to fill in the 3 fields to make it work? I have try many combinations without result

Can anybody help? Is it possible to sent httpS ?

I don't think you can use https, just http, but I could be wrong.

What is it you are trying to accomplish? If it is to show the cameras on your dashboard get out the post below. I don't have my Surveillance Station running yet or I could provide more details.

1 Like

I want to send a trigger to my synology to save some snapshots, It works when I paste the link in my browser , I get {"success":true} and the action rule in my Synology is running (the snapshots are saved).

I have no issues to show the streams on my dashbord, this is working fine

Try like this (both http and https, make sure http is open on the NAS, or/and test with http 1st)

This is how I automate rebooting my hub.

Ha, I found it :slight_smile:
This HTTPS link:
https://192.168.158.213:12312/webapi/entry.cgi?api=SYNO.SurveillanceStation.Webhook&method="Incoming"&version=1&token=NSEjblablablablamqqJw627ww6

needed to be changed to a HTTP link with the HTTP port of the Synology NAS SurveillanceStation
http://192.168.158.213:12313/webapi/entry.cgi?api=SYNO.SurveillanceStation.Webhook&method="Incoming"&version=1&token=NSEjblablablablamqqJw627ww6

This is how I need to make the POST request (without the "?")

From now on I can send a trigger to my Surveillance Station to make for example some snapshots:-)

1 Like