webCoRE for Hubitat Updates

webCoRe can be used in HE but from experience I would advise not to use it.
It slows my hub down and I have found that I can do everything I had in WC on ST can be replicated In RM3.
It may take a bit of playing to get used to it but worth it.
This is just my opinion from my experience and others I know are using it.

I'm running @nh.schottfam's maintained version of WC and not seeing any issues.

One difference between WC and RM is how user's can easily create something in WC that would negatively impact hub performance where as it's tougher for users to create something with RM that will cause a hub slowdown.

If you @Aldo had good experience with WC and STs then you will probably be happy with it and HE.

From my experience, if you run into an issue @nh.schottfam has been helpful to figure out what might be going on and if a fix were possible he provided it.


you can use both. They show up as separate hubs in your webcore dashboard (same as if you had multiple ST hubs).

1 Like

Great. I read as well that having many devices authorized to show in WebCore can cause issues. How many are considered too many? I have about 90 including virtual and physical devices.

I have 40 devices showing up for Webcore.

Actually I just counted them and I have about 130. Could this be a problem?

You could also keep WebCore on ST (for anything you couldn’t replicate in Rule Machine) and mirror some HE devices onto your ST hub using HubConnect for participation in those particular WebCore pistons. I.e. mostly local on HE using RM ..

I don't expect the same issues ST has seen.

That said I don't have 130 devices.

You might create / import some pistons, and add devices and let me know of any issue. If there are issues, I likely could address them once I see them.

Great it would take me some time but I will post here anything I find. Thanks for the great support

Curent Release Updated May 31st, 2019

  • Updates for device capabilities and commands (auto-fill in IDE)
  • fix for physical and programmatic device trigger filters
  • Experimental support for $weather variable based on APIXU data
    • this can be enabled by:
      • installing the storage app
      • entering your apiXU key in the webCoRE app (HE Dashboard -> Apps -> webCoRE)
    • data format is apiXU data format (pistons need to be modified to this data layout)
1 Like

I just upgraded to the latest release and everything seems to be working okay. The problem I have is when I launch staging.webcore.co I am given the message "A newer UI version (v0.3.10c.20190522) is available, please hard reload this web page to get the newest version."

I have tried several hard reloads and the message won't go away. When I create new pistons it still shows the old revision. Any idea what is going on?

I even tried loading up another browser and and after authorizing it, it too gives the same message. I don't know if this is a big deal or not but if anyone has an explanation I will be grateful.

Edited: Is staging.webcore.co even needed anymore? I was using it because it was providing the proper endpoint URL as apposed to dashboard.webcore.co but I just checked and both are returning the same URL so it looks like using the regular dashboard is the solution?

it should be resolved when staging gets an update of the pull request i sent the webcore team. it is cosmetic and nothing to be concerned at this time

Edit: I provided a submit to the webcore team - I have not seen them release it yet. It is possible they reverted staging, but I expect if they did they will soon put the pull request there for testing.

So in short, as far as I know you want staging if you are using the mentioned functions (external access URLs, local fuel stream displays, want to execute rules)

1 Like

is there a WebCore team for HE maintaining it ?? is it the original team that created it for Smartthings?? I thought you were the one doing the maintenance and fixes.

The service side changes are put into the webcore servers by the webcore team.

They have been very helpful to me throughout my updates.

1 Like

Request for testing.

the webCoRE folks have posted the patch for HE on staging.webcore.co

This is a request for HE folks using webcore to try out staging and report if any issues are found. This is the next step in the main webcore servers being updated with HE support.


Hub keeps breaking daily now. I turned off often-run pistons; will see if that improves anything. So far, this is the second day when WC basically loses all the devices - I open any piston and instead of the device name it shows its :code:. Naturally nothing runs. Need to restore the whole hub backup to get it back up and running.

Does the issue happen on staging.webcore.co, or dashboard.webcore.co or both?

Any error messages in the Logs in the HE dashboard?

If you want to move to private message to limit data exposure, we can do that.

Also what FW level is your HE hub, and what version of webCoRE are you running?

I am yet to figure it out... It definitely happened in the dashboard/webcore/co, as I only learned about staging tonight. However I don't think that crap-out happened due to the dashboard. I just noticed that one piston got stuck, thinking that one of the switch is on, while everything in the hub was showing it as off. When I went to inspect other pistons, they all were showing device codes instead of names.
I turned off some of the pistons that were running on a 1/5 minute intervals - probably were thrashing the hub, and in case of any memory leaks, were quite detrimental and see if it happens again tomorrow. Nothing was in the logs, at least as far as I could tell.
It's the latest hub version (updated last night) and May'31 webcore, as I only migrated from ST to HE last Sunday.

This sounds vaguely familiar to this.

Have you checked the hub itself? I’ve been running WC for months now with very few issues.

Hi, regarding this. I think there’s an issue here in the UK with this. We use postcode which has a space, but is this using the code in the Hubs location and mode settings? Pretty sure apixu doesn’t like the space.

Eg. Postcodes are AB1 2CD
Not like 90201 etc.

I put mine in without the space in WC, but it still threw errors. I removed the postcode from locations and modes and now appears ok.

Any way to change it so that it doesn’t take the postcode from the location settings, and just uses the postcode in WC settings?


Ok may appear a mute point as HE won’t allow me to put my postcode back in anyway (to reproduce the issue). States it’s invalid which it’s not, so I’ve left it blank.