Washer and dryer done alerts

It can be either. If you set it to 0 it will immediately detect the blinking, but if you increase the detection delay, you can adjust so it looks for a change when the light is off, thus it doesn’t detect blinking. Mine is set to 4 seconds. You Have to do some experimentation to get it right for your machine and the cadence at which the light blinks.

There’s also a no detection setting, but I think it didn’t work for me :thinking: can’t remember to be honest, but I know that my setup works as I expect it to and doesn’t detect blinking.

Interesting. On our machine when it goes into rinse the light of course is solid. Then when you go in to add rinse you press the start button and it pauses the machine and at that time it blinks. When your done adding rinse you press the button again and then it goes back to solid until the cycle is finished. In the rule it is a timing issue. If I were to press the switch a second time to resume and the light was off (very narrow window) the rule would think the light had just come on and fire the rule again. So I am wondering if I set the duration to the longest time and then if I were able to put in rinse and start the machine again all within 20 sec. it should work! :grin:

1 Like

@SmartHomePrimer, would you mind sharing your rule for the light sensor? I have one that I've been struggling with to work with my dryer.

Mine has a light that turns on when the dryer is running, flashes during a cool down period, then turns off when complete.

I tried to set it up so that a couple of lights flash for 2 seconds when it is finished, but often the lights flash for much longer than that, which is a little annoying.

Thank you.

My rule won't help you much. I'm just looking for the child device to turn off and then turning on a switch that handles my notifications. You'll do better by adjusting the setting in the driver. Here are mine for my machine, but it takes a bit of experimentation.

Is there really not a cheaper light sensor than that? $40 to monitor ONE light... ouch.

1 Like

I built one using the Hubduino project and a photoresistor.

that sounds like a fun project. might have to buy some parts. Do you know if the sketch allows for two inputs, or is there only one analog input?

I didn't use the analog input, I created a binary sensor and used one of the digital inputs. You can buy one readymade and just wire it to the board.
https://www.amazon.com/WINGONEER-Digital-Intensity-Resistor-Photoresistor/dp/B07B94Q1C8/ref=sr_1_8?keywords=arduino+Light+sensor&qid=1578025776&sr=8-8

This sensor has a digital output that can be adjusted by the pot on the board. I then just have the photoresistor taped over with black electrical tape to keep extraneous light out.

Definitely expensive, but it’s also a Z-Wave Plus repeater if that makes the price easier to accept. :joy:

The HubDuino is a nice sounding alternative. :+1:t2:

Back to the Samsung SmartThings Outlet [GP-U999SJVLDAA]. I can turn the plug on and off, but I can only see the wattage when I manually do a refresh on the device page. The data is saved to History.
I am almost there - Does anyone have an idea about what to do next?


image
image

You have the automatic power reporting set to 500watts. I think you need to adjust that setting.

1 Like

I was thinking values were for total watts - I see now that it it is for reporting increments. Thanks so much for your help - you saved me some hair.

1 Like

Be careful with that in conjunction with Rule Machine. It may have been the way my rule was written, but we determined that was the cause of my hub crashing/freezing/whatever. A power outlet set at a 1W reporting threshold creates a lot of events. A rule that executes on those events has the potential to bog things down to the point that they stop entirely. Killed the rule and the hub has been rock solid since. YMMV, but if things start getting funky I would try disabling the rule as the first troubleshooting step to avoid a lot of hair pulling. :crazy_face:

Thanks for that. I am starting off with 30 watt increments.
I am aware striking a balance. I have an automation to turn on a bulb in my closet. That is the first thing I see every morning.

I use the Aeotec switches and 1W reporting with no issues, however I’m using my own custom app instead of rule machine. I haven’t seen any performance issues.

Hi Don, I have the exact same device that is reporting at 5 Watts resolution, it seems to report fine except when the washing machine is finished I get a last report of say 70 Watts. No good as I am looking at a trigger of below 5 Watts to send me a "Finished" message. If I then go to the Device and look at its configuration page and press the "refresh" button I get a value of 0 Watts, a true value. Why it sticks on a non-zero value greater than the resolution value (5 Watts) I dont know. I need to force a refresh from Hubitat somehow.

There's another, similar app....

It also includes a "deadman timer" for exactly that non-report reason. ( Last in the screen cap. )

2 Likes

Wow, thanks for the quick response. I am completely new to "community" life, a bit of a hermit when it comes to collaboration. Maybe this Hubitat will change all that. Have never used Groovy before. I have done what you and the Help dialogue have suggested but have failed at the first hurdle when I try to save the new App. I get the result in the attachment

I don't know if you are the person I should respond to with a question, let me know if I am out of line. I expect I am doing something simple and stupid, are you able to assist?

Regards...

here is my port as well.

Install the Parent code first.

Download the Hubitat app