Unable to authorize new hub in SharpTools

[2.3.9.147] C8 Pro

I migrated from a C8 to C8 Pro. I’m ve trying for about two days to authorize the new hub in SharpTools to allow me to run their migration tool.

So far this has been unsuccessful. SharpTools support indicates the problem lies with the Hubitat OAuth severs, and specifically with the second step - “Failed to swap OAuth code for token. Received status ECONNABORTED

I’ve now lost the use of my dasboards. How can this be resolved. I’ve run through the authorization process many, many times.

Thanks.

Is new hub connected via ethernet or wifi?
Have you tried shutting the hub down and unplugging for 30 seconds then booting back up to see if it will reconnect to the cloud?

To check the cloud connection
Go to : My Hubitat > Registered hubs page
Then click on the details for your problem hub.
Check the Last Checkin and Active info, this will tell you if the hub is connected to the HE cloud servers.

There have been a few cases where the hub is having a hard time connecting to the cloud system.

image

Also tagging @josh from Sharp Tools

1 Like

Is this a SharpTools issue or a Hubitat issue or somewhere in between? Suggestions?

On the surface looks like there is some kind of timeout between SharpTools and HE when authenticating.

What if you click on the "experiencing performance issues" text?

Saw where someone yesterday was reporting a 401 error with that message. 401 usually means that the credentials were not sent for authorization.

Depends what error (exactly) that SharpTools is reporting.

Could be somewhere in between. Give it a few more minutes, then try again.

1 Like

Thanks for the tag! The communication with the Hubitat Cloud Relay is fine. Anybody who already has their location and devices authorized can continue to use them.

It appears to be limited to the OAuth servers.

That links to this thread on the SharpTools community:

Hubitat OAuth Connection Issues - #2 by josh - SharpTools.io (web) - SharpTools Community

It describes what's going on and a workaround for users who already have their hub authorized and just want to update their device selections. And it points to the following Hubitat Community thread:

--

I would note that this is impacting other integrations that use OAuth to connect to Hubitat including Google Home and IFTTT as well. It seems to be an intermittent thing, so as @bobbyD noted, sometimes just waiting a few minutes and trying again solves it.

Just kept trying. Worked eventually!

2 Likes

Can you guys give it a try again? :point_up_2:

1 Like

working :slight_smile:

1 Like