Tuya zigbee plug

I have a few tuya zigbee plugs (Tuya Smart Zigbee 3.0 Stekker 16A Eu Outlet 3680W Meter Afstandsbediening Werk Met Alexa En Tuya Hub|Building Automation| - AliExpress)
they should have power metering but I can not get it to work. The only driver that can turn the plug on and off is the "nue zigbee switch"
does anyone uses these plugs and what driver works for you?

Generic zigbee outlet driver should work (make sure you click save the configure when you change it) Then within the driver you should see reporting options. This is providing they actually meter)

Thanks for the reply. That driver does not work. I tried it before (and now again to be sure) I cannot even switch on or off with this driver.
Most drivers will not let me switch this plug. so far only the "nue zigbee switch"

Maybe @mike.maxwell can throw something into the conversation here.... Can you post the screenshot of the fingerprint of the device?

Use this driver ...


this driver gives the same results. switching not working and no metering....
I tried 2 plugs on 2 different hubitat c7 hubs.

Most tuya (the non zigbee 3.0 versions) device implementations do not follow the Zigbee Home Automation spec, for this reason as well as general availability issues they aren't currently compatible with the inbuilt Hubitat drivers.

1 Like

they claim to use the zigbee 3.0 protocol on the website and according to the manual in the box

Can you post the Device Details ''Data" section?

Also, please switch on the 'Enable debug logging' option, then manually switch the plug on / off from the device knob and copy/paste the debug information from the HE logs page.

If that is indeed the case for the device you have in hand then it would work with the generic zigbee outlet driver.

1 Like

dev:2722021-12-24 18:08:41.311 infotest tuya : Switch : On

dev:2722021-12-24 18:08:41.306 debugtest tuya : Parse : read attr - raw: 058F0100060800001001, dni: 058F, endpoint: 01, cluster: 0006, size: 08, attrId: 0000, encoding: 10, command: 0A, value: 01

dev:2722021-12-24 18:08:40.411 infotest tuya : Switch : Off

dev:2722021-12-24 18:08:40.404 debugtest tuya : Parse : read attr - raw: 058F0100060800001000, dni: 058F, endpoint: 01, cluster: 0006, size: 08, attrId: 0000, encoding: 10, command: 0A, value: 00

switch on and off on the device itself

Seems like a standard on/off reporting... the switch on/off status should be reported correctly with the Generic zigbee outlet driver?

Please do the following:

  1. Make sure the device is configured to use the "Tuya Zigbee Metyering Plug" driver.

  2. Delete the device by pressing the "Remove Device" red button on the device page bottom right corner,

  3. Pair the device again. When the device is discovered, press the 'more' link:

  4. Copy/paste all the information, like in this screenshot:

  5. After saving the detailed device information, press the Save button..

In the AliExpress link that you provided a customer states that this smart plug works with the latest zigbee2mqtt development version, so there shouldn't be a reason to not make it work with HE as well.

2 Likes

thanks for the extended reply.
It was recognized as a


For this plug it is not working.

For an older (also tuya) I have this trick worked fine, so thanks for that

1 Like

@aren there is the xiaomi/aquara motion sensor driver in HPM available. Try that (obviously after installing and switching to the driver, click save then configure..) See if that works for you

I don't understand what you mean. My power plug is recognized as a xiaomi motion sensor. How can another motion sensor driver help me?
I am looking for a driver to switch my power plug on and off, and read my power usage. If I am misreading your reply, please correct me

@aren In hubitat package manager there is a community driver made specifically for that device which may give you what you want.

Weird. From the clusters shown, it should work with the Tuya Zigbee Metering Plug driver written by @kkossev.

@aren I have added your device fingerprint as "Tuya / Neo NAS-WR01" in version 1.1.2 of "Tuya Zigbee Metering Plug" driver. You can update it from HPM or directly from this link.

Please hit the 'Configure' button after updating the driver. Also, make sure your device is actually using this driver:

If after updating and Configuring again the On/Off commands and power/energy readings still do not work, please re-pair the device again to HE hub. I think that repairing again should not be needed, as this is a mains powered zigbee device and the configuration commands should be accepted almost immediately.

@aaiyar The problem seems to be that Markus's driver has the same inClusers and outClusters list, and his driver is selected automatically during the pairing process (probably because this driver was installed earlier than the Tuya driber). Now when this specific device inClusters, outClusters, mode, and manufacturer matches exactly the fingerprint in my driver it should be selected automatically when paired, instead of partially matching Markus driver.

2 Likes

@kkossev thanks for the effort. but I get the same results. these are strange plugs. after changing the driver to your new version. I did not work. I removed the device and re-added it. It was again recognized as a xiaomi sensor. I changed to your driver pressed configure and rebooted the hub. still not working. I checked to see that I use the latest version off the driver. I use 1.1.2.

@aren I think that with a few more iterations we should get it working...

The first problem to solve is to match the correct driver during the pairing process, I see now why my driver fingerprint was not matching - the inClusters list of your device is "0003,0004,0005,0006,0702,0B04,E000,E001,0000", while my device is "0000,0003,0004,0005,0006,0702,0B04,E000,E001". It is one and the same set of clusters, but the two different devices report and HE stores them in a different order. So the simple inClusters string comparison fails. Although the above does not explain why Markus 'Zigbee - Xiaomi/Aqara Motion Sensor' driver is selected instead, the fingerprints there are very different than this Tuya plug...

Just to be sure, can you temporarily change the Tuya plug driver to a "Device" type?
image

Then press the "Get Info" button, copy/paste the text logs for and send the text to me.
Should look like this:

dev:12932021-12-25 16:09:37.293 infofingerprint profileId:"0104", endpointId:"01", inClusters:"0000,0003,0004,0005,0006,0702,0B04,E000,E001", outClusters:"0019,000A", model:"TS011F", manufacturer:"_TZ3000_cphmq0q7"

dev:12932021-12-25 16:09:37.197 traceZCL version:03

dev:12932021-12-25 16:09:37.193 traceSoftware Build Id:unknown

dev:12932021-12-25 16:09:37.188 traceModel:TS011F

dev:12932021-12-25 16:09:37.184 traceManufacturer:_TZ3000_cphmq0q7

dev:12932021-12-25 16:09:36.968 debuggetting info for unknown Zigbee device...

The second problem is that most probably the switch on/off commands are sent to the wrong endpoint/ProfileID (the Zigbee 3.0 'Green Power')... This could be detected and prevented in a future driver version, but I hope that once the correct driver is picked up during the initial pairing process, it will start working OK. At least this was the solution for a similar Tuya plug a month ago.

1 Like

Download the Hubitat app